aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2007-03-05 14:11:39 +0000
committerDiane Bruce <db@FreeBSD.org>2007-03-05 14:11:39 +0000
commit3ed4bb20aae306897158cb4bd0d66b71ad4b4304 (patch)
tree62f1d2a0208fd639c4db24d28a9de9082fb18d14 /comms/trustedqsl
parentb637188afc1a43e2d0e32f6624bde19d85bb1848 (diff)
downloadports-3ed4bb20aae306897158cb4bd0d66b71ad4b4304.tar.gz
ports-3ed4bb20aae306897158cb4bd0d66b71ad4b4304.zip
Notes
Diffstat (limited to 'comms/trustedqsl')
-rw-r--r--comms/trustedqsl/Makefile2
-rw-r--r--comms/trustedqsl/files/Makefile2
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_configure42
3 files changed, 44 insertions, 2 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index 91bddc8c8ac2..e183766c1c3e 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_PERL5= yes
USE_GETOPT_LONG= yes
USE_WX= 2.6
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
MAKE_ENV= INCDIR="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/comms/trustedqsl/files/Makefile b/comms/trustedqsl/files/Makefile
index 203a0cd9b84c..44491f14b104 100644
--- a/comms/trustedqsl/files/Makefile
+++ b/comms/trustedqsl/files/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
all:
- (cd tqsllib-2.0;./configure --with-wxwindows=${WX_CONFIG};make;make converter;make gen_crq;make load_cert;make station_loc)
+ (cd tqsllib-2.0;./configure --with-wxwindows=${WX_CONFIG};make;make converter;make gen_crq;make load_cert;make station_loc;make)
(cd TrustedQSL-1.11;make)
install:
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_configure b/comms/trustedqsl/files/patch-tqsllib-2.0_configure
new file mode 100644
index 000000000000..e85383ddf3e1
--- /dev/null
+++ b/comms/trustedqsl/files/patch-tqsllib-2.0_configure
@@ -0,0 +1,42 @@
+--- tqsllib-2.0/configure.orig Fri Mar 11 07:50:44 2005
++++ tqsllib-2.0/configure Tue Feb 27 22:27:07 2007
+@@ -7793,8 +7793,7 @@
+ ;;
+
+ freebsd*)
+- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+- version_type=freebsd-$objformat
++ version_type=freebsd-elf
+ case $version_type in
+ freebsd-elf*)
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+@@ -11512,8 +11511,7 @@
+ ;;
+
+ freebsd*)
+- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+- version_type=freebsd-$objformat
++ version_type=freebsd-elf
+ case $version_type in
+ freebsd-elf*)
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+@@ -14682,8 +14680,7 @@
+ ;;
+
+ freebsd*)
+- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+- version_type=freebsd-$objformat
++ version_type=freebsd-elf
+ case $version_type in
+ freebsd-elf*)
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'
+@@ -17050,8 +17047,7 @@
+ ;;
+
+ freebsd*)
+- objformat=`test -x /usr/bin/objformat && /usr/bin/objformat || echo aout`
+- version_type=freebsd-$objformat
++ version_type=freebsd-elf
+ case $version_type in
+ freebsd-elf*)
+ library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext} $libname${shared_ext}'