aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-12-01 07:39:02 +0000
commitd750615763ee2d3250de2115295079f66d813d1f (patch)
tree05b94e79be3ac272b9b617e50fc723ea52c6cf34 /comms/trustedqsl
parent767bcfc72cf9c3574739d745cff6620fa75b0e74 (diff)
downloadports-d750615763ee2d3250de2115295079f66d813d1f.tar.gz
ports-d750615763ee2d3250de2115295079f66d813d1f.zip
Notes
Diffstat (limited to 'comms/trustedqsl')
-rw-r--r--comms/trustedqsl/Makefile4
-rw-r--r--comms/trustedqsl/files/Makefile2
-rw-r--r--comms/trustedqsl/files/Makefile.TrustedQSL-1.114
3 files changed, 5 insertions, 5 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index 09c8cbf143e4..ee750b61cf9b 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -16,11 +16,11 @@ DISTFILES= tqsllib-2.0.tar.gz TrustedQSL-1.11.tar.gz
MAINTAINER= db@db.net
COMMENT= Amateur Radio Station electronic trusted logbook
-LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
- wx_base-2.6:${PORTSDIR}/x11-toolkits/wxgtk26
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_PERL5= yes
USE_GETOPT_LONG= yes
+USE_WX= 2.6
INSTALLS_SHLIB= yes
MAKE_ENV= INCDIR="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/comms/trustedqsl/files/Makefile b/comms/trustedqsl/files/Makefile
index 8496fa12b0a0..203a0cd9b84c 100644
--- a/comms/trustedqsl/files/Makefile
+++ b/comms/trustedqsl/files/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
all:
- (cd tqsllib-2.0;./configure --with-wxwindows=${X11BASE}/bin/wxgtk2-2.6-config;make;make converter;make gen_crq;make load_cert;make station_loc)
+ (cd tqsllib-2.0;./configure --with-wxwindows=${WX_CONFIG};make;make converter;make gen_crq;make load_cert;make station_loc)
(cd TrustedQSL-1.11;make)
install:
diff --git a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11 b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
index 46d15dd72e27..e4088bc751fa 100644
--- a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
+++ b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
@@ -5,8 +5,8 @@ TQSL_VERSION_MINOR = 0
LIBS=-lz -lexpat -lcrypto
INCDIR = -I$(TQSLINC)
BUILD = unofficial
-WXFLAGS=`wxgtk2-2.6-config --cflags`
-WXLIBS=`wxgtk2-2.6-config --libs`
+WXFLAGS=`${WX_CONFIG} --cflags`
+WXLIBS=`${WX_CONFIG} --libs`
DEFS = -DHAVE_CONFIG_H
CXXFLAGS += $(DEFS) $(INCDIR) -DHAVE_LIBCRYPTO=1 -DSTDC_HEADERS=1 -DHAVE_MKDIR=1 -DHAVE_STRERROR=1 $(WXFLAGS)