aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-05-09 21:16:56 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-05-09 21:16:56 +0000
commit0a96d78e357e216aec1367734535f6a3a28352f5 (patch)
tree3d0bb6b279d58408460351032649b802a5cd20d1 /comms/trustedqsl
parente945f71e7d2621237e617f602ba6c7a8febe5bb1 (diff)
downloadports-0a96d78e357e216aec1367734535f6a3a28352f5.tar.gz
ports-0a96d78e357e216aec1367734535f6a3a28352f5.zip
Notes
Diffstat (limited to 'comms/trustedqsl')
-rw-r--r--comms/trustedqsl/files/Makefile6
-rw-r--r--comms/trustedqsl/files/Makefile.TrustedQSL-1.1112
2 files changed, 9 insertions, 9 deletions
diff --git a/comms/trustedqsl/files/Makefile b/comms/trustedqsl/files/Makefile
index 553f160a83dd..8496fa12b0a0 100644
--- a/comms/trustedqsl/files/Makefile
+++ b/comms/trustedqsl/files/Makefile
@@ -1,9 +1,11 @@
# $FreeBSD$
all:
- (cd tqsllib;make)
+ (cd tqsllib-2.0;./configure --with-wxwindows=${X11BASE}/bin/wxgtk2-2.6-config;make;make converter;make gen_crq;make load_cert;make station_loc)
(cd TrustedQSL-1.11;make)
install:
- (cd tqsllib;make install)
+ (cd tqsllib-2.0;make install)
+ (cd tqsllib-2.0/.libs; \
+ %%INSTALL%% converter gen_crq load_cert station_loc %%PREFIX%%/bin)
(cd TrustedQSL-1.11;make install)
diff --git a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11 b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
index d8527c17b62f..46d15dd72e27 100644
--- a/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
+++ b/comms/trustedqsl/files/Makefile.TrustedQSL-1.11
@@ -1,8 +1,7 @@
-TQSLLIB=../tqsllib
-TQSLINC=../tqsllib
-TQSL_VERSION_MAJOR = 1
-TQSL_VERSION_MINOR = 11
-OPENSSL=/usr/local
+TQSLLIB=../tqsllib-2.0/.libs
+TQSLINC=../tqsllib-2.0
+TQSL_VERSION_MAJOR = 2
+TQSL_VERSION_MINOR = 0
LIBS=-lz -lexpat -lcrypto
INCDIR = -I$(TQSLINC)
BUILD = unofficial
@@ -11,7 +10,7 @@ WXLIBS=`wxgtk2-2.6-config --libs`
DEFS = -DHAVE_CONFIG_H
CXXFLAGS += $(DEFS) $(INCDIR) -DHAVE_LIBCRYPTO=1 -DSTDC_HEADERS=1 -DHAVE_MKDIR=1 -DHAVE_STRERROR=1 $(WXFLAGS)
-LDLIBS = -L$(TQSLLIB) -L$(OPENSSL)/lib -ltqsllib $(LIBS) $(WXLIBS)
+LDLIBS = -L$(TQSLLIB) -ltqsllib $(LIBS) $(WXLIBS)
TQSLLIBFILE=$(TQSLLIB)/libtqsllib.a
CCDEPMODE = depmode=gcc3
BINDIR=${PREFIX}/bin
@@ -62,4 +61,3 @@ clean:
install:
${INSTALL} -d $(BINDIR) $(ETCDIR)/tqsl
${INSTALL} -C $(TARGETS) $(BINDIR)
- ${INSTALL} -C ../tqsllib/config.xml $(ETCDIR)/tqsl