aboutsummaryrefslogtreecommitdiff
path: root/comms/trustedqsl
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2006-05-09 05:51:15 +0000
committerAndrej Zverev <az@FreeBSD.org>2006-05-09 05:51:15 +0000
commit9cd5e2a10fcfb529b3544bcfaefeb246f9b32fb9 (patch)
tree73acd5ee1689cf17bfd102d62f33424151987cae /comms/trustedqsl
parent86836956e1907a56f17f557be17fdc3523cdef93 (diff)
downloadports-9cd5e2a10fcfb529b3544bcfaefeb246f9b32fb9.tar.gz
ports-9cd5e2a10fcfb529b3544bcfaefeb246f9b32fb9.zip
Notes
Diffstat (limited to 'comms/trustedqsl')
-rw-r--r--comms/trustedqsl/Makefile33
-rw-r--r--comms/trustedqsl/distinfo6
-rw-r--r--comms/trustedqsl/files/Makefile.tqsllib49
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in12
-rw-r--r--comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp11
-rw-r--r--comms/trustedqsl/files/sysconfig.h.tqsllib45
-rw-r--r--comms/trustedqsl/pkg-plist10
7 files changed, 59 insertions, 107 deletions
diff --git a/comms/trustedqsl/Makefile b/comms/trustedqsl/Makefile
index 3c4a2eae05ef..09c8cbf143e4 100644
--- a/comms/trustedqsl/Makefile
+++ b/comms/trustedqsl/Makefile
@@ -7,11 +7,11 @@
PORTNAME= trustedqsl
PORTVERSION= 1.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= trustedqsl
-DISTFILES= tqsllib-1.4.tar.gz TrustedQSL-1.11.tar.gz
+DISTFILES= tqsllib-2.0.tar.gz TrustedQSL-1.11.tar.gz
MAINTAINER= db@db.net
COMMENT= Amateur Radio Station electronic trusted logbook
@@ -21,6 +21,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
USE_PERL5= yes
USE_GETOPT_LONG= yes
+INSTALLS_SHLIB= yes
MAKE_ENV= INCDIR="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -28,15 +29,16 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "does not compile"
+BROKEN= can not build on 4.x
.endif
post-patch:
- ${CP} ${FILESDIR}/Makefile ${WRKSRC}
- ${CP} ${FILESDIR}/Makefile.tqsllib ${WRKSRC}/tqsllib/Makefile
- ${CP} ${FILESDIR}/Makefile.TrustedQSL-1.11 ${WRKSRC}/TrustedQSL-1.11/Makefile
- ${CP} ${FILESDIR}/sysconfig.h.tqsllib ${WRKSRC}/tqsllib/sysconfig.h
- ${CP} ${FILESDIR}/sysconfig.h.TrustedQSL-1.11 ${WRKSRC}/TrustedQSL-1.11/sysconfig.h
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+ @${REINPLACE_CMD} -e 's|%%INSTALL%%|${INSTALL_PROGRAM}|' \
+ -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/Makefile
+ @${CP} ${FILESDIR}/Makefile.TrustedQSL-1.11 ${WRKSRC}/TrustedQSL-1.11/Makefile
+ @${CP} ${FILESDIR}/sysconfig.h.TrustedQSL-1.11 ${WRKSRC}/TrustedQSL-1.11/sysconfig.h
do-extract:
@${RM} -rf ${WRKDIR}
@@ -50,11 +52,22 @@ do-extract:
done
post-install:
+ ${MKDIR} ${PREFIX}/etc/tqsl
+ ${INSTALL_DATA} ${WRKSRC}/tqsllib-2.0/config.xml ${PREFIX}/etc/tqsl/config.xml
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/tqslcert
@${MKDIR} ${PREFIX}/share/doc/tqslapp
- @${CP} ${WRKSRC}/TrustedQSL-1.11/help/tqslcert/* ${PREFIX}/share/doc/tqslcert/
- @${CP} ${WRKSRC}/TrustedQSL-1.11/help/tqslapp/* ${PREFIX}/share/doc/tqslapp/
+ @${INSTALL_DATA} ${WRKSRC}/TrustedQSL-1.11/help/tqslcert/* ${PREFIX}/share/doc/tqslcert/
+ @${INSTALL_DATA} ${WRKSRC}/TrustedQSL-1.11/help/tqslapp/* ${PREFIX}/share/doc/tqslapp/
+ @${INSTALL_DATA} ${WRKSRC}/tqsllib-2.0/LICENSE ${PREFIX}/share/doc/tqsllib
+ @${INSTALL_DATA} ${WRKSRC}/tqsllib-2.0/ChangeLog ${PREFIX}/share/doc/tqsllib
.endif
+ @${ECHO}
+ @${ECHO} trustedqsl is now installed.
+ @${ECHO} You will have to create a directory .tqsl in your
+ @${ECHO} home directory and setup a copy of
+ @${ECHO} ${PREFIX}/etc/tqsl/config.xml here
+ @${ECHO} before this program will run correctly.
+ @${ECHO}
.include <bsd.port.post.mk>
diff --git a/comms/trustedqsl/distinfo b/comms/trustedqsl/distinfo
index 6193c0db6d7c..591fab915cc0 100644
--- a/comms/trustedqsl/distinfo
+++ b/comms/trustedqsl/distinfo
@@ -1,6 +1,6 @@
-MD5 (tqsllib-1.4.tar.gz) = 008705afbf39f52e0984e195d32e8378
-SHA256 (tqsllib-1.4.tar.gz) = 3b21fa2734c95c872847c9ce81590cf34b97d48274f307cdf784eed57f76643c
-SIZE (tqsllib-1.4.tar.gz) = 160585
+MD5 (tqsllib-2.0.tar.gz) = eab6bcd6c93561881f68ef184456a193
+SHA256 (tqsllib-2.0.tar.gz) = 083c4405455c5b5a711e82275fe2b7106266bfc1edbd1a78ef542244e25909dc
+SIZE (tqsllib-2.0.tar.gz) = 433450
MD5 (TrustedQSL-1.11.tar.gz) = 2b39274763ec27823489f2eca975fdab
SHA256 (TrustedQSL-1.11.tar.gz) = 1b208e6f84602c161d936dae161e40b555ebc53883b4eda33d6e8f5fa84d68d9
SIZE (TrustedQSL-1.11.tar.gz) = 346049
diff --git a/comms/trustedqsl/files/Makefile.tqsllib b/comms/trustedqsl/files/Makefile.tqsllib
deleted file mode 100644
index 89bbe3851aaa..000000000000
--- a/comms/trustedqsl/files/Makefile.tqsllib
+++ /dev/null
@@ -1,49 +0,0 @@
-CXX = g++
-CC ?= gcc
-LIBS=-lcrypto -lexpat
-CXXFLAGS += -I. -I${LOCALBASE}/include -DHAVE_CONFIG_H
-LDFLAGS = -L. $(LIBS) -L${LOCALBASE}/lib -lstdc++
-TARGETS = gen_crq load_cert station_loc dumptqsldata converter
-ZLIB=z
-MYLIB=tqsllib
-
-OBJS= tqsllib.o openssl_cert.o adif.o xml.o\
- location.o tqslconvert.o cabrillo.o
-
-all: $(TARGETS)
-
-gen_crq: gen_crq.o lib$(MYLIB).a
- ${CXX} -o gen_crq gen_crq.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-load_cert: load_cert.o lib$(MYLIB).a
- ${CXX} -o load_cert load_cert.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-converter: converter.o lib$(MYLIB).a
- ${CXX} -o converter converter.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-station_loc: station_loc.o lib$(MYLIB).a
- ${CXX} -o station_loc station_loc.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-dumptqsldata: dumptqsldata.o lib$(MYLIB).a
- ${CXX} -o dumptqsldata dumptqsldata.o -l$(MYLIB) $(LDFLAGS) -l$(ZLIB)
-
-include tqsllib.depends
-
-libtqsllib.a: $(OBJS)
- ${AR} qc libtqsllib.a ${OBJS}
-
-install:
- ${INSTALL} gen_crq ${PREFIX}/bin
- ${INSTALL} load_cert ${PREFIX}/bin
- ${INSTALL} converter ${PREFIX}/bin
- ${INSTALL} station_loc ${PREFIX}/bin
- ${INSTALL} dumptqsldata ${PREFIX}/bin
-
-clean:
- rm -f converter dumptqsldata gen_crq load_cert station_loc
- rm -f *.o *.lo *.a *.la *~ xxx.* *.a
- rm -rf .libs
-
-%.o: %.cpp
- ${CXX} ${CXXFLAGS} -c -o $@ $*.cpp
-
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in b/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in
new file mode 100644
index 000000000000..cb99bde9bb20
--- /dev/null
+++ b/comms/trustedqsl/files/patch-tqsllib-2.0_Makefile.in
@@ -0,0 +1,12 @@
+--- tqsllib-2.0/Makefile.in.orig Fri Mar 11 07:58:31 2005
++++ tqsllib-2.0/Makefile.in Tue Apr 18 15:53:02 2006
+@@ -767,8 +767,7 @@
+
+ info-am:
+
+-install-data-am: install-dataDATA install-docDATA \
+- install-includeHEADERS
++install-data-am: install-includeHEADERS
+
+ install-exec-am: install-binPROGRAMS install-exec-local \
+ install-libLIBRARIES install-libLTLIBRARIES
diff --git a/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp b/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp
new file mode 100644
index 000000000000..b703c45c52f5
--- /dev/null
+++ b/comms/trustedqsl/files/patch-tqsllib-2.0_openssl_cert.cpp
@@ -0,0 +1,11 @@
+--- tqsllib-2.0/openssl_cert.cpp.orig Fri Mar 11 07:47:11 2005
++++ tqsllib-2.0/openssl_cert.cpp Wed Mar 29 11:27:41 2006
+@@ -1290,6 +1290,8 @@
+ attrib->set = 1;
+ #elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00907000
+ attrib->single = 0;
++#elif (OPENSSL_VERSION_NUMBER & 0xfffff000) == 0x00908000
++ attrib->single = 0;
+ #else
+ #error "Unexpected OpenSSL version; check X509_ATTRIBUTE struct compatibility"
+ #endif
diff --git a/comms/trustedqsl/files/sysconfig.h.tqsllib b/comms/trustedqsl/files/sysconfig.h.tqsllib
deleted file mode 100644
index de7c9c9b2d01..000000000000
--- a/comms/trustedqsl/files/sysconfig.h.tqsllib
+++ /dev/null
@@ -1,45 +0,0 @@
-/* tqsllib/sysconfig.h. Generated automatically by configure. */
-/* lotwdb/sysconfig.h.in. Generated automatically from configure.in by autoheader. */
-
-/* Define to empty if the keyword does not work. */
-/* #undef const */
-
-/* Define to `int' if <sys/types.h> doesn't define. */
-/* #undef mode_t */
-
-/* Define if you have the ANSI C header files. */
-#define STDC_HEADERS 1
-
-/* Define if your <sys/time.h> declares struct tm. */
-/* #undef TM_IN_SYS_TIME */
-
-/* Defined if this is LOTW server code */
-#undef LOTW_SERVER
-
-/* Define if you have the mkdir function. */
-#define HAVE_MKDIR 1
-
-/* Define if you have the strerror function. */
-#define HAVE_STRERROR 1
-
-/* Define if you have the snprintf function. */
-#define HAVE_SNPRINTF 1
-
-/* Define if you have the <unistd.h> header file. */
-#define HAVE_UNISTD_H 1
-
-/* Define if you have the <getopt.h> header file. */
-#define HAVE_GETOPT_H
-
-/* Define if you have the crypto library (-lcrypto). */
-#define HAVE_LIBCRYPTO 1
-
-/* Define if you have the dl library (-ldl). */
-#define HAVE_LIBDL 1
-
-/* Define if you have the pcrl library (-lpcrl). */
-#undef HAVE_LIBPCRL
-
-/* Define if you have the sqlca library (-lsqlca). */
-#undef HAVE_LIBSQLCA
-
diff --git a/comms/trustedqsl/pkg-plist b/comms/trustedqsl/pkg-plist
index f8810b394a9f..97755d45d924 100644
--- a/comms/trustedqsl/pkg-plist
+++ b/comms/trustedqsl/pkg-plist
@@ -6,6 +6,15 @@ bin/station_loc
bin/tqsl
bin/tqslcert
etc/tqsl/config.xml
+include/tqsllib.h
+include/tqslerrno.h
+include/cabrillo.h
+include/adif.h
+include/tqslconvert.h
+lib/libtqsllib.so.1
+lib/libtqsllib.so
+lib/libtqsllib.la
+lib/libtqsllib.a
%%PORTDOCS%%share/doc/tqslapp/addcont.bmp
%%PORTDOCS%%share/doc/tqslapp/addstnl.bmp
%%PORTDOCS%%share/doc/tqslapp/addstnl0.bmp
@@ -69,6 +78,7 @@ etc/tqsl/config.xml
%%PORTDOCS%%share/doc/tqslcert/tqslcert.hhp
%%PORTDOCS%%share/doc/tqslcert/unlock.bmp
%%PORTDOCS%%share/doc/tqslcert/unlock.htm
+%%PORTDOCS%%share/doc/tqsllib
%%PORTDOCS%%@dirrm share/doc/tqslcert
%%PORTDOCS%%@dirrm share/doc/tqslapp
@dirrm etc/tqsl