aboutsummaryrefslogtreecommitdiff
path: root/comms/uartlirc/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2012-05-13 16:06:05 +0000
committerJuergen Lock <nox@FreeBSD.org>2012-05-13 16:06:05 +0000
commit6a1d7c932a5e0648085597022e2ded39f9fff06f (patch)
tree47ee1dde4077215141f2aec641b7395ff6e08be6 /comms/uartlirc/Makefile
parenteed462d207c60b5601e10f4a8e3e32ffcab36e73 (diff)
Notes
Diffstat (limited to 'comms/uartlirc/Makefile')
-rw-r--r--comms/uartlirc/Makefile53
1 files changed, 53 insertions, 0 deletions
diff --git a/comms/uartlirc/Makefile b/comms/uartlirc/Makefile
new file mode 100644
index 000000000000..eedaa69a05e7
--- /dev/null
+++ b/comms/uartlirc/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: uarlirc
+# Date created: Sun May 13 17:39:40 CEST 2012
+# Whom: nox@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= uartlirc
+PORTVERSION= 0.3
+CATEGORIES= comms kld
+MASTER_SITES= LOCAL/nox \
+ http://people.freebsd.org/~nox/tmp/
+DISTNAME= ${PORTNAME}-preliminary-003
+EXTRACT_SUFX= .shar
+
+MAINTAINER= nox@FreeBSD.org
+COMMENT= Driver for "homebrew" serial LIRC receivers
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+EXTRACT_CMD= ${SH}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS=
+
+.include <bsd.port.pre.mk>
+
+PLIST_FILES+= "@cwd /"
+PLIST_FILES+= ${KMODDIR:C,^/,,}/${PORTNAME}.ko
+PLIST_FILES+= "@exec kldxref ${KMODDIR}"
+PLIST_FILES+= "@unexec kldxref ${KMODDIR}"
+
+# install where x11/nvidia-driver does also:
+KMODDIR= /boot/modules
+
+MAKE_ENV+= KMODDIR="${KMODDIR}"
+
+SYSDIR?= ${SRC_BASE}/sys
+MAKE_ENV+= SYSDIR="${SYSDIR}"
+
+CFLAGS+= ${DEBUG_FLAGS}
+
+.if ${OSVERSION} < 800000
+IGNORE= needs <sys/buf_ring.h>
+.endif
+
+.if !exists(${SYSDIR}/Makefile)
+IGNORE= requires kernel source to be installed
+.endif
+
+do-install:
+ ${INSTALL} ${WRKSRC}/${PORTNAME}.ko ${KMODDIR}
+ kldxref ${KMODDIR}
+
+.include <bsd.port.post.mk>