aboutsummaryrefslogtreecommitdiff
path: root/comms/usbmuxd
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2014-09-28 22:58:51 +0000
committerAlberto Villa <avilla@FreeBSD.org>2014-09-28 22:58:51 +0000
commitc6c79da969e63a1b59f318e5e20c9a2475290bf2 (patch)
tree3519e27224702b200392e2556264193fb94f359e /comms/usbmuxd
parent0393573f88dd44a26be995caa3ce8ef85916f214 (diff)
downloadports-c6c79da969e63a1b59f318e5e20c9a2475290bf2.tar.gz
ports-c6c79da969e63a1b59f318e5e20c9a2475290bf2.zip
Notes
Diffstat (limited to 'comms/usbmuxd')
-rw-r--r--comms/usbmuxd/Makefile52
-rw-r--r--comms/usbmuxd/distinfo4
-rw-r--r--comms/usbmuxd/files/patch-Modules__FindInotify.cmake30
-rw-r--r--comms/usbmuxd/files/patch-libusbmuxd__CMakeLists.txt26
-rw-r--r--comms/usbmuxd/pkg-plist11
5 files changed, 24 insertions, 99 deletions
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
index af4a3675f06f..f78c98427c31 100644
--- a/comms/usbmuxd/Makefile
+++ b/comms/usbmuxd/Makefile
@@ -1,50 +1,42 @@
# $FreeBSD$
PORTNAME= usbmuxd
-PORTVERSION= 1.0.8
+DISTVERSION= 1.0.9-alpha1
CATEGORIES= comms
-MASTER_SITES= http://www.libimobiledevice.org/downloads/
MAINTAINER= avilla@FreeBSD.org
COMMENT= Daemon for multiplexing connections over USB to iPhone/iPod Touch
-LIB_DEPENDS= libplist.so:${PORTSDIR}/devel/libplist
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
-USES= cmake pkgconfig tar:bzip2
-USE_LDCONFIG= yes
+LIB_DEPENDS= libplist.so:${PORTSDIR}/devel/libplist \
+ libimobiledevice.so:${PORTSDIR}/comms/libimobiledevice
-PORTDOCS= AUTHORS README README.devel
+USE_GITHUB= yes
+GH_ACCOUNT= libimobiledevice
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 2f6d9d5
-OPTIONS_DEFINE= INOTIFY
+USES= autoreconf libtool:build pathfix pkgconfig tar:bzip2
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --without-systemd \
+ libusb_CFLAGS="-I/usr/include" \
+ libusb_LIBS="-lusb"
-INOTIFY_DESC= Use inotify instead of polling (saves energy)
+PLIST_FILES= sbin/usbmuxd
-.include <bsd.port.options.mk>
+PORTDOCS= AUTHORS README
-.if ${PORT_OPTIONS:MINOTIFY}
-LIB_DEPENDS+= libinotify.so:${PORTSDIR}/devel/libinotify
-CMAKE_ARGS+= -DWANT_INOTIFY:BOOL=TRUE
-.else
-CMAKE_ARGS+= -DWANT_INOTIFY:BOOL=FALSE
-.endif
+OPTIONS_DEFINE= DOCS
-.if ${OSVERSION} <= 800107 || ${OSVERSION} >= 900000 && ${OSVERSION} <= 900002
-IGNORE= requires libusb 1.0.3
-.endif
-
-post-patch:
- @${REINPLACE_CMD} -e 's,$${LIB_SUFFIX}/pkgconfig,data/pkgconfig,' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
- ${WRKSRC}/Modules/FindInotify.cmake
-
-pre-install:
- @${REINPLACE_CMD} -e '1 s,python,env python,' \
- ${WRKSRC}/python-client/*.py
+pre-configure:
+# TODO: add devd(8) rule.
+ @${REINPLACE_CMD} -e 's,-lpthread,-pthread,g' \
+ -e '/*cygwin*/ s,),|*bsd*),' \
+ ${WRKSRC}/configure.ac
post-install:
- @${MKDIR} ${STAGEDIR}${DATADIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/python-client/*.py ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
diff --git a/comms/usbmuxd/distinfo b/comms/usbmuxd/distinfo
index 805952157c6d..9b4b5ae12d22 100644
--- a/comms/usbmuxd/distinfo
+++ b/comms/usbmuxd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (usbmuxd-1.0.8.tar.bz2) = 899d63cb7915ee844f1d3d651bee06f3dbb862cebca849f0a57f27a0fdfcba5c
-SIZE (usbmuxd-1.0.8.tar.bz2) = 59347
+SHA256 (usbmuxd-1.0.9-alpha1.tar.bz2) = f19583d56899e60cc71e31144ade77008a196333e7f343853144802742fb6c66
+SIZE (usbmuxd-1.0.9-alpha1.tar.bz2) = 55916
diff --git a/comms/usbmuxd/files/patch-Modules__FindInotify.cmake b/comms/usbmuxd/files/patch-Modules__FindInotify.cmake
deleted file mode 100644
index c1f4b25798ec..000000000000
--- a/comms/usbmuxd/files/patch-Modules__FindInotify.cmake
+++ /dev/null
@@ -1,30 +0,0 @@
---- ./Modules/FindInotify.cmake.orig 2012-04-18 16:08:32.799038053 +0200
-+++ ./Modules/FindInotify.cmake 2012-04-18 16:18:43.588979805 +0200
-@@ -1,11 +1,20 @@
--set(INOTIFY_H "NOTFOUND")
--find_file(INOTIFY_H
-- "sys/inotify.h"
-- PATHS ENV INCLUDE
-+find_path(INOTIFY_INCLUDE_DIR
-+ NAMES sys/inotify.h
-+ PATHS
-+ /usr/local/include
-+ /usr/include
- )
-
--if (INOTIFY_H)
-+find_library(INOTIFY_LIBRARY
-+ NAMES inotify
-+ PATHS
-+ /usr/local/lib
-+ /usr/lib
-+ /lib
-+)
-+
-+if(INOTIFY_INCLUDE_DIR AND INOTIFY_LIBRARY)
- set(INOTIFY_FOUND TRUE)
--else()
-+else(INOTIFY_INCLUDE_DIR AND INOTIFY_LIBRARY)
- set(INOTIFY_FOUND FALSE)
--endif()
-+endif(INOTIFY_INCLUDE_DIR AND INOTIFY_LIBRARY)
diff --git a/comms/usbmuxd/files/patch-libusbmuxd__CMakeLists.txt b/comms/usbmuxd/files/patch-libusbmuxd__CMakeLists.txt
deleted file mode 100644
index 577b5c193eb6..000000000000
--- a/comms/usbmuxd/files/patch-libusbmuxd__CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
---- ./libusbmuxd/CMakeLists.txt.orig 2012-04-18 16:20:48.468900320 +0200
-+++ ./libusbmuxd/CMakeLists.txt 2012-04-18 16:27:25.439000508 +0200
-@@ -2,17 +2,20 @@
- find_package(Threads)
-
- option(WANT_INOTIFY "Build with inotify support" ON)
-+
-+add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
-+find_library (PTHREAD pthread)
-+
- if (WANT_INOTIFY)
- find_package(Inotify)
- if (INOTIFY_FOUND)
- add_definitions("-DHAVE_INOTIFY")
-+ include_directories(${INOTIFY_INCLUDE_DIR})
-+ target_link_libraries(libusbmuxd ${INOTIFY_LIBRARY})
- message("-- libusbmuxd will be built with inotify support")
- endif()
- endif(WANT_INOTIFY)
-
--add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
--find_library (PTHREAD pthread)
--
- if (HAVE_PLIST)
- add_definitions("-DHAVE_PLIST")
- message("-- libusbmuxd will be built with protocol version 1 support")
diff --git a/comms/usbmuxd/pkg-plist b/comms/usbmuxd/pkg-plist
deleted file mode 100644
index 56e50bf024ff..000000000000
--- a/comms/usbmuxd/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-bin/iproxy
-include/usbmuxd-proto.h
-include/usbmuxd.h
-lib/libusbmuxd.so
-lib/libusbmuxd.so.1.0.8
-lib/libusbmuxd.so.2
-libdata/pkgconfig/libusbmuxd.pc
-sbin/usbmuxd
-%%DATADIR%%/tcprelay.py
-%%DATADIR%%/usbmux.py
-@dirrm %%DATADIR%%