aboutsummaryrefslogtreecommitdiff
path: root/comms/uticom
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-24 11:49:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-24 11:49:37 +0000
commit1c9dca221a90bcf74d9f355826ab4d1fcbe43f11 (patch)
tree938a8d09e83921554ad64adbc502b999812450c8 /comms/uticom
parentdd5f0bf0844b2d46d840ee18e2f529a8466ef092 (diff)
downloadports-1c9dca221a90bcf74d9f355826ab4d1fcbe43f11.tar.gz
ports-1c9dca221a90bcf74d9f355826ab4d1fcbe43f11.zip
Notes
Diffstat (limited to 'comms/uticom')
-rw-r--r--comms/uticom/Makefile38
-rw-r--r--comms/uticom/distinfo2
-rw-r--r--comms/uticom/pkg-descr3
-rw-r--r--comms/uticom/pkg-plist1
4 files changed, 44 insertions, 0 deletions
diff --git a/comms/uticom/Makefile b/comms/uticom/Makefile
new file mode 100644
index 000000000000..76e61d7554d1
--- /dev/null
+++ b/comms/uticom/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: uticom
+# Date created: 17-10-2005
+# Whom: Dmitry Komissaroff <dxi@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= uticom
+PORTVERSION= 0.1
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= uticom-${PORTVERSION}
+
+MAINTAINER= dxi@mail.ru
+COMMENT= A FreeBSD Driver for TUSB3410 uart-to-usb converter
+
+NO_PACKAGE= "Should be in sync with the kernel to work correctly"
+
+ONLY_FOR_ARCHS= i386
+SRCPREFIX?= /usr/src
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+LOCALBASE= /boot/kernel
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD < 5.0 are not supported
+.endif
+
+# Make sure kernel sources are present before going any further
+.if ! exists(${SRCPREFIX}/sys/dev/usb/usb.c)
+IGNORE= You need to extract kernel source tree before building this package
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/uticom/distinfo b/comms/uticom/distinfo
new file mode 100644
index 000000000000..bd09634ceca4
--- /dev/null
+++ b/comms/uticom/distinfo
@@ -0,0 +1,2 @@
+MD5 (uticom-0.1.tar.gz) = c59c6bca627a5aa546d476ee25f510c1
+SIZE (uticom-0.1.tar.gz) = 14552
diff --git a/comms/uticom/pkg-descr b/comms/uticom/pkg-descr
new file mode 100644
index 000000000000..4116cb2821cb
--- /dev/null
+++ b/comms/uticom/pkg-descr
@@ -0,0 +1,3 @@
+FreeBSD Driver for TUSB3410 uart-to-usb converter.
+
+WWW: http://sf.net/projects/uticom
diff --git a/comms/uticom/pkg-plist b/comms/uticom/pkg-plist
new file mode 100644
index 000000000000..d2d381ac8ead
--- /dev/null
+++ b/comms/uticom/pkg-plist
@@ -0,0 +1 @@
+uticom.ko