aboutsummaryrefslogtreecommitdiff
path: root/comms/wsjt/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2007-02-25 02:37:44 +0000
committerDiane Bruce <db@FreeBSD.org>2007-02-25 02:37:44 +0000
commitbc31aba5aff9ad920b4c93f34886b9966640bb2d (patch)
tree8526f00344c00a8c6d69b8b159eabf4e111c2154 /comms/wsjt/Makefile
parent5676d104b10b9e877ba584cfe9a4619e93fd384a (diff)
Notes
Diffstat (limited to 'comms/wsjt/Makefile')
-rw-r--r--comms/wsjt/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index dabba7162150..9da56d76cb17 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wsjt
PORTVERSION= 5.9.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= wsjt
@@ -17,30 +17,27 @@ EXTRACT_SUFX= .tgz
MAINTAINER= db@FreeBSD.org
COMMENT= Weak signal ham radio communication pakage
-BUILD_DEPENDS= gfortran41:${PORTSDIR}/lang/gfortran \
- ${PYTHON_SITELIBDIR}/scipy:${PORTSDIR}/science/py-scipy03 \
- ${PYTHON_SITELIBDIR}/f2py2e:${PORTSDIR}/lang/f2py
-# ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSIDR}/x11-toolkits/py-tkinter
+BUILD_DEPENDS= gfortran42:${PORTSDIR}/lang/gcc42 \
+ ${PYTHON_SITELIBDIR}/scipy:${PORTSDIR}/science/py-scipy \
+ ${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2 \
+ ${PYNUMPY}
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter/ \
+ ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
LIB_DEPENDS= samplerate:${PORTSDIR}/audio/libsamplerate
-ONLY_FOR_ARCHS= i386
-ONLY_FOR_ARCHS_REASON= WIP for amd64 and perhaps others
-
+WANT_FORTRAN= yes #dummy
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_PYTHON= 2.4+
-PYNUMERIC= yes
USE_AUTOTOOLS= libtool:15
-#
-# This until Joe renames the tarball properly --db
-#
post-extract:
@${MV} ${WRKDIR}/wsjt596r309 ${WRKDIR}/wsjt-5.9.6.r309
-pre-configure:
- @${CP} ${FILESDIR}/portaudio-v19-Makefile ${WRKSRC}/portaudio-v19/Makefile
- @${CP} ${FILESDIR}/portaudio-v19-config.status ${WRKSRC}/portaudio-v19/config.status
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/configure
do-install:
@${MKDIR} ${DATADIR}