aboutsummaryrefslogtreecommitdiff
path: root/comms/wsjt/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2012-02-10 13:15:13 +0000
committerDiane Bruce <db@FreeBSD.org>2012-02-10 13:15:13 +0000
commit73aa2aa3f21125774fd5913b8eafa8b15c52ba02 (patch)
tree9427fc15d4379ae18b0065194905d931f2246e10 /comms/wsjt/Makefile
parent662a0abff499ebcb040d24e501aa2a1a4e62a914 (diff)
Notes
Diffstat (limited to 'comms/wsjt/Makefile')
-rw-r--r--comms/wsjt/Makefile49
1 files changed, 23 insertions, 26 deletions
diff --git a/comms/wsjt/Makefile b/comms/wsjt/Makefile
index 0a9cbc32d579..16576f71387a 100644
--- a/comms/wsjt/Makefile
+++ b/comms/wsjt/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= wsjt
-PORTVERSION= 7.04
-PORTREVISION= 4
+VERSION= 9.1
+DISTVERSION= ${VERSION}.r${SVN_REV}
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= db
@@ -24,10 +24,9 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/scipy:${PORTSDIR}/science/py-scipy \
${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2 \
${PYNUMPY}
-BROKEN= does not build
-
ALL_TARGET= build
USE_BZIP2= yes
+USE_GMAKE= yes
USE_FORTRAN= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gfortran --prefix=${LOCALBASE} \
@@ -38,46 +37,44 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_PYTHON= 2.5+
USE_AUTOTOOLS= libtool
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
- PORTVERSION=${PORTVERSION}
+ VERSION=${VERSION}
.include <bsd.port.pre.mk>
-post-configure:
- @${REINPLACE_CMD} -e 's|-Wl.*||' ${WRKSRC}/Makefile
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for d in ${WRKSRC}/WSJT_Quick_Reference.pdf ${WRKSRC}/WSJT_Source_Code.txt \
- ${WRKSRC}/WSJT_User_600.pdf ${WRKSRC}/UpdateHistory.txt \
- ${WRKSRC}/WSJT_Source_Code.txt ${WRKSRC}/LICENSE.TXT
- ${INSTALL_DATA} ${WRKSRC}/${d} ${DOCSDIR}
-.endfor
- @${ECHO}
- @${ECHO} "docs installed in ${DOCSDIR}"
- @${ECHO}
-.endif
- @${CAT} ${PKGMESSAGE}
.if defined(BOOTSTRAP)
-SVN_REV!= svn info http://svn.berlios.de/svnroot/repos/wsjt/trunk/ | ${GREP} Revision | cut -d' ' -f2
+SVN_REV!= svn info http://svn.code.sf.net/p/wsjt/code/trunk/ | ${GREP} Revision | cut -d' ' -f2
.else
.include "Makefile.svn_rev"
.endif
-.if defined(BOOTSTRAP)
+.if defined(BOOTSTRAP) || defined(SVN_FETCH)
FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
do-fetch:
${MKDIR} ${WRKDIR}
svn export -r ${SVN_REV} \
- http://svn.berlios.de/svnroot/repos/wsjt/trunk ${WRKSRC}
+ http://svn.code.sf.net/p/wsjt/code/trunk ${WRKDIR}/wsjt-r${SVN_REV}
cd ${WRKDIR};rm -f ${DISTNAME}/*.a ${DISTNAME}/*.lib ${DISTNAME}/*.dll;\
tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2 ${DISTNAME}
- echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
+ echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
.if ${USER} == db
scp ${DISTDIR}/${DISTNAME}.tar.bz2 \
- freefall.freebsd.org:public_distfiles/
+ freefall.freebsd.org:public_distfiles/
.endif
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for d in ${WRKSRC}/WSJT_Quick_Reference.pdf ${WRKSRC}/WSJT_Source_Code.txt \
+ ${WRKSRC}/WSJT_User_600.pdf ${WRKSRC}/UpdateHistory.txt \
+ ${WRKSRC}/WSJT_Source_Code.txt ${WRKSRC}/LICENSE.TXT
+ ${INSTALL_DATA} ${WRKSRC}/${d} ${DOCSDIR}
+.endfor
+ @${ECHO}
+ @${ECHO} "docs installed in ${DOCSDIR}"
+ @${ECHO}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>