aboutsummaryrefslogtreecommitdiff
path: root/comms/wspr
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-10-04 14:34:50 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-10-04 14:34:50 +0000
commit810bc9d8b32c016ab0392a892ee4be1791b4eecd (patch)
tree84625309cb0332e4f053b41df8ce3381ed2bfacb /comms/wspr
parent74161011c0d9cb110ae2a78d6087955a3f7f58ff (diff)
comms/wspr: switch from py-imaging to py-pillow
- USES python With hat: python Reviewed by: portmgr (bdrewery, implicit)
Notes
Notes: svn path=/head/; revision=369966
Diffstat (limited to 'comms/wspr')
-rw-r--r--comms/wspr/Makefile7
-rw-r--r--comms/wspr/files/patch-wspr.py11
2 files changed, 14 insertions, 4 deletions
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 389625560f1a..30f5ded7318c 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wspr
DISTVERSION= ${VERSION}.r${SVN_REV}
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= db
@@ -13,7 +13,7 @@ MAINTAINER= hamradio@FreeBSD.org
COMMENT= Weak signal for HF ham radio communication package
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter \
- ${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow
LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib \
libfftw3f.so:${PORTSDIR}/math/fftw3-float \
libsamplerate.so:${PORTSDIR}/audio/libsamplerate
@@ -21,7 +21,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/scipy:${PORTSDIR}/science/py-scipy \
${LOCALBASE}/lib/portaudio2/libportaudio.so:${PORTSDIR}/audio/portaudio2 \
${PYNUMPY}
-USES= fortran gmake libtool tar:bzip2
+USES= fortran gmake libtool python tar:bzip2
ALL_TARGET= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gfortran --prefix=${STAGEDIR}${LOCALBASE} \
@@ -29,7 +29,6 @@ CONFIGURE_ARGS= --enable-gfortran --prefix=${STAGEDIR}${LOCALBASE} \
--with-portaudio-lib-dir=${LOCALBASE}/lib/portaudio2
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_PYTHON= yes
MAKE_ENV+= PYTHONUSERBASE=${STAGEDIR}${PYTHONBASE}
PLIST_SUB= PYVER=${PYTHON_VERSION:S/python//} \
VERSION=${VERSION}
diff --git a/comms/wspr/files/patch-wspr.py b/comms/wspr/files/patch-wspr.py
new file mode 100644
index 000000000000..87c6e2021f03
--- /dev/null
+++ b/comms/wspr/files/patch-wspr.py
@@ -0,0 +1,11 @@
+--- wspr.py.orig 2014-10-04 14:29:49 UTC
++++ wspr.py
+@@ -14,7 +14,7 @@
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image, ImageTk, ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *