aboutsummaryrefslogtreecommitdiff
path: root/comms/wspr
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-12-16 02:58:47 +0000
committerDiane Bruce <db@FreeBSD.org>2014-12-16 02:58:47 +0000
commit4a50f64bed005f9a3474d315bff2094795c00365 (patch)
tree211f633ac3f86db3bcd7015a5ab93895d008470a /comms/wspr
parent1d3eebb51315c446f0e4175f9b09efbbf79a93b0 (diff)
Notes
Diffstat (limited to 'comms/wspr')
-rw-r--r--comms/wspr/Makefile2
-rw-r--r--comms/wspr/files/patch-WsprMode_specjt.py18
2 files changed, 15 insertions, 5 deletions
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index cd37b028d19b..3403a8252f1c 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wspr
DISTVERSION= ${VERSION}.r${SVN_REV}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= db
diff --git a/comms/wspr/files/patch-WsprMode_specjt.py b/comms/wspr/files/patch-WsprMode_specjt.py
index e991851916b8..bc7650c29904 100644
--- a/comms/wspr/files/patch-WsprMode_specjt.py
+++ b/comms/wspr/files/patch-WsprMode_specjt.py
@@ -1,6 +1,6 @@
---- WsprMod/specjt.py.orig 2014-12-14 19:17:21.630624057 -0500
-+++ WsprMod/specjt.py 2014-12-14 19:19:41.021613990 -0500
-@@ -34,10 +34,7 @@
+--- WsprMod/specjt.py.orig 2014-12-15 21:51:30.000000000 -0500
++++ WsprMod/specjt.py 2014-12-15 21:54:38.000000000 -0500
+@@ -34,10 +34,8 @@
import tkinter.messagebox
from . import w
@@ -8,7 +8,17 @@
- from numpy.oldnumeric import zeros, multiarray
-except:
- from Numeric import zeros, multiarray
-+from numpy import zeros, multiarray
++from numpy import zeros
++from numpy.core import multiarray
import Image, ImageTk, ImageDraw
from .palettes import colormapblue, colormapgray0, colormapHot, \
colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+@@ -94,7 +92,7 @@
+ ttot=0.0
+
+ c=Canvas()
+-a=zeros(225000,'s')
++##a=zeros(225000,'s')
+ im=Image.new('P',(750,300))
+ line0=Image.new('P',(750,1)) #Image fragment for top line of waterfall
+ draw=ImageDraw.Draw(im)