aboutsummaryrefslogtreecommitdiff
path: root/comms/xastir/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-25 05:24:30 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-25 05:24:30 +0000
commit0f7e123ec028e704cc4f8c370ab65c7b42180b39 (patch)
treef10c8e1421ca8ef8b65666c318e31268dcddf10e /comms/xastir/Makefile
parent29f39224bd0b06390a2aa3e5782b114112586374 (diff)
downloadports-0f7e123ec028e704cc4f8c370ab65c7b42180b39.tar.gz
ports-0f7e123ec028e704cc4f8c370ab65c7b42180b39.zip
Notes
Diffstat (limited to 'comms/xastir/Makefile')
-rw-r--r--comms/xastir/Makefile40
1 files changed, 35 insertions, 5 deletions
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
index 8e65a8074f87..7b229fab3ef8 100644
--- a/comms/xastir/Makefile
+++ b/comms/xastir/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xastir
-PORTVERSION= 1.4.1
+PORTVERSION= 1.5.0
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xastir
@@ -22,20 +22,27 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_MOTIF= yes
+USE_GETTEXT= yes
USE_REINPLACE= yes
MAN1= xastir.1
-PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
OPTIONS= SHAPELIB "Include Shapelib support" On \
- PCRE "Include Perl Compatible Regular Expression Support" On \
+ PCRE "Include Perl Compat Regular Expression Support" On \
DBFAWK "Include DBFAWK Support" On \
MAGICK "Include ImageMagick Support" On \
CURL "Include CURL Internet Image support" On \
GDAL "Include GDAL Support" Off \
GPSMAN "Include GPSMAN Support" Off \
FESTIVAL "Include Festival Voice Synthesis Support" Off \
+ RTREE "Enable spatial indexing of shapefiles" Off \
+ ERRORPOP "Send error popups to stderr" Off \
+ DB40 "Tiger Map Caching using Berkeley DB v4.0" Off \
+ DB41 "Tiger Map Caching using Berkeley DB v4.1" Off \
+ DB42 "Tiger Map Caching using Berkeley DB v4.2" Off \
+ DB43 "Tiger Map Caching using Berkeley DB v4.3" Off \
OPTCFLAGS "Use optimized CFLAGS (-O2 -pipe)" Off
.include <bsd.port.pre.mk>
@@ -88,6 +95,30 @@ LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
CONFIGURE_ARGS+= --without-gdal
.endif
+.if defined(WITH_RTREE)
+CONFIGURE_ARGS+= --with-rtree
+.endif
+
+.if defined(WITH_ERRORPOP)
+CONFIGURE_ARGS+= --with-errorpopups
+.endif
+
+.if defined(WITH_DB40)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db4
+.endif
+
+.if defined(WITH_DB41)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db41
+.endif
+
+.if defined(WITH_DB42)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db42
+.endif
+
+.if defined(WITH_DB43)
+CONFIGURE_ARGS+= --with-bdb-incdir=${LOCALBASE}/include/db43
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
WITH_OPTCFLAGS= true
.endif
@@ -99,9 +130,8 @@ CFLAGS+= -O2 -pipe
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
- @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${.CURDIR}/pkg-message > ${PKGMESSAGE}
post-install:
- ${CAT} ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>