aboutsummaryrefslogtreecommitdiff
path: root/comms/xcwcp
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-12-12 12:37:36 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-12-12 12:37:36 +0000
commit7bf1890cf3a99fc00ba32d0f6c47ba7f7304a1a7 (patch)
treee80961be7970c1da0c957db09d37e514f9107788 /comms/xcwcp
parent114e81674c93819f439195119fd58bcc82f44b6e (diff)
downloadports-7bf1890cf3a99fc00ba32d0f6c47ba7f7304a1a7.tar.gz
ports-7bf1890cf3a99fc00ba32d0f6c47ba7f7304a1a7.zip
Notes
Diffstat (limited to 'comms/xcwcp')
-rw-r--r--comms/xcwcp/Makefile28
-rw-r--r--comms/xcwcp/pkg-descr6
2 files changed, 34 insertions, 0 deletions
diff --git a/comms/xcwcp/Makefile b/comms/xcwcp/Makefile
new file mode 100644
index 000000000000..610a33587a17
--- /dev/null
+++ b/comms/xcwcp/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+CATEGORIES= comms hamradio
+
+COMMENT= X11 CW Tutor using unixcw
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libcw.so:${PORTSDIR}/comms/unixcw
+
+MASTERDIR= ${.CURDIR}/../unixcw
+
+PLIST= ${.CURDIR}/pkg-plist
+USE_QT4= gui moc_build qmake_build rcc_build uic_build designer
+USE_AUTOTOOLS= autoconf
+CONFIGURE_ARGS= --enable-xcwcp
+PLIST_FILES= bin/xcwcp \
+ man/man1/xcwcp.1.gz
+
+post-stage:
+ # Remove files from the unixcw plist
+ for plistfile in `cat ${MASTERDIR}/pkg-plist`; \
+ do \
+ cleanfile=`echo $${plistfile} | ${SED} -E 's|man/man(.*).gz|man/man\1|'`; \
+ ${RM} ${STAGEDIR}${PREFIX}/$${cleanfile}; \
+ done
+
+.include "${MASTERDIR}/Makefile"
diff --git a/comms/xcwcp/pkg-descr b/comms/xcwcp/pkg-descr
new file mode 100644
index 000000000000..fe8e634d098e
--- /dev/null
+++ b/comms/xcwcp/pkg-descr
@@ -0,0 +1,6 @@
+xcwcp: a CW tutor program for X Window environment. It offers the
+same random and keyboard sending as comms/cwcp, and in addition can
+read CW that sent to it using the keyboard or mouse as a keyer,
+making it useful for sending as well as receiving practice.
+
+WWW: http://www.ibiblio.org/pub/linux/apps/ham/morse/