aboutsummaryrefslogtreecommitdiff
path: root/comms/yaps
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2000-10-20 21:26:52 +0000
committerStefan Eßer <se@FreeBSD.org>2000-10-20 21:26:52 +0000
commitb9258b969ecaaf5c09a5c332a8a47fa994b4f8ad (patch)
tree55e489e39fcba13b2a626cf34e4fc45ba4cb2ac9 /comms/yaps
parent74e8a39c35cc9d285a61fe5c8a5a5c00ea763bad (diff)
downloadports-b9258b969ecaaf5c09a5c332a8a47fa994b4f8ad.tar.gz
ports-b9258b969ecaaf5c09a5c332a8a47fa994b4f8ad.zip
Apply diffs submitted with PR 21367:
- use ${PREFIX} instead of hard-coded paths. - respect NOPORTDOCS PR: 21367 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=34047
Diffstat (limited to 'comms/yaps')
-rw-r--r--comms/yaps/Makefile12
-rw-r--r--comms/yaps/files/patch-aa70
-rw-r--r--comms/yaps/pkg-plist4
3 files changed, 65 insertions, 21 deletions
diff --git a/comms/yaps/Makefile b/comms/yaps/Makefile
index 06cec2c73ba1..3bad494526b7 100644
--- a/comms/yaps/Makefile
+++ b/comms/yaps/Makefile
@@ -18,10 +18,12 @@ USE_GMAKE= true
MAN1= yaps.1
post-install:
- ${MKDIR} ${PREFIX}/share/doc/yaps; \
- ${INSTALL_DATA} ${WRKSRC}/yaps.rc ${PREFIX}/etc/yaps.rc.sample; \
- ${INSTALL_DATA} ${WRKSRC}/yaps.doc ${PREFIX}/share/doc/yaps; \
- ${INSTALL_DATA} ${WRKSRC}/yaps.html ${PREFIX}/share/doc/yaps; \
- ${INSTALL_MAN} ${WRKSRC}/yaps.1 ${PREFIX}/man/man1;
+ ${INSTALL_DATA} ${WRKSRC}/yaps.rc ${PREFIX}/etc/yaps.rc.sample
+ ${INSTALL_MAN} ${WRKSRC}/yaps.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/yaps
+ ${INSTALL_DATA} ${WRKSRC}/yaps.doc ${PREFIX}/share/doc/yaps
+ ${INSTALL_DATA} ${WRKSRC}/yaps.html ${PREFIX}/share/doc/yaps
+.endif
.include <bsd.port.mk>
diff --git a/comms/yaps/files/patch-aa b/comms/yaps/files/patch-aa
index 1adde0c5b893..94b9d370021c 100644
--- a/comms/yaps/files/patch-aa
+++ b/comms/yaps/files/patch-aa
@@ -1,7 +1,8 @@
-*** Config~ Tue Sep 29 15:15:18 1998
---- Config Tue Sep 29 15:16:10 1998
+*** Config.orig Sat Jun 14 19:32:18 1997
+--- Config Tue Aug 8 20:29:41 2000
***************
-*** 2,8 ****
+*** 1,9 ****
+ # -*- sh -*-
# SECTION A.) Global configuration
# Select compiler command
! CC = gcc
@@ -9,7 +10,9 @@
! CFLAGS = -Wall -Wno-parentheses -Wshadow -Wstrict-prototypes -Wmissing-prototypes
LDFLAGS =
EXLIBS =
---- 2,8 ----
+ #
+--- 1,9 ----
+ # -*- sh -*-
# SECTION A.) Global configuration
# Select compiler command
! #CC = gcc
@@ -17,29 +20,68 @@
! #CFLAGS = -Wall -Wno-parentheses -Wshadow -Wstrict-prototypes -Wmissing-prototypes
LDFLAGS =
EXLIBS =
+ #
***************
-*** 21,25 ****
+*** 14,35 ****
+ #LUA = True
+ #
+ # Define this to disable debugging
+! #NDEBUG = True
+ #
+ #
+ #
# SECTION B.) yaps configuration
# Name and location of global configuration file
! YAPS_CFGFILE = /etc/yaps.rc
# Name of local configuration file (location is $HOME.)
YAPS_LCFGFILE = .yapsrc
---- 21,25 ----
- # SECTION B.) yaps configuration
- # Name and location of global configuration file
-! YAPS_CFGFILE = /usr/local/etc/yaps.rc
- # Name of local configuration file (location is $HOME.)
- YAPS_LCFGFILE = .yapsrc
-***************
-*** 30,34 ****
+ # Directory for installing the binary
+! YAPS_BINDIR = /usr/local/bin
+ # Directory for optional support files
+! YAPS_LIBDIR = /usr/local/lib/yaps
# User/Group/Mode for yaps
YAPS_USER = bin
! YAPS_GROUP = uucp
YAPS_MODE = 2711
# User/Group/Mode for global configuration file
---- 30,34 ----
+ YAPS_RCUSER = bin
+--- 14,35 ----
+ #LUA = True
+ #
+ # Define this to disable debugging
+! NDEBUG = True
+ #
+ #
+ #
+ # SECTION B.) yaps configuration
+ # Name and location of global configuration file
+! YAPS_CFGFILE = ${PREFIX}/etc/yaps.rc
+ # Name of local configuration file (location is $HOME.)
+ YAPS_LCFGFILE = .yapsrc
+ # Directory for installing the binary
+! YAPS_BINDIR = ${PREFIX}/bin
+ # Directory for optional support files
+! YAPS_LIBDIR = ${PREFIX}/share/yaps
# User/Group/Mode for yaps
YAPS_USER = bin
! YAPS_GROUP = dialer
YAPS_MODE = 2711
# User/Group/Mode for global configuration file
+ YAPS_RCUSER = bin
+***************
+*** 56,62 ****
+ #
+ ifdef NDEBUG
+ DDEFS = -DNDEBUG
+! G = -O
+ else
+ G = -g
+ endif
+--- 56,62 ----
+ #
+ ifdef NDEBUG
+ DDEFS = -DNDEBUG
+! G =
+ else
+ G = -g
+ endif
diff --git a/comms/yaps/pkg-plist b/comms/yaps/pkg-plist
index 56244edfe948..6527f62b675d 100644
--- a/comms/yaps/pkg-plist
+++ b/comms/yaps/pkg-plist
@@ -1,7 +1,7 @@
bin/yaps
-@exec mkdir %D/lib/yaps
+@exec mkdir -p %D/share/yaps
etc/yaps.rc.sample
share/doc/yaps/yaps.doc
share/doc/yaps/yaps.html
@dirrm share/doc/yaps
-@dirrm lib/yaps
+@unexec rmdir %D/share/yaps 2>/dev/null || true