aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-10-30 11:36:44 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-10-30 11:36:44 +0000
commit06b560c9a1aa55d911a3598b8ae31d4a35d9cdc8 (patch)
tree655818a9103233c641b2f80e84c0890030d050a2 /comms
parent6ffea465aa89f7b85b572cac680f3efcecc8e7b5 (diff)
downloadports-06b560c9a1aa55d911a3598b8ae31d4a35d9cdc8.tar.gz
ports-06b560c9a1aa55d911a3598b8ae31d4a35d9cdc8.zip
Fix build on powerpc64, and, possibly, armvX.
PR: 231600 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=483470
Diffstat (limited to 'comms')
-rw-r--r--comms/rxtx/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/comms/rxtx/Makefile b/comms/rxtx/Makefile
index 2f4fae7a5390..754fe2da697b 100644
--- a/comms/rxtx/Makefile
+++ b/comms/rxtx/Makefile
@@ -15,9 +15,6 @@ COMMENT= Native interface to serial ports in Java
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_armv6= fails to link: librxtxParallel.so: No such file or directory
-BROKEN_armv7= fails to link: librxtxParallel.so: No such file or directory
-BROKEN_powerpc64= fails to link: librxtxParallel.so: No such file or directory
NOT_FOR_ARCHS= mips mips64
NOT_FOR_ARCHS_REASON= Java not available for this architecture
@@ -32,6 +29,14 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-PLIST_SUB= ARCH=${ARCH} JAVA_HOME=${JAVA_HOME:S,^${PREFIX}/,,}
+PLIST_SUB= JAVA_HOME=${JAVA_HOME:S,^${PREFIX}/,,}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "powerpc64"
+PLIST_SUB+= ARCH=ppc64
+.else
+PLIST_SUB+= ARCH=${ARCH}
+.endif
+
+.include <bsd.port.post.mk>