aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorGeorge V. Neville-Neil <gnn@FreeBSD.org>2018-09-03 18:36:32 +0000
committerGeorge V. Neville-Neil <gnn@FreeBSD.org>2018-09-03 18:36:32 +0000
commit4bfca623850eea01c3780d855a0fee7ff4a9bd55 (patch)
tree4f9aa4a6cc172a1998c1a0d3ae2ca7a6ce3ba04d /comms
parent1870b0034692751091abb3c07c93b56776d3b305 (diff)
downloadports-4bfca623850eea01c3780d855a0fee7ff4a9bd55.tar.gz
ports-4bfca623850eea01c3780d855a0fee7ff4a9bd55.zip
Ubertooth Tools for use with Ubertooth One a Bluetooth and BLE sniffer
Notes
Notes: svn path=/head/; revision=478890
Diffstat (limited to 'comms')
-rw-r--r--comms/ubertooth/Makefile25
-rw-r--r--comms/ubertooth/distinfo3
-rw-r--r--comms/ubertooth/files/patch-libubertooth_src_ubertooth__control.h11
-rw-r--r--comms/ubertooth/pkg-descr4
-rw-r--r--comms/ubertooth/pkg-plist29
5 files changed, 72 insertions, 0 deletions
diff --git a/comms/ubertooth/Makefile b/comms/ubertooth/Makefile
new file mode 100644
index 000000000000..bc019cacf227
--- /dev/null
+++ b/comms/ubertooth/Makefile
@@ -0,0 +1,25 @@
+# Created by: George V. Neville-Neil <gnn@freebsd.org>
+# $FreeBSD$
+
+PORTNAME= ubertooth
+PORTVERSION= 201808R1
+CATEGORIES= comms
+
+MAINTAINER= gnn@FreeBSD.org
+COMMENT= Bluetooth Baseband Library
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/../COPYING
+
+BUILD_DEPENDS= python27:lang/python27 \
+ pyside-py27:devel/pyside \
+ ${PYNUMPY}
+
+USES= cmake:outsource
+
+USE_GITHUB= yes
+GH_ACCOUNT= greatscottgadgets
+GH_TAGNAME= 2018-08-R1
+
+WRKSRC_SUBDIR= host
+.include <bsd.port.mk>
diff --git a/comms/ubertooth/distinfo b/comms/ubertooth/distinfo
new file mode 100644
index 000000000000..bcb287535491
--- /dev/null
+++ b/comms/ubertooth/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1535998506
+SHA256 (greatscottgadgets-ubertooth-201808R1-2018-08-R1_GH0.tar.gz) = d567da047d659013876185a285b0b94a283ba16efaea441745e15043fd974ef3
+SIZE (greatscottgadgets-ubertooth-201808R1-2018-08-R1_GH0.tar.gz) = 1279106
diff --git a/comms/ubertooth/files/patch-libubertooth_src_ubertooth__control.h b/comms/ubertooth/files/patch-libubertooth_src_ubertooth__control.h
new file mode 100644
index 000000000000..75f882f19b07
--- /dev/null
+++ b/comms/ubertooth/files/patch-libubertooth_src_ubertooth__control.h
@@ -0,0 +1,11 @@
+--- libubertooth/src/ubertooth_control.h.orig 2018-08-07 22:27:29 UTC
++++ libubertooth/src/ubertooth_control.h
+@@ -36,7 +36,7 @@
+ #define htole16 EndianU16_NtoL
+ #define htole32 EndianU32_NtoL
+ #else
+-#include <endian.h>
++#include <sys/endian.h>
+ #endif
+
+ #include <stdio.h>
diff --git a/comms/ubertooth/pkg-descr b/comms/ubertooth/pkg-descr
new file mode 100644
index 000000000000..8fa43fc88d30
--- /dev/null
+++ b/comms/ubertooth/pkg-descr
@@ -0,0 +1,4 @@
+Project Ubertooth is an open source wireless development platform
+suitable for Bluetooth experimentation. Ubertooth ships with a
+capable BLE (Bluetooth Smart) sniffer and can sniff some data from
+Basic Rate (BR) Bluetooth Classic connections.
diff --git a/comms/ubertooth/pkg-plist b/comms/ubertooth/pkg-plist
new file mode 100644
index 000000000000..27af70df85cd
--- /dev/null
+++ b/comms/ubertooth/pkg-plist
@@ -0,0 +1,29 @@
+bin/ubertooth-afh
+bin/ubertooth-btle
+bin/ubertooth-debug
+bin/ubertooth-dfu
+bin/ubertooth-dump
+bin/ubertooth-ego
+bin/ubertooth-rx
+bin/ubertooth-specan
+bin/ubertooth-specan-ui
+bin/ubertooth-tx
+bin/ubertooth-util
+include/ubertooth.h
+include/ubertooth_callback.h
+include/ubertooth_control.h
+include/ubertooth_fifo.h
+include/ubertooth_interface.h
+lib/libubertooth.so
+lib/libubertooth.so.1
+lib/libubertooth.so.1.1
+man/man1/ubertooth-afh.1.gz
+man/man1/ubertooth-btle.1.gz
+man/man1/ubertooth-dfu.1.gz
+man/man1/ubertooth-dump.1.gz
+man/man1/ubertooth-ego.1.gz
+man/man1/ubertooth-rx.1.gz
+man/man1/ubertooth-scan.1.gz
+man/man1/ubertooth-specan.1.gz
+man/man1/ubertooth-util.1.gz
+man/man7/ubertooth.7.gz