aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2018-10-06 13:06:42 +0000
commit9dff3523203bdda7ae358dcff3eb5a5ef3e54d33 (patch)
tree0721b637b4bcfc0a8ff2a945bdcb7e68f8993680 /comms
parent2e4b740f2cc9a250b2c6056d8706e15d3bfa9763 (diff)
downloadports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.tar.gz
ports-9dff3523203bdda7ae358dcff3eb5a5ef3e54d33.zip
Fix every instance of RUN_DEPENDS:=${BUILD_DEPENDS} in p5 ports, except
for where it resulted in a change in output from build-depends-list or run-depends-list. Approved by: portmgr (adamw)
Notes
Notes: svn path=/head/; revision=481365
Diffstat (limited to 'comms')
-rw-r--r--comms/p5-Device-Modem/Makefile4
-rw-r--r--comms/p5-Nexmo-SMS/Makefile4
-rw-r--r--comms/p5-SMS-Send-DeviceGsm/Makefile4
-rw-r--r--comms/p5-SMS-Send-NexmoUnicode/Makefile4
-rw-r--r--comms/p5-SMS-Send-TW-HiAir/Makefile4
-rw-r--r--comms/p5-SMS-Send-TW-ShareSMS/Makefile4
-rw-r--r--comms/p5-SMS-Send/Makefile4
7 files changed, 14 insertions, 14 deletions
diff --git a/comms/p5-Device-Modem/Makefile b/comms/p5-Device-Modem/Makefile
index 9ff82f072cc4..84655a573632 100644
--- a/comms/p5-Device-Modem/Makefile
+++ b/comms/p5-Device-Modem/Makefile
@@ -14,8 +14,8 @@ COMMENT= Perl class to interface generic modems (AT-compliant)
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Device-SerialPort>=0:comms/p5-Device-SerialPort
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Device-SerialPort>=0:comms/p5-Device-SerialPort
USES= perl5 shebangfix
SHEBANG_FILES= examples/xmodem.pl \
diff --git a/comms/p5-Nexmo-SMS/Makefile b/comms/p5-Nexmo-SMS/Makefile
index fc54084404a9..674821c7083c 100644
--- a/comms/p5-Nexmo-SMS/Makefile
+++ b/comms/p5-Nexmo-SMS/Makefile
@@ -12,10 +12,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@freebsd.cs.nctu.edu.tw
COMMENT= Send SMS via http://www.nexmo.com/ API
-BUILD_DEPENDS= p5-HTTP-Message>=5.836:www/p5-HTTP-Message \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-HTTP-Message>=5.836:www/p5-HTTP-Message \
p5-JSON-PP>=2.26000:converters/p5-JSON-PP \
p5-libwww>=5.835:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Pod>=1.22:devel/p5-Test-Pod \
p5-Test-Pod-Coverage>=1.08:devel/p5-Test-Pod-Coverage
diff --git a/comms/p5-SMS-Send-DeviceGsm/Makefile b/comms/p5-SMS-Send-DeviceGsm/Makefile
index a83ffebc0cff..2c7aa7d941b6 100644
--- a/comms/p5-SMS-Send-DeviceGsm/Makefile
+++ b/comms/p5-SMS-Send-DeviceGsm/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= SMS::Send driver for Device::Gsm
-BUILD_DEPENDS= p5-SMS-Send>=0.04:comms/p5-SMS-Send \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-SMS-Send>=0.04:comms/p5-SMS-Send \
p5-Device-Gsm>=1.45:comms/p5-Device-Gsm
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-NexmoUnicode/Makefile b/comms/p5-SMS-Send-NexmoUnicode/Makefile
index fb386ace50c6..b33ac23f0016 100644
--- a/comms/p5-SMS-Send-NexmoUnicode/Makefile
+++ b/comms/p5-SMS-Send-NexmoUnicode/Makefile
@@ -11,9 +11,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@freebsd.cs.nctu.edu.tw
COMMENT= SMS::Send driver for www.nexmo.com (Unicode)
-BUILD_DEPENDS= p5-Nexmo-SMS>=0.04:comms/p5-Nexmo-SMS \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Nexmo-SMS>=0.04:comms/p5-Nexmo-SMS \
p5-SMS-Send>=0:comms/p5-SMS-Send
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-TW-HiAir/Makefile b/comms/p5-SMS-Send-TW-HiAir/Makefile
index 2960d5754a2d..d61ceb5c6b2e 100644
--- a/comms/p5-SMS-Send-TW-HiAir/Makefile
+++ b/comms/p5-SMS-Send-TW-HiAir/Makefile
@@ -11,11 +11,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= jnlin@freebsd.cs.nctu.edu.tw
COMMENT= SMS::Send driver for http://hiair.hinet.net/
-BUILD_DEPENDS= p5-SMS-Send>=0:comms/p5-SMS-Send \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-SMS-Send>=0:comms/p5-SMS-Send \
p5-WWW-Mechanize>=0:www/p5-WWW-Mechanize \
p5-Crypt-SSLeay>=0.51:security/p5-Crypt-SSLeay \
p5-Text-Iconv>=0:converters/p5-Text-Iconv
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send-TW-ShareSMS/Makefile b/comms/p5-SMS-Send-TW-ShareSMS/Makefile
index 030ee9c8fccb..886c793c4170 100644
--- a/comms/p5-SMS-Send-TW-ShareSMS/Makefile
+++ b/comms/p5-SMS-Send-TW-ShareSMS/Makefile
@@ -11,10 +11,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= snowfly@yuntech.edu.tw
COMMENT= SMS::Send driver for www.ShareSMS.com
-BUILD_DEPENDS= p5-SMS-Send>=0.03:comms/p5-SMS-Send \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-SMS-Send>=0.03:comms/p5-SMS-Send \
p5-URI>=0:net/p5-URI \
p5-libwww>=2:www/p5-libwww
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure
diff --git a/comms/p5-SMS-Send/Makefile b/comms/p5-SMS-Send/Makefile
index 78c15d10d308..8721bf13e434 100644
--- a/comms/p5-SMS-Send/Makefile
+++ b/comms/p5-SMS-Send/Makefile
@@ -14,9 +14,9 @@ COMMENT= Driver-based API for sending SMS messages
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
-BUILD_DEPENDS= p5-Class-Adapter>=1.05:devel/p5-Class-Adapter \
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Class-Adapter>=1.05:devel/p5-Class-Adapter \
p5-Params-Util>=1.00:devel/p5-Params-Util
-RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= configure