aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-10-31 06:24:57 +0000
committerWen Heping <wen@FreeBSD.org>2018-10-31 06:24:57 +0000
commita45b65a3c7f7d1feb1c57c0ecb8bcba2efbb6ed8 (patch)
treed027db0d4343e782246d2b5848ceb537accb26ef /comms
parent0653ebc475994ff07f6514e098736a70706215b7 (diff)
downloadports-a45b65a3c7f7d1feb1c57c0ecb8bcba2efbb6ed8.tar.gz
ports-a45b65a3c7f7d1feb1c57c0ecb8bcba2efbb6ed8.zip
- Update to 3.2p3
PR: 231814 Submitted by: osidorkin@gmail.com Approved by: maintainer
Notes
Notes: svn path=/head/; revision=483552
Diffstat (limited to 'comms')
-rw-r--r--comms/owfs/Makefile21
-rw-r--r--comms/owfs/Makefile.options8
-rw-r--r--comms/owfs/distinfo5
-rw-r--r--comms/owfs/pkg-plist20
4 files changed, 40 insertions, 14 deletions
diff --git a/comms/owfs/Makefile b/comms/owfs/Makefile
index ef5d4eb2b88f..aa5695660698 100644
--- a/comms/owfs/Makefile
+++ b/comms/owfs/Makefile
@@ -2,10 +2,8 @@
# $FreeBSD$
PORTNAME= owfs
-PORTVERSION= 3.1p1
-PORTREVISION= 1
+PORTVERSION= 3.2p3
CATEGORIES= comms
-MASTER_SITES= SF/owfs/owfs/${PORTVERSION}
MAINTAINER= johan@stromnet.se
COMMENT= OWFS -- 1-Wire file system
@@ -18,6 +16,9 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+USE_GITHUB= yes
+GH_TAGNAME= v${DISTVERSION}
+
.include "Makefile.options"
OPTIONS_SUB=yes
@@ -28,6 +29,12 @@ CONFIGURE_ARGS= --enable-owlib
CONFIGURE_ARGS+= --disable-w1
CONFIGURE_ARGS+= --disable-parport
+AVAHI_CONFIGURE_ENABLE= avahi
+AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
+
+FDTDI_CONFIGURE_EANBLE= ftdi
+FTDI_LIB_DEPENDS= libftdi.so:devel/libftdi
+
OWDEBUG_CONFIGURE_ENABLE= debug
OWMUTEXDEBUG_CONFIGURE_ENABLE= mutexdebug
OWSHELL_CONFIGURE_ENABLE= owshell
@@ -48,6 +55,7 @@ OWMON_CONFIGURE_ENABLE= owmon
OWMON_USES= tk:wrapper
OWCAPI_CONFIGURE_ENABLE= owcapi
+OWEXTERNAL_CONFIGURE_ENABLE= owexternal
OWPERL_CONFIGURE_ENABLE= owperl
OWPERL_USES= perl5
@@ -110,6 +118,13 @@ CONFIGURE_ARGS+= --disable-swig
CONFIGURE_ARGS+= --enable-owtcl --with-tcl=${TCL_LIBDIR}
.endif
+.if ${PORT_OPTIONS:MOWEXTERNAL}
+PLIST_SUB+= OWEXTERNAL=""
+.else
+PLIST_SUB+= OWEXTERNAL="@comment "
+CONFIGURE_ARGS+= --disable-owexternal
+.endif
+
# This takes a few seconds so give the user some notice
pre-configure:
@${MKDIR} ${WRKSRC}/m4
diff --git a/comms/owfs/Makefile.options b/comms/owfs/Makefile.options
index 03b65ffce8d5..fa64c64136e7 100644
--- a/comms/owfs/Makefile.options
+++ b/comms/owfs/Makefile.options
@@ -1,6 +1,8 @@
# $FreeBSD$
OPTIONS_DEFINE = \
+ AVAHI \
+ FTDI \
OWDEBUG \
OWMUTEXDEBUG \
OWSHELL \
@@ -14,6 +16,7 @@ OPTIONS_DEFINE = \
OWTRAFFIC \
OWMON \
OWCAPI \
+ OWEXTERNAL \
OWPERL \
OWPHP \
OWPYTHON \
@@ -27,7 +30,8 @@ OPTIONS_DEFINE = \
# PARPORT - linux/parport.h not available
# W1 - no support on FreeBSD
-
+AVAHI_DESC= Enable zero-config autodiscovery
+FTDI_DESC= Enable LinkUSB support via libftdi
OWDEBUG_DESC= Enable debug output
OWMUTEXDEBUG_DESC= Enable mutex debug
OWSHELL_DESC= Enable CLI utils
@@ -41,6 +45,7 @@ OWTRAFFIC_DESC= Enable debug bus traffic reports
OWTAP_DESC= Enable owtap module (X11)
OWMON_DESC= Enable owmon module (X11)
OWCAPI_DESC= Enable C API
+OWEXTERNAL_DESC= Enable owexternal
OWPERL_DESC= Enable Perl binding (BROKEN)
OWPHP_DESC= Enable PHP binding (BROKEN)
OWPYTHON_DESC= Enable Python binding
@@ -62,6 +67,7 @@ OPTIONS_DEFAULT=OWDEBUG\
OWFTPD\
OWSERVER\
OWCAPI\
+ OWEXTERNAL \
OWFS\
USB
diff --git a/comms/owfs/distinfo b/comms/owfs/distinfo
index 3614271da4a4..65f65bd104d9 100644
--- a/comms/owfs/distinfo
+++ b/comms/owfs/distinfo
@@ -1,2 +1,3 @@
-SHA256 (owfs-3.1p1.tar.gz) = e69421ae534565c1f8530a2447f583401f4d0d4b1cf3cb8cf399a57133ed7f81
-SIZE (owfs-3.1p1.tar.gz) = 1400962
+TIMESTAMP = 1538774075
+SHA256 (owfs-owfs-3.2p3-v3.2p3_GH0.tar.gz) = 680385e4db007a951e9678a48989dca7d43868b754299c8368010c80d0c2de4a
+SIZE (owfs-owfs-3.2p3-v3.2p3_GH0.tar.gz) = 1322466
diff --git a/comms/owfs/pkg-plist b/comms/owfs/pkg-plist
index e1807a691011..99066dd39af3 100644
--- a/comms/owfs/pkg-plist
+++ b/comms/owfs/pkg-plist
@@ -1,14 +1,16 @@
%%OWCAPI%%include/owcapi.h
-%%OWCAPI%%lib/libowcapi-3.1.so.1
-%%OWCAPI%%lib/libowcapi-3.1.so.1.0.0
+%%OWCAPI%%lib/libowcapi-3.2.so.3
+%%OWCAPI%%lib/libowcapi-3.2.so.3.0.0
%%OWCAPI%%lib/libowcapi.so
+%%OWCAPI%%libdata/pkgconfig/owcapi.pc
+%%OWEXTERNAL%%bin/owexternal
%%OWFS%%bin/owfs
%%OWFTPD%%bin/owftpd
%%OWHTTPD%%bin/owhttpd
%%OWMON%%bin/owmon
%%OWNETLIB%%include/ownetapi.h
-%%OWNETLIB%%lib/libownet-3.1.so.1
-%%OWNETLIB%%lib/libownet-3.1.so.1.0.0
+%%OWNETLIB%%lib/libownet-3.2.so.3
+%%OWNETLIB%%lib/libownet-3.2.so.3.0.0
%%OWNETLIB%%lib/libownet.so
%%OWNETPERL%%%%PERL5_MAN3%%/OWNet.3.gz
%%OWNETPERL%%%%SITE_PERL%%/OWNet.pm
@@ -21,7 +23,7 @@
%%OWNETPYTHON%%%%PYTHON_SITELIBDIR%%/ownet/connection.pyo
%%OWPERL%%%%SITE_ARCH%%/OW.pm
%%OWPERL%%%%SITE_ARCH%%/auto/OW/OW.so
-%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow-3.1p1-py2.7.egg-info
+%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow-3.2p3-py%%PYTHON_VER%%.egg-info
%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/_OW.so
%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.py
%%OWPYTHON%%%%PYTHON_SITELIBDIR%%/ow/__init__.pyc
@@ -32,21 +34,22 @@
%%OWSHELL%%bin/owget
%%OWSHELL%%bin/owpresent
%%OWSHELL%%bin/owread
+%%OWSHELL%%bin/owusbprobe
%%OWSHELL%%bin/owwrite
%%OWTAP%%bin/owtap
%%OWTCL%%lib/owtcl-1.0/ow-1.0.so
%%OWTCL%%lib/owtcl-1.0/ow.so
%%OWTCL%%lib/owtcl-1.0/ow.tcl
%%OWTCL%%lib/owtcl-1.0/pkgIndex.tcl
-bin/owexternal
include/owfs_config.h
-lib/libow-3.1.so.1
-lib/libow-3.1.so.1.0.0
+lib/libow-3.2.so.3
+lib/libow-3.2.so.3.0.0
lib/libow.so
man/man1/libowcapi.1.gz
man/man1/libownet.1.gz
man/man1/owcapi.1.gz
man/man1/owdir.1.gz
+man/man1/owexist.1.gz
man/man1/owfs.1.gz
man/man1/owftpd.1.gz
man/man1/owget.1.gz
@@ -146,6 +149,7 @@ man/man3/EDS0083.3.gz
man/man3/EDS0085.3.gz
man/man3/EDS0090.3.gz
man/man3/EEEF.3.gz
+man/man3/IBLSS.3.gz
man/man3/LCD.3.gz
man/man3/MAX31820.3.gz
man/man3/MAX31826.3.gz