aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-10-30 11:49:32 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-10-30 11:49:32 +0000
commitca8ab26c382ab14b8adc6b1140fc17447b0f8828 (patch)
tree00aa127d52306c8628723641ab4ba307833f3c35 /comms
parent2dbcc43af2918d36a28698135f085aeff41122b4 (diff)
downloadports-ca8ab26c382ab14b8adc6b1140fc17447b0f8828.tar.gz
ports-ca8ab26c382ab14b8adc6b1140fc17447b0f8828.zip
Fix build on gcc-based architectures.
PR: 232560 Submitted by: Piotr Kubaj
Notes
Notes: svn path=/head/; revision=483473
Diffstat (limited to 'comms')
-rw-r--r--comms/telldus-core/Makefile7
-rw-r--r--comms/telldus-core/files/patch-common-Socket_unix.cpp13
-rw-r--r--comms/telldus-core/files/patch-service-ConnectionListener_unix.cpp9
3 files changed, 19 insertions, 10 deletions
diff --git a/comms/telldus-core/Makefile b/comms/telldus-core/Makefile
index aefe38f044f9..836dd9f9a7da 100644
--- a/comms/telldus-core/Makefile
+++ b/comms/telldus-core/Makefile
@@ -17,11 +17,8 @@ LIB_DEPENDS= libftdi.so:devel/libftdi \
libconfuse.so:devel/libconfuse \
libargp.so:devel/argp-standalone
-BROKEN_powerpc64= Does not build: error: strlen was not declared in this scope
-BROKEN_sparc64= Does not build: error: strlen was not declared in this scope
-
-USE_LDCONFIG= yes
USES= cmake compiler:c++11-lang iconv:wchar_t
+USE_LDCONFIG= yes
CMAKE_ARGS+=-DGENERATE_MAN=TRUE
# Note: these are internal defines and shall NOT contain ${STAGEDIR}
@@ -50,7 +47,7 @@ post-patch:
post-install:
cd ${STAGEDIR}${PREFIX}/etc && \
${MV} tellstick.conf tellstick.conf.sample
- # This file is actually empty but allows us to simply use @sample to
+ # This file is actually empty but allows us to simply use @sample to
# make sure it stays between upgrades if modified
cd ${STAGEDIR}/var/telldus && \
${MV} telldus-core.conf telldus-core.conf.sample
diff --git a/comms/telldus-core/files/patch-common-Socket_unix.cpp b/comms/telldus-core/files/patch-common-Socket_unix.cpp
index be5341c7a9d7..71fd748e224d 100644
--- a/comms/telldus-core/files/patch-common-Socket_unix.cpp
+++ b/comms/telldus-core/files/patch-common-Socket_unix.cpp
@@ -1,6 +1,13 @@
---- common/Socket_unix.cpp
+--- common/Socket_unix.cpp.orig 2014-03-31 10:30:09 UTC
+++ common/Socket_unix.cpp
-@@ -18,7 +18,7 @@
+@@ -12,13 +12,14 @@
+ #include <fcntl.h>
+ #include <math.h>
+ #include <string>
++#include <cstring>
+
+ #include "common/Socket.h"
+ #include "common/Mutex.h"
#include "common/Strings.h"
#define BUFSIZE 512
@@ -9,7 +16,7 @@
#define SOCK_CLOEXEC 0
#endif
-@@ -128,8 +128,10 @@ std::wstring Socket::read(int timeout) {
+@@ -128,8 +129,10 @@ std::wstring Socket::read(int timeout) {
void Socket::stopReadWait() {
TelldusCore::MutexLocker locker(&d->mutex);
diff --git a/comms/telldus-core/files/patch-service-ConnectionListener_unix.cpp b/comms/telldus-core/files/patch-service-ConnectionListener_unix.cpp
index b2abd2f9ce1f..d0041c08c507 100644
--- a/comms/telldus-core/files/patch-service-ConnectionListener_unix.cpp
+++ b/comms/telldus-core/files/patch-service-ConnectionListener_unix.cpp
@@ -1,6 +1,11 @@
---- service/ConnectionListener_unix.cpp
+--- service/ConnectionListener_unix.cpp.orig 2014-03-31 10:30:09 UTC
+++ service/ConnectionListener_unix.cpp
-@@ -17,7 +17,7 @@
+@@ -13,11 +13,12 @@
+ #include <fcntl.h>
+ #include <errno.h>
+ #include <string>
++#include <cstring>
+
#include "service/ConnectionListener.h"
#include "common/Socket.h"