aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2018-08-14 23:33:58 +0000
committerDiane Bruce <db@FreeBSD.org>2018-08-14 23:33:58 +0000
commitcf884890a6390a137c05981c0cfcb733c251765f (patch)
tree821e4ae09fd6dbcc1426cb49349b51048e6c1ff9 /comms
parent7814c55c41a39c79207b301bcc1f4e988df46269 (diff)
downloadports-cf884890a6390a137c05981c0cfcb733c251765f.tar.gz
ports-cf884890a6390a137c05981c0cfcb733c251765f.zip
## [3.7.13.4] - 2018-07-15
### Fixed #### Project Scope - Fix Boost 1.67 linking issue #### gnuradio-runtime - Logging: fixed issues where messages weren't properly written to stdout/stderr due to incorrect strings #### gr-analog - `fmdet_cf`'s derivative coefficients were wrong. #### gr-blocks - `skiphead` used to incorrectly handle tags, now properly shifts #### gr-digital - `qa_packet_format`: Unit test used to potentially lock up due to incorrect conditionals - `clock_recovery_cc`, `crc32_bb`: Accessing the `[0]` element of an empty vector is UB, even if you don't use the result afterwards. #### gr-fec - `polar_encoder`/`_common`: Fixed multiple out-of-bound accesses due to insufficient vector length checks #### gr-filter - `fft_filter`, `filter_delay`: Accessing the `[0]` element of an empty vector is UB, even if you don't use the result afterwards. Fix dependancy problem when UHD is not used.
Notes
Notes: svn path=/head/; revision=477209
Diffstat (limited to 'comms')
-rw-r--r--comms/gnuradio/Makefile6
-rw-r--r--comms/gnuradio/distinfo6
-rw-r--r--comms/gnuradio/files/patch-cmake_Modules_FindUSB.cmake4
-rw-r--r--comms/gnuradio/files/patch-gr-uhd_examples_c++_CMakeLists.txt11
-rw-r--r--comms/gnuradio/pkg-plist168
5 files changed, 93 insertions, 102 deletions
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 5dde8e79e2a6..9c8e73e887d7 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= gnuradio
-PORTVERSION= 3.7.13.3
-PORTREVISION= 4
+PORTVERSION= 3.7.13.4
CATEGORIES= comms astro hamradio
MASTER_SITES= http://gnuradio.org/releases/gnuradio/ \
LOCAL/db
@@ -111,6 +110,9 @@ TESTING_BUILD_DEPENDS= cppunit-config:devel/cppunit
.if ${PORT_OPTIONS:MUHD}
LIBSTRIP_FILES+= uhd
LIB_DEPENDS+= libuhd.so:comms/uhd
+PLIST_SUB+= UHD=""
+.else
+PLIST_SUB+= UHD="@comment "
.endif
PATCH_FILES= docs/doxygen/Doxyfile.in \
diff --git a/comms/gnuradio/distinfo b/comms/gnuradio/distinfo
index abb914b59be7..af28c738fad1 100644
--- a/comms/gnuradio/distinfo
+++ b/comms/gnuradio/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1529253899
-SHA256 (gnuradio-3.7.13.3.tar.gz) = 1e07ce40fa3c3eede1fb54e320dad8a221a3c01de341e9cef2d7b265ed06a6e9
-SIZE (gnuradio-3.7.13.3.tar.gz) = 4544605
+TIMESTAMP = 1534033130
+SHA256 (gnuradio-3.7.13.4.tar.gz) = c536c268b1e9c24f1206bbc881a5819ac46e662f4e8beaded6f3f441d3502f0d
+SIZE (gnuradio-3.7.13.4.tar.gz) = 4546663
diff --git a/comms/gnuradio/files/patch-cmake_Modules_FindUSB.cmake b/comms/gnuradio/files/patch-cmake_Modules_FindUSB.cmake
index 77cd2981154c..9050bab3474d 100644
--- a/comms/gnuradio/files/patch-cmake_Modules_FindUSB.cmake
+++ b/comms/gnuradio/files/patch-cmake_Modules_FindUSB.cmake
@@ -1,6 +1,6 @@
---- cmake/Modules/FindUSB.cmake.orig 2018-06-13 21:42:48 UTC
+--- cmake/Modules/FindUSB.cmake.orig 2018-07-15 16:09:20 UTC
+++ cmake/Modules/FindUSB.cmake
-@@ -22,6 +22,19 @@ else(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES)
+@@ -23,6 +23,19 @@ else(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES)
set(LIBUSB_FOUND FALSE CACHE INTERNAL "libusb-1.0 found")
message(STATUS "libusb-1.0 not found.")
endif(LIBUSB_INCLUDE_DIR AND LIBUSB_LIBRARIES)
diff --git a/comms/gnuradio/files/patch-gr-uhd_examples_c++_CMakeLists.txt b/comms/gnuradio/files/patch-gr-uhd_examples_c++_CMakeLists.txt
deleted file mode 100644
index 7068fca81b33..000000000000
--- a/comms/gnuradio/files/patch-gr-uhd_examples_c++_CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- gr-uhd/examples/c++/CMakeLists.txt.orig 2018-06-13 21:42:48 UTC
-+++ gr-uhd/examples/c++/CMakeLists.txt
-@@ -35,7 +35,7 @@ link_directories(${Boost_LIBRARY_DIRS})
- # Build executable
- ########################################################################
- add_executable(tags_demo tags_demo.cc)
--target_link_libraries(tags_demo gnuradio-uhd)
-+target_link_libraries(tags_demo gnuradio-uhd -lpthread)
-
- INSTALL(TARGETS
- tags_demo
diff --git a/comms/gnuradio/pkg-plist b/comms/gnuradio/pkg-plist
index 8df331d88ec3..bb3c7cb7eb21 100644
--- a/comms/gnuradio/pkg-plist
+++ b/comms/gnuradio/pkg-plist
@@ -43,11 +43,11 @@ bin/gr_time_raster_b
bin/gr_time_raster_f
bin/grcc
bin/polar_channel_construction
-bin/uhd_fft
-bin/uhd_rx_cfile
-bin/uhd_rx_nogui
-bin/uhd_siggen
-bin/uhd_siggen_gui
+%%UHD%%bin/uhd_fft
+%%UHD%%bin/uhd_rx_cfile
+%%UHD%%bin/uhd_rx_nogui
+%%UHD%%bin/uhd_siggen
+%%UHD%%bin/uhd_siggen_gui
bin/usrp_flex
bin/usrp_flex_all
bin/usrp_flex_band
@@ -892,8 +892,8 @@ include/gnuradio/swig/trellis_swig0.i
include/gnuradio/swig/trellis_swig0_doc.i
include/gnuradio/swig/trellis_swig1.i
include/gnuradio/swig/trellis_swig1_doc.i
-include/gnuradio/swig/uhd_swig.i
-include/gnuradio/swig/uhd_swig_doc.i
+%%UHD%%include/gnuradio/swig/uhd_swig.i
+%%UHD%%include/gnuradio/swig/uhd_swig_doc.i
include/gnuradio/swig/video_sdl_swig.i
include/gnuradio/swig/video_sdl_swig_doc.i
include/gnuradio/swig/vocoder_swig.i
@@ -983,11 +983,11 @@ include/gnuradio/trellis/viterbi_combined_ss.h
include/gnuradio/trellis/viterbi_i.h
include/gnuradio/trellis/viterbi_s.h
include/gnuradio/types.h
-include/gnuradio/uhd/amsg_source.h
-include/gnuradio/uhd/api.h
-include/gnuradio/uhd/usrp_block.h
-include/gnuradio/uhd/usrp_sink.h
-include/gnuradio/uhd/usrp_source.h
+%%UHD%%include/gnuradio/uhd/amsg_source.h
+%%UHD%%include/gnuradio/uhd/api.h
+%%UHD%%include/gnuradio/uhd/usrp_block.h
+%%UHD%%include/gnuradio/uhd/usrp_sink.h
+%%UHD%%include/gnuradio/uhd/usrp_source.h
include/gnuradio/unittests.h
include/gnuradio/video_sdl/api.h
include/gnuradio/video_sdl/sink_s.h
@@ -1253,9 +1253,9 @@ lib/libgnuradio-runtime.so.%%PORTVERSION%%
lib/libgnuradio-trellis.so
lib/libgnuradio-trellis.so.%%MAJOR_VERSION%%
lib/libgnuradio-trellis.so.%%PORTVERSION%%
-lib/libgnuradio-uhd.so
-lib/libgnuradio-uhd.so.%%MAJOR_VERSION%%
-lib/libgnuradio-uhd.so.%%PORTVERSION%%
+%%UHD%%lib/libgnuradio-uhd.so
+%%UHD%%lib/libgnuradio-uhd.so.%%MAJOR_VERSION%%
+%%UHD%%lib/libgnuradio-uhd.so.%%PORTVERSION%%
lib/libgnuradio-video-sdl.so
lib/libgnuradio-video-sdl.so.%%MAJOR_VERSION%%
lib/libgnuradio-video-sdl.so.%%PORTVERSION%%
@@ -2084,19 +2084,19 @@ lib/libvolk.so.1.4
%%PYTHON_SITELIBDIR%%/gnuradio/trellis/trellis_swig1.py
%%PYTHON_SITELIBDIR%%/gnuradio/trellis/trellis_swig1.pyc
%%PYTHON_SITELIBDIR%%/gnuradio/trellis/trellis_swig1.%%PYTHON_PYOEXTENSION%%
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/__init__.py
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/__init__.pyc
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/__init__.%%PYTHON_PYOEXTENSION%%
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/_uhd_swig.so
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_app.py
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_app.pyc
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_app.%%PYTHON_PYOEXTENSION%%
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_siggen_base.py
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_siggen_base.pyc
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_siggen_base.%%PYTHON_PYOEXTENSION%%
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_swig.py
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_swig.pyc
-%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_swig.%%PYTHON_PYOEXTENSION%%
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/__init__.py
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/__init__.pyc
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/__init__.%%PYTHON_PYOEXTENSION%%
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/_uhd_swig.so
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_app.py
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_app.pyc
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_app.%%PYTHON_PYOEXTENSION%%
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_siggen_base.py
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_siggen_base.pyc
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_siggen_base.%%PYTHON_PYOEXTENSION%%
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_swig.py
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_swig.pyc
+%%UHD%%%%PYTHON_SITELIBDIR%%/gnuradio/uhd/uhd_swig.%%PYTHON_PYOEXTENSION%%
%%PYTHON_SITELIBDIR%%/gnuradio/video_sdl/__init__.py
%%PYTHON_SITELIBDIR%%/gnuradio/video_sdl/__init__.pyc
%%PYTHON_SITELIBDIR%%/gnuradio/video_sdl/__init__.%%PYTHON_PYOEXTENSION%%
@@ -2307,7 +2307,7 @@ libdata/pkgconfig/gnuradio-pager.pc
libdata/pkgconfig/gnuradio-qtgui.pc
libdata/pkgconfig/gnuradio-runtime.pc
libdata/pkgconfig/gnuradio-trellis.pc
-libdata/pkgconfig/gnuradio-uhd.pc
+%%UHD%%libdata/pkgconfig/gnuradio-uhd.pc
libdata/pkgconfig/gnuradio-video-sdl.pc
libdata/pkgconfig/gnuradio-vocoder.pc
libdata/pkgconfig/gnuradio-wavelet.pc
@@ -2325,7 +2325,7 @@ libexec/gnuradio/grc_setup_freedesktop
%%PORTDOCS%%%%DOCSDIR%%/README.fft
%%PORTDOCS%%%%DOCSDIR%%/README.filter
%%PORTDOCS%%%%DOCSDIR%%/README.qtgui
-%%PORTDOCS%%%%DOCSDIR%%/README.uhd
+%%UHD%%%%PORTDOCS%%%%DOCSDIR%%/README.uhd
%%PORTDOCS%%%%DOCSDIR%%/README.vocoder
%%PORTDOCS%%%%DOCSDIR%%/html/gr-trellis.html
%%PORTDOCS%%%%DOCSDIR%%/xml/test_tcm.py.xml
@@ -2380,8 +2380,8 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/digital/demod/symbol_sync_test_float_ted_gain.m
%%DATADIR%%/examples/digital/demod/test_corr_and_sync.grc
%%DATADIR%%/examples/digital/demod/test_corr_est.grc
-%%DATADIR%%/examples/digital/demod/uhd_corr_and_sync_rx.grc
-%%DATADIR%%/examples/digital/demod/uhd_corr_and_sync_tx.grc
+%%UHD%%%%DATADIR%%/examples/digital/demod/uhd_corr_and_sync_rx.grc
+%%UHD%%%%DATADIR%%/examples/digital/demod/uhd_corr_and_sync_tx.grc
%%DATADIR%%/examples/digital/example_costas.py
%%DATADIR%%/examples/digital/example_fll.py
%%DATADIR%%/examples/digital/example_timing.py
@@ -2395,7 +2395,7 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/digital/narrowband/transmit_path.py
%%DATADIR%%/examples/digital/narrowband/tunnel.py
%%DATADIR%%/examples/digital/narrowband/tx_voice.py
-%%DATADIR%%/examples/digital/narrowband/uhd_interface.py
+%%UHD%%%%DATADIR%%/examples/digital/narrowband/uhd_interface.py
%%DATADIR%%/examples/digital/ofdm/benchmark_add_channel.py
%%DATADIR%%/examples/digital/ofdm/benchmark_rx.py
%%DATADIR%%/examples/digital/ofdm/benchmark_tx.py
@@ -2406,7 +2406,7 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/digital/ofdm/transmit_path.py
%%DATADIR%%/examples/digital/ofdm/tunnel.py
%%DATADIR%%/examples/digital/ofdm/tx_ofdm.grc
-%%DATADIR%%/examples/digital/ofdm/uhd_interface.py
+%%UHD%%%%DATADIR%%/examples/digital/ofdm/uhd_interface.py
%%DATADIR%%/examples/digital/packet/burst_tagger.grc
%%DATADIR%%/examples/digital/packet/example_corr_est.grc
%%DATADIR%%/examples/digital/packet/example_corr_est_and_clock_sync.grc
@@ -2426,10 +2426,10 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/digital/packet/tx_stage5.grc
%%DATADIR%%/examples/digital/packet/tx_stage6.grc
%%DATADIR%%/examples/digital/packet/tx_stage6a.grc
-%%DATADIR%%/examples/digital/packet/uhd_packet_rx.grc
-%%DATADIR%%/examples/digital/packet/uhd_packet_rx_tun.grc
-%%DATADIR%%/examples/digital/packet/uhd_packet_tx.grc
-%%DATADIR%%/examples/digital/packet/uhd_packet_tx_tun.grc
+%%UHD%%%%DATADIR%%/examples/digital/packet/uhd_packet_rx.grc
+%%UHD%%%%DATADIR%%/examples/digital/packet/uhd_packet_rx_tun.grc
+%%UHD%%%%DATADIR%%/examples/digital/packet/uhd_packet_tx.grc
+%%UHD%%%%DATADIR%%/examples/digital/packet/uhd_packet_tx_tun.grc
%%DATADIR%%/examples/digital/run_length.py
%%DATADIR%%/examples/digital/snr_estimators.py
%%DATADIR%%/examples/dtv/README.atsc
@@ -2457,9 +2457,9 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/dtv/germany-g7.grc
%%DATADIR%%/examples/dtv/germany-g8.grc
%%DATADIR%%/examples/dtv/germany-g9.grc
-%%DATADIR%%/examples/dtv/uhd_atsc_capture.grc
-%%DATADIR%%/examples/dtv/uhd_atsc_tx.grc
-%%DATADIR%%/examples/dtv/uhd_rx_atsc.grc
+%%UHD%%%%DATADIR%%/examples/dtv/uhd_atsc_capture.grc
+%%UHD%%%%DATADIR%%/examples/dtv/uhd_atsc_tx.grc
+%%UHD%%%%DATADIR%%/examples/dtv/uhd_rx_atsc.grc
%%DATADIR%%/examples/dtv/vv001-cr%%MAJOR_VERSION%%5.grc
%%DATADIR%%/examples/dtv/vv00%%MAJOR_VERSION%%-cr2%%MAJOR_VERSION%%.grc
%%DATADIR%%/examples/dtv/vv004-8kfft.grc
@@ -2519,20 +2519,20 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/filter/resampler_demo.grc
%%DATADIR%%/examples/filter/synth_filter.py
%%DATADIR%%/examples/filter/synth_to_chan.py
-%%DATADIR%%/examples/hf_explorer/README
-%%DATADIR%%/examples/hf_explorer/hfx.py
-%%DATADIR%%/examples/hf_explorer/hfx_help
-%%DATADIR%%/examples/hf_radio/README.TXT
-%%DATADIR%%/examples/hf_radio/hfir.sci
-%%DATADIR%%/examples/hf_radio/input.py
-%%DATADIR%%/examples/hf_radio/output.py
-%%DATADIR%%/examples/hf_radio/radio.py
-%%DATADIR%%/examples/hf_radio/radio.xml
-%%DATADIR%%/examples/hf_radio/ssb_taps
-%%DATADIR%%/examples/hf_radio/ssbagc.py
-%%DATADIR%%/examples/hf_radio/ssbdemod.py
-%%DATADIR%%/examples/hf_radio/startup.py
-%%DATADIR%%/examples/hf_radio/ui.py
+%%UHD%%%%DATADIR%%/examples/hf_explorer/README
+%%UHD%%%%DATADIR%%/examples/hf_explorer/hfx.py
+%%UHD%%%%DATADIR%%/examples/hf_explorer/hfx_help
+%%UHD%%%%DATADIR%%/examples/hf_radio/README.TXT
+%%UHD%%%%DATADIR%%/examples/hf_radio/hfir.sci
+%%UHD%%%%DATADIR%%/examples/hf_radio/input.py
+%%UHD%%%%DATADIR%%/examples/hf_radio/output.py
+%%UHD%%%%DATADIR%%/examples/hf_radio/radio.py
+%%UHD%%%%DATADIR%%/examples/hf_radio/radio.xml
+%%UHD%%%%DATADIR%%/examples/hf_radio/ssb_taps
+%%UHD%%%%DATADIR%%/examples/hf_radio/ssbagc.py
+%%UHD%%%%DATADIR%%/examples/hf_radio/ssbdemod.py
+%%UHD%%%%DATADIR%%/examples/hf_radio/startup.py
+%%UHD%%%%DATADIR%%/examples/hf_radio/ui.py
%%DATADIR%%/examples/metadata/file_metadata_sink.grc
%%DATADIR%%/examples/metadata/file_metadata_source.grc
%%DATADIR%%/examples/metadata/file_metadata_vector_sink.grc
@@ -2572,7 +2572,7 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/qt-gui/qtgui_vector_sink_example.grc
%%DATADIR%%/examples/qt-gui/test_qtgui_msg.grc
%%DATADIR%%/examples/tags/test_file_tags.py
-%%DATADIR%%/examples/tags/uhd_burst_detector.py
+%%UHD%%%%DATADIR%%/examples/tags/uhd_burst_detector.py
%%DATADIR%%/examples/trellis/README
%%DATADIR%%/examples/trellis/fsm_files/awgn1o1_16rsc.fsm
%%DATADIR%%/examples/trellis/fsm_files/awgn1o1_4rsc.fsm
@@ -2615,30 +2615,30 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/examples/trellis/test_tcm.py
%%DATADIR%%/examples/trellis/turbo_equalization.grc
%%DATADIR%%/examples/trellis/viterbi_equalization.grc
-%%DATADIR%%/examples/uhd/fm_tx4.py
-%%DATADIR%%/examples/uhd/fm_tx_2_daughterboards.py
-%%DATADIR%%/examples/uhd/max_power.py
-%%DATADIR%%/examples/uhd/tags_demo
-%%DATADIR%%/examples/uhd/uhd_const_wave.grc
-%%DATADIR%%/examples/uhd/uhd_dpsk_mod.grc
-%%DATADIR%%/examples/uhd/uhd_fft.grc
-%%DATADIR%%/examples/uhd/uhd_rx_dpsk.grc
-%%DATADIR%%/examples/uhd/uhd_two_tone_loopback.grc
-%%DATADIR%%/examples/uhd/uhd_tx_dpsk.grc
-%%DATADIR%%/examples/uhd/uhd_wbfm_receive.grc
-%%DATADIR%%/examples/uhd/usrp_am_mw_rcv.py
-%%DATADIR%%/examples/uhd/usrp_nbfm_ptt.py
-%%DATADIR%%/examples/uhd/usrp_nbfm_rcv.py
-%%DATADIR%%/examples/uhd/usrp_spectrum_sense.py
-%%DATADIR%%/examples/uhd/usrp_tv_rcv.py
-%%DATADIR%%/examples/uhd/usrp_tv_rcv_nogui.py
-%%DATADIR%%/examples/uhd/usrp_wfm_rcv.py
-%%DATADIR%%/examples/uhd/usrp_wfm_rcv2_nogui.py
-%%DATADIR%%/examples/uhd/usrp_wfm_rcv_fmdet.py
-%%DATADIR%%/examples/uhd/usrp_wfm_rcv_nogui.py
-%%DATADIR%%/examples/uhd/usrp_wfm_rcv_pll.py
-%%DATADIR%%/examples/uhd/usrp_wfm_rcv_sca.py
-%%DATADIR%%/examples/uhd/usrp_wxapt_rcv.py
+%%UHD%%%%DATADIR%%/examples/uhd/fm_tx4.py
+%%UHD%%%%DATADIR%%/examples/uhd/fm_tx_2_daughterboards.py
+%%UHD%%%%DATADIR%%/examples/uhd/max_power.py
+%%UHD%%%%DATADIR%%/examples/uhd/tags_demo
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_const_wave.grc
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_dpsk_mod.grc
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_fft.grc
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_rx_dpsk.grc
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_two_tone_loopback.grc
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_tx_dpsk.grc
+%%UHD%%%%DATADIR%%/examples/uhd/uhd_wbfm_receive.grc
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_am_mw_rcv.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_nbfm_ptt.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_nbfm_rcv.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_spectrum_sense.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_tv_rcv.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_tv_rcv_nogui.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wfm_rcv.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wfm_rcv2_nogui.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wfm_rcv_fmdet.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wfm_rcv_nogui.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wfm_rcv_pll.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wfm_rcv_sca.py
+%%UHD%%%%DATADIR%%/examples/uhd/usrp_wxapt_rcv.py
%%DATADIR%%/examples/vocoder/alaw_audio_loopback.py
%%DATADIR%%/examples/vocoder/codec2_audio_loopback.py
%%DATADIR%%/examples/vocoder/cvsd_audio_loopback.py
@@ -3113,10 +3113,10 @@ libexec/gnuradio/grc_setup_freedesktop
%%DATADIR%%/grc/blocks/trellis_siso_f.xml
%%DATADIR%%/grc/blocks/trellis_viterbi_combined_xx.xml
%%DATADIR%%/grc/blocks/trellis_viterbi_x.xml
-%%DATADIR%%/grc/blocks/uhd_amsg_source.xml
-%%DATADIR%%/grc/blocks/uhd_block_tree.xml
-%%DATADIR%%/grc/blocks/uhd_usrp_sink.xml
-%%DATADIR%%/grc/blocks/uhd_usrp_source.xml
+%%UHD%%%%DATADIR%%/grc/blocks/uhd_amsg_source.xml
+%%UHD%%%%DATADIR%%/grc/blocks/uhd_block_tree.xml
+%%UHD%%%%DATADIR%%/grc/blocks/uhd_usrp_sink.xml
+%%UHD%%%%DATADIR%%/grc/blocks/uhd_usrp_source.xml
%%DATADIR%%/grc/blocks/variable.xml
%%DATADIR%%/grc/blocks/variable_band_pass_filter_taps.xml
%%DATADIR%%/grc/blocks/variable_band_reject_filter_taps.xml