aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-09-10 13:14:50 +0000
commite1bfdfbe5665c963621e06f6bbfbbc2c000a804e (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /comms
parentf57bc4af665126de839ff734a08e57726e84da84 (diff)
downloadports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.tar.gz
ports-e1bfdfbe5665c963621e06f6bbfbbc2c000a804e.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Notes
Notes: svn path=/head/; revision=479406
Diffstat (limited to 'comms')
-rw-r--r--comms/dcf77pi/Makefile4
-rw-r--r--comms/direwolf/Makefile2
-rw-r--r--comms/hidapi/Makefile2
-rw-r--r--comms/libirman/Makefile2
-rw-r--r--comms/liquid-dsp/Makefile2
-rw-r--r--comms/nasawash/Makefile2
-rw-r--r--comms/nec2c/Makefile2
-rw-r--r--comms/splat/Makefile1
-rw-r--r--comms/svxlink/Makefile3
-rw-r--r--comms/thebridge/Makefile2
-rw-r--r--comms/tlf/Makefile2
-rw-r--r--comms/twpsk/Makefile2
-rw-r--r--comms/uhd/Makefile2
-rw-r--r--comms/wspr/Makefile2
14 files changed, 26 insertions, 4 deletions
diff --git a/comms/dcf77pi/Makefile b/comms/dcf77pi/Makefile
index 2e57c2602281..8b4f972e6e67 100644
--- a/comms/dcf77pi/Makefile
+++ b/comms/dcf77pi/Makefile
@@ -14,7 +14,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
LIB_DEPENDS= libjson-c.so:devel/json-c
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOXYGEN DOCS
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
DOXYGEN_ALL_TARGET= all doxygen
@@ -26,6 +26,8 @@ USE_LDCONFIG= yes
PATCH_STRIP= -p1
PORTDOCS= CHANGELOG.md README.md receiver.svg
+
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_PORTDOCS= html/*
INSTALL_TARGET= install-strip
diff --git a/comms/direwolf/Makefile b/comms/direwolf/Makefile
index ab2f08978f02..cffba9868298 100644
--- a/comms/direwolf/Makefile
+++ b/comms/direwolf/Makefile
@@ -24,6 +24,8 @@ SHEBANG_FILES= telemetry-toolkit/telem-bits.pl telemetry-toolkit/telem-parm.pl\
telemetry-toolkit/telem-data91.pl \
telemetry-toolkit/telem-unit.pl telemetry-toolkit/telem-balloon.pl
+OPTIONS_DEFINE= DOCS
+
post-patch:
${CP} ${FILESDIR}/Makefile.FreeBSD ${WRKSRC}
${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/dw-start.sh
diff --git a/comms/hidapi/Makefile b/comms/hidapi/Makefile
index 29012fee3c82..7cc1fc5f1b72 100644
--- a/comms/hidapi/Makefile
+++ b/comms/hidapi/Makefile
@@ -24,6 +24,8 @@ PORTDOCS= *
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
pre-configure:
@${CP} ${LOCALBASE}/share/gettext/config.rpath ${WRKSRC}
diff --git a/comms/libirman/Makefile b/comms/libirman/Makefile
index 0393f5ef339b..16bdec829d92 100644
--- a/comms/libirman/Makefile
+++ b/comms/libirman/Makefile
@@ -19,4 +19,6 @@ INSTALL_TARGET= install-strip
PORTDOCS= README TECHNICAL
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/comms/liquid-dsp/Makefile b/comms/liquid-dsp/Makefile
index 20427c8e3779..2798c359aa08 100644
--- a/comms/liquid-dsp/Makefile
+++ b/comms/liquid-dsp/Makefile
@@ -29,6 +29,8 @@ PORTDOCS= *
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
+OPTIONS_DEFINE= DOCS
+
pre-configure:
@cd ${WRKSRC}; ${SH} bootstrap.sh
diff --git a/comms/nasawash/Makefile b/comms/nasawash/Makefile
index 683c2c19f3a7..df13d1469500 100644
--- a/comms/nasawash/Makefile
+++ b/comms/nasawash/Makefile
@@ -17,6 +17,8 @@ USES= tar:tgz
PLIST_FILES= bin/nasawash
PORTDOCS= nasawash.txt nasawash.upd
+OPTIONS_DEFINE= DOCS
+
do-build:
${CC} ${CPPFLAGS} ${CFLAGS} -c -o ${WRKSRC}/nasawash.o ${WRKSRC}/nasawash.c
${CC} -o ${WRKSRC}/nasawash ${WRKSRC}/nasawash.o ${LIBS}
diff --git a/comms/nec2c/Makefile b/comms/nec2c/Makefile
index cbf7fdb30f57..7534db4b4b9c 100644
--- a/comms/nec2c/Makefile
+++ b/comms/nec2c/Makefile
@@ -14,7 +14,7 @@ COMMENT= Used to calculate antenna patterns useful to ham radio
LIB_DEPENDS= libccm.so:math/ccmath
-OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nec2c ${STAGEDIR}${PREFIX}/bin
diff --git a/comms/splat/Makefile b/comms/splat/Makefile
index 626dcc757c01..bfa2d7c53159 100644
--- a/comms/splat/Makefile
+++ b/comms/splat/Makefile
@@ -13,6 +13,7 @@ LICENSE= GPLv2
USES= tar:bzip2
PORTDOCS= README README2 CHANGES
+OPTIONS_DEFINE= DOCS
OPTIONS_SINGLE= SRM
OPTIONS_RADIO= HRM
OPTIONS_SINGLE_SRM= SRM_2X2 SRM_3X3 SRM_4X4 SRM_5X5 SRM_6X6 SRM_7X7 SRM_8X8
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 22db1be22ef9..78bb3e190051 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -36,7 +36,7 @@ CMAKE_ARGS+= -DUSE_QT:BOOL=NO
USE_LDCONFIG= yes
ALL_TARGET?= all man
-OPTIONS_DEFINE= DOXYGEN STATIC
+OPTIONS_DEFINE= DOXYGEN STATIC DOCS
STATIC_DESC= Build and install static libraries
STATIC_CMAKE_ON= -DBUILD_STATIC_LIBS=YES
.if ${PORTNAME}==svxlink
@@ -49,6 +49,7 @@ ALSA_CMAKE_ON= -DUSE_ALSA:BOOL=ON
OSS_CMAKE_OFF= -DUSE_OSS:BOOL=OFF
OSS_CMAKE_ON= -DUSE_OSS:BOOL=ON
.endif
+DOXYGEN_IMPLIES= DOCS
DOXYGEN_ALL_TARGET=doc
DOXYGEN_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen:BOOL=TRUE
DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen \
diff --git a/comms/thebridge/Makefile b/comms/thebridge/Makefile
index e1067f623068..d4e63c1db3b1 100644
--- a/comms/thebridge/Makefile
+++ b/comms/thebridge/Makefile
@@ -25,6 +25,8 @@ SHEBANG_FILES= addons/usermgmt.cgi
INSTALL_TARGET= install-strip
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} 's!tbdcmd=\/usr\/local!tbdcmd=${PREFIX}!'\
${WRKSRC}/addons/usermgmt.cgi
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index f978b216f124..d10b067e0c94 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -33,4 +33,6 @@ HAMLIB_CONFIGURE_ENABLE=hamlib
FLDIGI_LIB_DEPENDS= libxmlrpc.so:net/xmlrpc-c
FLDIGI_CONFIGURE_ENABLE=fldigi-xmlrpc
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/comms/twpsk/Makefile b/comms/twpsk/Makefile
index 52880d49dd62..2fd5506d4598 100644
--- a/comms/twpsk/Makefile
+++ b/comms/twpsk/Makefile
@@ -21,4 +21,6 @@ CFLAGS+= -L${LOCALBASE}/lib -I${PREFIX}/include
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PORTDOCS= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/comms/uhd/Makefile b/comms/uhd/Makefile
index 462a643ea306..912433571f34 100644
--- a/comms/uhd/Makefile
+++ b/comms/uhd/Makefile
@@ -48,7 +48,7 @@ CMAKE_ARGS+= -DPKG_LIB_DIR:STRING="share/uhd" -DUHD_TXRX_DEBUG_PRINTS="yes"
IMAGE_FILE= uhd-images_003.010.003.000-release.zip
-OPTIONS_DEFINE= DOXYGEN
+OPTIONS_DEFINE= DOXYGEN DOCS
#OPTIONS_DEFAULT= DOXYGEN
OPTIONS_SUB=yes
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 3ddc9f4f986a..8c8f67b21f38 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -35,6 +35,8 @@ MAKE_ENV+= PYTHONUSERBASE=${STAGEDIR}${PYTHONBASE}
#LDFLAGS+= -shared
VERSION= 4.00
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
pre-configure:
@${CP} ${FILESDIR}/wspr.sh.in ${WRKSRC}