aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-22 13:24:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-22 13:24:22 +0000
commit934175c3217de04d056fcf33cdfd5af019e6b494 (patch)
tree017b68d542f4e38be67c2ba9cca7b58231434a87 /comms
parenta6d43ac18f2b779d38eec563d6fccde34589db3b (diff)
downloadports-934175c3217de04d056fcf33cdfd5af019e6b494.tar.gz
ports-934175c3217de04d056fcf33cdfd5af019e6b494.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/smstools/Makefile42
-rw-r--r--comms/smstools/distinfo6
-rw-r--r--comms/smstools/files/patch-Makefile23
-rw-r--r--comms/smstools/files/patch-examples_smsd.conf.easy11
-rw-r--r--comms/smstools/files/patch-examples_smsd.conf.full61
-rw-r--r--comms/smstools/files/patch-install.sh65
-rw-r--r--comms/smstools/pkg-plist78
7 files changed, 125 insertions, 161 deletions
diff --git a/comms/smstools/Makefile b/comms/smstools/Makefile
index 66c4463650b1..f35d1b8d9a56 100644
--- a/comms/smstools/Makefile
+++ b/comms/smstools/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= smstools
-PORTVERSION= 2.2.18
-PORTREVISION= 1
+PORTVERSION= 2.2.20
CATEGORIES= comms
MASTER_SITES= http://www.meinemullemaus.de/smstools/packages/
@@ -16,15 +15,42 @@ COMMENT= Tools to handle Short Message Service
LIB_DEPENDS= mm:${PORTSDIR}/devel/mm
-WRKSRC= ${WRKDIR}/smstools
+WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GMAKE= yes
USE_RC_SUBR= smsd.sh
+SPOOLDIR?= /var/spool/sms
+PLIST_SUB+= PREFIX="${PREFIX}" \
+ SPOOLDIR="${SPOOLDIR}"
+
+DOCS= alarmhandler.html blacklist.html book.html butterfly.gif \
+ compiling.html configure.html configure2.html costs.html \
+ email.gif eventhandler.html faq.html fileformat.html \
+ gpl.html gpl_de.html hardwarecomp.html index.html \
+ license.html links.html paypalbutton.gif raster.gif \
+ references.html releasenotes.html run.html softwarecomp.html \
+ statformat.html statusmonitor.html support.gif support.html \
+ udh.html windows.html
+EXAMPLES= .procmailrc .qmailrc operator_logo1.sms operator_logo2.sms \
+ received_report.sms received_sms.sms send_sms.sms \
+ send_sms_unicode.sms smsd.conf.easy smsd.conf.full
+SCRIPTS= email2sms hex2bin hex2dec mysmsd sendsms sms sms2html \
+ sms2unicode sms2xml smsevent smsresend sql_demo unicode2sms
post-patch:
- @${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${WRKSRC}/src/smsd_cfg.c \
- ${WRKSRC}/install.sh \
- ${WRKSRC}/examples/smsd.conf.easy \
- ${WRKSRC}/examples/smsd.conf.full
+ @${REINPLACE_CMD} 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/install.sh
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/doc/,} ${DOCSDIR}/
+.endif
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/examples/,} ${EXAMPLESDIR}/
+.endif
+ @${INSTALL_SCRIPT} ${SCRIPTS:S,^,${WRKSRC}/scripts/,} ${PREFIX}/bin
+
+#post-install:
+ @${INSTALL_DATA} ${WRKSRC}/examples/smsd.conf.easy ${PREFIX}/etc/smsd.conf
.include <bsd.port.mk>
diff --git a/comms/smstools/distinfo b/comms/smstools/distinfo
index 6de77e0a7139..5c51e7a48eeb 100644
--- a/comms/smstools/distinfo
+++ b/comms/smstools/distinfo
@@ -1,3 +1,3 @@
-MD5 (smstools-2.2.18.tar.gz) = 3272133cebafc46de224e91d08a1d14f
-SHA256 (smstools-2.2.18.tar.gz) = ac2c2d6b506a9f22042623219825592d51c1eb22528367270b3603927e91c86b
-SIZE (smstools-2.2.18.tar.gz) = 176805
+MD5 (smstools-2.2.20.tar.gz) = 6d59c3815a7bdb8d2f1b8cfa71f1258d
+SHA256 (smstools-2.2.20.tar.gz) = 8eee958946332580bbe314f2e839734e633db487deb43bbb5d9bbc94b8f506bb
+SIZE (smstools-2.2.20.tar.gz) = 172234
diff --git a/comms/smstools/files/patch-Makefile b/comms/smstools/files/patch-Makefile
index 54caab8624e9..55fe33671c1c 100644
--- a/comms/smstools/files/patch-Makefile
+++ b/comms/smstools/files/patch-Makefile
@@ -1,27 +1,28 @@
---- Makefile Fri Apr 21 11:25:01 2006
-+++ Makefile Fri Apr 21 13:23:24 2006
-@@ -1,18 +1,18 @@
- # Makefile
+--- Makefile.old 2008-02-05 23:39:45.000000000 -0200
++++ Makefile 2008-02-05 23:40:48.000000000 -0200
+@@ -2,17 +2,17 @@
--VERSION=$(shell grep package_version src/version.h | cut -f2)
-+VERSION=2.0.7
+ VERSION=$(shell grep package_version src/version.h | cut -f2)
-compile:
- cd src && $(MAKE) -$(MAKEFLAGS)
-+all:
++all:
+ cd src && $(MAKE) $(MAKEFLAGS)
-install: compile
- ./install.sh
-+install:
++install:
+ @$(SH) ./install.sh
uninstall:
- ./uninstall.sh
+- ./uninstall.sh
++ @$(SH) ./uninstall.sh
clean:
- cd src && $(MAKE) -$(MAKEFLAGS) clean
+ cd src && $(MAKE) $(MAKEFLAGS) clean
- package: compile clean
- ./package.sh
+-package: compile clean
+- ./package.sh
++package: clean
++ @$(SH) ./package.sh
diff --git a/comms/smstools/files/patch-examples_smsd.conf.easy b/comms/smstools/files/patch-examples_smsd.conf.easy
deleted file mode 100644
index 7f083b27c9da..000000000000
--- a/comms/smstools/files/patch-examples_smsd.conf.easy
+++ /dev/null
@@ -1,11 +0,0 @@
---- examples/smsd.conf.easy.orig Sat Feb 4 14:52:06 2006
-+++ examples/smsd.conf.easy Fri Jul 20 09:41:03 2007
-@@ -5,6 +5,7 @@
- loglevel = 7
-
- [GSM1]
--device = /dev/ttyS0
-+device = /dev/cuad0
- incoming = yes
-+#baudrate = 9600
- #pin = 1111
diff --git a/comms/smstools/files/patch-examples_smsd.conf.full b/comms/smstools/files/patch-examples_smsd.conf.full
deleted file mode 100644
index a75f3e0be650..000000000000
--- a/comms/smstools/files/patch-examples_smsd.conf.full
+++ /dev/null
@@ -1,61 +0,0 @@
---- examples/smsd.conf.full.orig Sat Jul 29 14:58:42 2006
-+++ examples/smsd.conf.full Fri Jul 20 09:39:38 2007
-@@ -6,21 +6,21 @@
- #failed = /var/spool/sms/failed
- incoming = /var/spool/sms/incoming
- #sent = /var/spool/sms/sent
--mypath = /usr/local/bin
-+mypath = %%PREFIX%%/bin
- #logfile = /var/log/smsd.log
- loglevel = 7
--#alarmhandler = /usr/local/bin/alarmevent
-+#alarmhandler = %%PREFIX%%/bin/alarmevent
- alarmlevel = 4
- delaytime = 10
- errorsleeptime = 10
- blocktime = 3600
--#eventhandler = /usr/local/bin/smsevent
-+#eventhandler = %%PREFIX%%/bin/smsevent
- #stats = /var/log/smsd_stats
- #stats_interval = 3600
- #stats_no_zeroes = no
- #blacklist = /etc/smsd.black
- #whitelist = /etc/smsd.white
--#checkhandler = /usr/local/bin/smscheck
-+#checkhandler = %%PREFIX%%/bin/smscheck
- receive_before_send = no
- # autosplit 0=no 1=yes 2=with text numbers 3=concatenated
- autosplit = 3
-@@ -47,8 +47,8 @@
-
- [GSM1]
- init = ATE0+CPMS="SM"+CNMI=2,0,0,2,1
--# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0
--device = /dev/ttyS0
-+# Windows: /dev/com1, Solaris: /dev/cua/a, Linux /dev/ttyS0, FreeBSD /dev/cuad0
-+device = /dev/cuad0
- incoming = yes
- queues = OTHER
- #You don't need a PIN for mobile phones
-@@ -60,12 +60,12 @@
- cs_convert = yes
- report = no
- memory_start = 1
--#eventhandler = /usr/local/bin/smsevent
-+#eventhandler = %%PREFIX%%/bin/smsevent
-
- [GSM2]
- init = ATE0
--# Windows: /dev/com2, Solaris: /dev/cua/b, Linux /dev/ttyS1
--device = /dev/ttyS1
-+# Windows: /dev/com2, Solaris: /dev/cua/b, Linux /dev/ttyS1, FreeBSD /dev/cuad1
-+device = /dev/cuad1
- incoming = yes
- queues = OTHER
- #You don't need a PIN for mobile phones
-@@ -77,4 +77,4 @@
- cs_convert = yes
- report = no
- memory_start = 1
--#eventhandler = /usr/local/bin/smsevent
-+#eventhandler = %%PREFIX%%/bin/smsevent
diff --git a/comms/smstools/files/patch-install.sh b/comms/smstools/files/patch-install.sh
index 9c2e7f51864f..6ee29d743043 100644
--- a/comms/smstools/files/patch-install.sh
+++ b/comms/smstools/files/patch-install.sh
@@ -1,55 +1,26 @@
---- install.sh.orig Sat Jul 29 14:50:42 2006
-+++ install.sh Fri Jul 20 09:49:08 2007
-@@ -47,24 +47,35 @@
- fi
+--- install.sh.old 2008-02-05 23:45:04.000000000 -0200
++++ install.sh 2008-02-05 23:45:05.000000000 -0200
+@@ -2,7 +2,7 @@
+ #Do not run directly. This is a helper script for make.
- echo "Installing binary program files"
--makedir /usr/local
--makedir /usr/local/bin
- if [ -f src/smsd.exe ]; then
-- forcecopy src/smsd.exe /usr/local/bin/smsd.exe
-+ forcecopy src/smsd.exe %%PREFIX%%/bin/smsd.exe
- else
-- forcecopy src/smsd /usr/local/bin/smsd
-+ forcecopy src/smsd %%PREFIX%%/bin/smsd
- fi
--delete /usr/local/bin/getsms
--delete /usr/local/bin/putsms
+ # Remember to edit the config file if you change these default path's.
+-BINDIR=/usr/local/bin
++BINDIR=%%PREFIX%%/bin
+ SPOOLDIR=/var/spool/sms
- echo "Installing some scripts"
--copy scripts/sendsms /usr/local/bin/sendsms
--copy scripts/sms2html /usr/local/bin/sms2html
--copy scripts/sms2unicode /usr/local/bin/sms2unicode
--copy scripts/unicode2sms /usr/local/bin/unicode2sms
-+copy scripts/sendsms %%PREFIX%%/bin/sendsms
-+copy scripts/sms2html %%PREFIX%%/bin/sms2html
-+copy scripts/sms2unicode %%PREFIX%%/bin/sms2unicode
-+copy scripts/unicode2sms %%PREFIX%%/bin/unicode2sms
+
+@@ -68,7 +68,7 @@
+ copy scripts/unicode2sms $BINDIR/unicode2sms
echo "Installing config file"
-copy examples/smsd.conf.easy /etc/smsd.conf
-+copy examples/smsd.conf.full %%PREFIX%%/etc/smsd.conf.sample
-+
-+echo "Installing additional examples"
-+makedir %%EXAMPLESDIR%%
-+copy examples/operator_logo1.sms %%EXAMPLESDIR%%/operator_logo1.sms
-+copy examples/operator_logo2.sms %%EXAMPLESDIR%%/operator_logo2.sms
-+copy examples/received_report.sms %%EXAMPLESDIR%%/received_report.sms
-+copy examples/received_sms.sms %%EXAMPLESDIR%%/received_sms.sms
-+copy examples/send_sms.sms %%EXAMPLESDIR%%/send_sms.sms
-+copy examples/send_sms_unicode.sms %%EXAMPLESDIR%%/send_sms_unicode.sms
-+copy examples/smsd.conf.easy %%EXAMPLESDIR%%/smsd.conf.easy
-+copy examples/smsd.conf.full %%EXAMPLESDIR%%/smsd.conf.full
-+copy scripts/email2sms %%EXAMPLESDIR%%/email2sms
-+copy scripts/smsevent %%EXAMPLESDIR%%/smsevent
-+copy scripts/sql_demo %%EXAMPLESDIR%%/sql_demo
-+copy scripts/mysmsd %%EXAMPLESDIR%%/mysmsd
++copy examples/smsd.conf.easy %%PREFIX%%/etc/smsd.conf
echo "Creating minimum spool directories"
- makedir /var/spool
-@@ -73,15 +84,5 @@
- makedir /var/spool/sms/outgoing
- makedir /var/spool/sms/checked
+ makedir $SPOOLDIR
+@@ -76,15 +76,6 @@
+ makedir $SPOOLDIR/outgoing
+ makedir $SPOOLDIR/checked
-echo "Installing start-script"
-if [ -d /etc/init.d ]; then
@@ -61,6 +32,6 @@
-fi
-
echo ""
--echo "Example script files are not installed automatically."
+ echo "Example script files are not installed automatically."
-echo 'Please dont forget to edit /etc/smsd.conf.'
-+echo 'Please dont forget to create/edit %%PREFIX%%/etc/smsd.conf.'
++echo 'Please dont forget to edit %%PREFIX%%/etc/smsd.conf.'
diff --git a/comms/smstools/pkg-plist b/comms/smstools/pkg-plist
index d060fff4df09..fbf88add02c5 100644
--- a/comms/smstools/pkg-plist
+++ b/comms/smstools/pkg-plist
@@ -1,24 +1,62 @@
+bin/smsd
+bin/email2sms
+bin/hex2bin
+bin/hex2dec
+bin/mysmsd
bin/sendsms
+bin/sms
bin/sms2html
bin/sms2unicode
-bin/smsd
+bin/sms2xml
+bin/smsevent
+bin/smsresend
+bin/sql_demo
bin/unicode2sms
-etc/smsd.conf.sample
-%%EXAMPLESDIR%%/email2sms
-%%EXAMPLESDIR%%/mysmsd
-%%EXAMPLESDIR%%/operator_logo1.sms
-%%EXAMPLESDIR%%/operator_logo2.sms
-%%EXAMPLESDIR%%/received_report.sms
-%%EXAMPLESDIR%%/received_sms.sms
-%%EXAMPLESDIR%%/send_sms.sms
-%%EXAMPLESDIR%%/send_sms_unicode.sms
-%%EXAMPLESDIR%%/smsd.conf.easy
-%%EXAMPLESDIR%%/smsd.conf.full
-%%EXAMPLESDIR%%/smsevent
-%%EXAMPLESDIR%%/sql_demo
-@dirrm %%EXAMPLESDIR%%
-@cwd /
-@dirrm var/spool/sms/outgoing
-@dirrm var/spool/sms/incoming
-@dirrm var/spool/sms/checked
-@dirrm var/spool/sms
+etc/smsd.conf
+%%PORTDOCS%%%%DOCSDIR%%/alarmhandler.html
+%%PORTDOCS%%%%DOCSDIR%%/blacklist.html
+%%PORTDOCS%%%%DOCSDIR%%/book.html
+%%PORTDOCS%%%%DOCSDIR%%/butterfly.gif
+%%PORTDOCS%%%%DOCSDIR%%/compiling.html
+%%PORTDOCS%%%%DOCSDIR%%/configure.html
+%%PORTDOCS%%%%DOCSDIR%%/configure2.html
+%%PORTDOCS%%%%DOCSDIR%%/costs.html
+%%PORTDOCS%%%%DOCSDIR%%/email.gif
+%%PORTDOCS%%%%DOCSDIR%%/eventhandler.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/fileformat.html
+%%PORTDOCS%%%%DOCSDIR%%/gpl.html
+%%PORTDOCS%%%%DOCSDIR%%/gpl_de.html
+%%PORTDOCS%%%%DOCSDIR%%/hardwarecomp.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/links.html
+%%PORTDOCS%%%%DOCSDIR%%/paypalbutton.gif
+%%PORTDOCS%%%%DOCSDIR%%/raster.gif
+%%PORTDOCS%%%%DOCSDIR%%/references.html
+%%PORTDOCS%%%%DOCSDIR%%/releasenotes.html
+%%PORTDOCS%%%%DOCSDIR%%/run.html
+%%PORTDOCS%%%%DOCSDIR%%/softwarecomp.html
+%%PORTDOCS%%%%DOCSDIR%%/statformat.html
+%%PORTDOCS%%%%DOCSDIR%%/statusmonitor.html
+%%PORTDOCS%%%%DOCSDIR%%/support.gif
+%%PORTDOCS%%%%DOCSDIR%%/support.html
+%%PORTDOCS%%%%DOCSDIR%%/udh.html
+%%PORTDOCS%%%%DOCSDIR%%/windows.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.procmailrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/.qmailrc
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/operator_logo1.sms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/operator_logo2.sms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/received_report.sms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/received_sms.sms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/send_sms.sms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/send_sms_unicode.sms
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smsd.conf.easy
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/smsd.conf.full
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@exec mkdir -p %%SPOOLDIR%%/incoming %%SPOOLDIR%%/outgoing %%SPOOLDIR%%/checked
+@unexec echo "=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-="
+@unexec echo "If you are permanently removing smstools, you should also:" | /usr/bin/fmt
+@unexec echo "'rm -rf %%SPOOLDIR%%'" | /usr/bin/fmt
+@unexec echo "=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-="