aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2008-07-27 20:25:00 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2008-07-27 20:25:00 +0000
commit060c699a11d3e3d17f2799822580d8e1e35509ce (patch)
tree401df52978b2f7a2cbb7e1386b907f5368c2f982 /comms
parentd7d6622d5fe0bded40190ecb5bdc7e3484b5598b (diff)
downloadports-060c699a11d3e3d17f2799822580d8e1e35509ce.tar.gz
ports-060c699a11d3e3d17f2799822580d8e1e35509ce.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gnokii/Makefile107
-rw-r--r--comms/gnokii/files/pkg-message.in (renamed from comms/gnokii/pkg-message)6
2 files changed, 38 insertions, 75 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 983e8cb3768f..369a8e108986 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -1,13 +1,13 @@
-# New ports collection makefile for: gnokii
-# Date created: 15 March 1999
-# Whom: staffanu
+# New ports collection makefile for: gnokii
+# Date created: 15 March 1999
+# Whom: Staffan Ulfberg <staffanu@multivac.fatburen.org>
#
# $FreeBSD$
#
PORTNAME= gnokii
PORTVERSION= 0.6.26
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -18,12 +18,12 @@ MAINTAINER= mad@madpilot.net
COMMENT= Tools to talk to GSM cellular phones
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-USE_GMAKE= yes
USE_BZIP2= yes
+USE_GMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
+WANT_GNOME= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE} --enable-security \
--with-xgnokiidir=${PREFIX}/share
@@ -35,77 +35,49 @@ CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
PKGDEINSTALL= ${PKGINSTALL}
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-FIXPREFIX= Docs/man/gnokiid.8 Docs/DataCalls-QuickStart Docs/README \
- common/cfgreader.c po/et.po po/sl.po
-
-WANT_GNOME= yes
-
-.include <bsd.port.pre.mk>
-
-.if !defined(NOPORTDOCS)
+SUB_FILES+= pkg-message
+PORTDOCS= *
MAN1= gnokii.1 sendsms.1
MAN8= gnokiid.8 mgnokiidev.8
-PORTDOCS= *
-.endif
-
-.if exists(${LOCALBASE}/lib/libical.so)
-WITH_ICAL= yes
-.endif
-.if exists(${LOCALBASE}/lib/libusb.so)
-WITH_USB= yes
-.endif
+OPTIONS= ICAL "Build with IETF iCal support" off \
+ USB "Build with libusb support" off \
+ PCSC "Build with PC/SC-Lite support" off \
+ SMSD "Enable smsd daemon" off \
+ MYSQL "Enable MySQL support for smsd" off \
+ PGSQL "Enable PostgreSQL support for smsd" off \
+ X11 "Build graphical version (xgnokii)" on
-.if exists(${LOCALBASE}/lib/libpcsclite.so) && !defined(WITHOUT_PCSC)
-WITH_PCSC= yes
-.endif
+.include <bsd.port.pre.mk>
-.if defined(WITH_ICAL)
+.if exists(${LOCALBASE}/lib/libical.so) || defined(WITH_ICAL)
LIB_DEPENDS+= ical.27:${PORTSDIR}/devel/libical
.endif
-.if defined(WITH_USB)
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
-
-CONFIGURE_ARGS+= --enable-libusb
-.else
-CONFIGURE_ARGS+= --disable-libusb
+.if exists(${LOCALBASE}/lib/libusb.so) || defined(WITH_USB)
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
-.if defined(WITH_PCSC)
+.if exists(${LOCALBASE}/lib/libpcsclite.so) || defined(WITH_PCSC)
LIB_DEPENDS+= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-
-CONFIGURE_ARGS+= --enable-libpcsclite
-.else
-CONFIGURE_ARGS+= --disable-libpcsclite
.endif
-# If smsd is enabled check if MySQL or PostgreSQL are installed and
-# build the modules, no switches to make this port build those, if
-# you want them, just install them before this port. The port will
-# then activate a dependency.
.if !defined(WITH_SMSD)
-PLIST_SUB+= SMSD='@comment '
-PLIST_SUB+= PGM='@comment '
-PLIST_SUB+= MSM='@comment '
+PLIST_SUB+= SMSD='@comment ' MSM='@comment ' PGM='@comment '
CONFIGURE_ARGS+= --disable-smsd
.else
PLIST_SUB+= SMSD=''
-MAN8+= smsd.8
USE_GNOME+= glib20
+MAN8+= smsd.8
.if exists(${LOCALBASE}/lib/mysql/libmysqlclient.so) && !defined(WITHOUT_MYSQL)
USE_MYSQL= yes
PLIST_SUB+= MSM=''
-WITH_MYSQL= yes
.else
PLIST_SUB+= MSM='@comment '
.endif
.if exists(${LOCALBASE}/bin/psql) && !defined(WITHOUT_PGSQL)
USE_PGSQL= yes
PLIST_SUB+= PGM=''
-WITH_PGSQL= yes
.else
PLIST_SUB+= PGM='@comment '
.endif
@@ -116,25 +88,13 @@ CONFIGURE_ARGS+= --without-x
PLIST_SUB+= X11='@comment '
.else
USE_XORG= xpm
-USE_GNOME+= glib20 gtk20 libgnome
+USE_GNOME+= gtk20
PLIST_SUB+= X11=''
-.if !defined(NOPORTDOCS)
MAN1+= xgnokii.1
.endif
-.endif
-
-pre-fetch:
-.if !defined(WITH_SMSD)
- @${ECHO}
- @${ECHO} "If you plan using the smsd daemon for automatically receiving,"
- @${ECHO} "managing and sending SMSes define WITH_SMSD=yes."
- @${ECHO} "smsd has support for normal file system operations, MySQL and"
- @${ECHO} "PostgreSQL. If any of these 2 database systems are installed support"
- @${ECHO} "will be automatically compiled in. Normal file systems support is"
- @${ECHO} "always compiled in."
- @${ECHO}
-.endif
+FIXPREFIX= Docs/man/gnokiid.8 Docs/DataCalls-QuickStart Docs/README \
+ common/cfgreader.c po/et.po po/sl.po
post-patch:
.for f in ${FIXPREFIX}
@${REINPLACE_CMD} -e "s:/etc/gnokiirc:${PREFIX}/etc/gnokiirc:g" \
@@ -146,7 +106,7 @@ post-patch:
@${REINPLACE_CMD} -E -e "s:^(#ifdef.*)__OpenBSD__:\1__FreeBSD__:" \
${WRKSRC}/${f}
.endfor
-# fix test conditions on configure
+# fix test(1) conditions in configure script
@${REINPLACE_CMD} -E \
-e 's|([[:space:]]+test[[:space:]]+.+)==([[:space:]]+"yes")|\1=\2|' \
${WRKSRC}/${CONFIGURE_SCRIPT}
@@ -165,7 +125,6 @@ post-build:
@${REINPLACE_CMD} -e 's/^#libsmsd_pq_la_LIBADD/libsmsd_pq_la_LIBADD/' ${WRKSRC}/smsd/Makefile.in
.endif
.endif
- @${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${PKGDIR}/pkg-message > ${PKGMESSAGE}
pre-install:
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
@@ -174,22 +133,26 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/xgnokii/xgnokii.pc ${PREFIX}/libdata/pkgconfig
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if !defined(NOPORTDOCS)
- @(cd ${WRKSRC}/Docs && ${GMAKE} install)
+ ${GMAKE} install -C ${WRKSRC}/Docs
+.else
+ ${GMAKE} install -C ${WRKSRC}/Docs/man
.endif
${INSTALL_DATA} ${WRKSRC}/Docs/sample/gnokiirc \
${PREFIX}/etc/gnokiirc.sample
.if defined(WITH_SMSD)
@cd ${WRKSRC}/smsd && ${GMAKE} install
${MKDIR} ${PREFIX}/share/smsd
- ${INSTALL_SCRIPT} ${WRKSRC}/smsd/action ${PREFIX}/share/smsd/action
- ${INSTALL_DATA} ${WRKSRC}/smsd/README ${PREFIX}/share/smsd/README
+ ${INSTALL_SCRIPT} ${WRKSRC}/smsd/action ${PREFIX}/share/smsd
+ ${INSTALL_DATA} ${WRKSRC}/smsd/README ${PREFIX}/share/smsd
.if defined(WITH_MYSQL)
- ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.mysql.sql ${PREFIX}/share/smsd/sms.tables.mysql.sql
+ ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.mysql.sql ${PREFIX}/share/smsd
.endif
.if defined(WITH_PGSQL)
- ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.pq.sql ${PREFIX}/share/smsd/sms.tables.pq.sql
+ ${INSTALL_DATA} ${WRKSRC}/smsd/sms.tables.pq.sql ${PREFIX}/share/smsd
.endif
.endif
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.post.mk>
diff --git a/comms/gnokii/pkg-message b/comms/gnokii/files/pkg-message.in
index ec818f44ff0f..7f1b37d3d186 100644
--- a/comms/gnokii/pkg-message
+++ b/comms/gnokii/files/pkg-message.in
@@ -1,4 +1,4 @@
-================================================================================
+==============================================================================
The default config is installed in %%PREFIX%%/etc/gnokiirc.sample, and is
configured for Nokia 6210 phones connected on COM1. Have a look at the
documentation/manpages for more information. You'll need to copy
@@ -9,5 +9,5 @@ Add the users that shall be authorized to run gnokii programs to the
gnokii group.
NOTE: if you have enabled and plan using the smsd program check
-%%PREFIX%%/share/smsd/README
-================================================================================
+%%PREFIX%%/share/smsd/README.
+==============================================================================