aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-02-24 12:44:07 +0000
committerDiane Bruce <db@FreeBSD.org>2020-02-24 12:44:07 +0000
commitc30ce26dd11e39c70aa4d46eb68f48240c40ae67 (patch)
tree5e6c5d7b0dcd4780718fe67ba5bcf0774df287af /comms
parent4ab2ebe9d0e665253579ce0e107a53bcb157f0dc (diff)
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/digiham/Makefile23
-rw-r--r--comms/digiham/distinfo3
-rw-r--r--comms/digiham/pkg-descr7
-rw-r--r--comms/digiham/pkg-plist10
5 files changed, 44 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 80e5852820ea..5c4d328090f8 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -34,6 +34,7 @@
SUBDIR += deforaos-phone
SUBDIR += dfu-programmer
SUBDIR += dfu-util
+ SUBDIR += digiham
SUBDIR += direwolf
SUBDIR += dsd
SUBDIR += dump1090
diff --git a/comms/digiham/Makefile b/comms/digiham/Makefile
new file mode 100644
index 000000000000..23ba66a6bb1a
--- /dev/null
+++ b/comms/digiham/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= digiham
+DISTVERSION= 0.3.0
+CATEGORIES= comms hamradio
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Tools for decoding digital ham communication
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libmbe.so:comms/mbelib
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= jketterl
+GH_PROJECT= digiham
+
+post-install:
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/comms/digiham/distinfo b/comms/digiham/distinfo
new file mode 100644
index 000000000000..8d9ec583adf9
--- /dev/null
+++ b/comms/digiham/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1582527683
+SHA256 (jketterl-digiham-0.3.0_GH0.tar.gz) = 81242bca840a78c7aca0ba3a96fd3cb442ad41373085b4ddd0cfaac04fea7375
+SIZE (jketterl-digiham-0.3.0_GH0.tar.gz) = 68345
diff --git a/comms/digiham/pkg-descr b/comms/digiham/pkg-descr
new file mode 100644
index 000000000000..5fceca2a0e8e
--- /dev/null
+++ b/comms/digiham/pkg-descr
@@ -0,0 +1,7 @@
+This a simple set of command-line tools that is intended to
+be used to decode digital modulations used by ham radio
+operators. The main focus is on digital voice modes.
+
+Right now this project enables you to decode DMR and YSF.
+
+WWW: https://github.com/jketterl/digiham
diff --git a/comms/digiham/pkg-plist b/comms/digiham/pkg-plist
new file mode 100644
index 000000000000..937b9bfadae0
--- /dev/null
+++ b/comms/digiham/pkg-plist
@@ -0,0 +1,10 @@
+bin/rrc_filter
+bin/dc_block
+bin/gfsk_demodulator
+bin/dmr_decoder
+bin/ysf_decoder
+bin/mbe_synthesizer
+bin/digitalvoice_filter
+bin/fsk_demodulator
+bin/pocsag_decoder
+%%EXAMPLESDIR%%/dmr-decoder.sh