aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2011-02-11 14:17:16 +0000
committerDiane Bruce <db@FreeBSD.org>2011-02-11 14:17:16 +0000
commit146f3740439628dc1ac565af4e1f56a73eaa20d7 (patch)
treedc3ecb3cd84deff0dcec1d6000713baa85f9ac05 /comms
parent755770b0bb55205e29f0886831551e6a36e06c00 (diff)
downloadports-146f3740439628dc1ac565af4e1f56a73eaa20d7.tar.gz
ports-146f3740439628dc1ac565af4e1f56a73eaa20d7.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/ebook2cw/Makefile6
-rw-r--r--comms/ebook2cw/distinfo5
-rw-r--r--comms/ebook2cw/files/patch-Makefile27
3 files changed, 24 insertions, 14 deletions
diff --git a/comms/ebook2cw/Makefile b/comms/ebook2cw/Makefile
index ddc75dc5ca24..23c9c6fc21f3 100644
--- a/comms/ebook2cw/Makefile
+++ b/comms/ebook2cw/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ebook2cw
-PORTVERSION= 0.7.0
-PORTREVISION?= 1
+PORTVERSION= 0.8.0
CATEGORIES= comms hamradio
MASTER_SITES= http://fkurz.net/ham/ebook2cw/ \
${MASTER_SITE_LOCAL}
@@ -16,7 +15,8 @@ MASTER_SITE_SUBDIR= db
MAINTAINER= db@FreeBSD.org
COMMENT= Convert textfiles into cw as a mp3 file
-LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame
+LIB_DEPENDS= mp3lame:${PORTSDIR}/audio/lame \
+ vorbis:${PORTSDIR}/audio/libvorbis
MAN1= ebook2cw.1
diff --git a/comms/ebook2cw/distinfo b/comms/ebook2cw/distinfo
index 61de6fcd1689..af86668ead83 100644
--- a/comms/ebook2cw/distinfo
+++ b/comms/ebook2cw/distinfo
@@ -1,3 +1,2 @@
-MD5 (ebook2cw-0.7.0.tar.gz) = 77a2902ef19340ad8528514822d17518
-SHA256 (ebook2cw-0.7.0.tar.gz) = 1f4ce59f78f5519986cfa0a8f4f9ca4e38996ddc1842511a79179a247719a33a
-SIZE (ebook2cw-0.7.0.tar.gz) = 19580
+SHA256 (ebook2cw-0.8.0.tar.gz) = 4eea453ec7557ca2739de936343c2b872346bd8224f83f8e3d1d6cf34a713654
+SIZE (ebook2cw-0.8.0.tar.gz) = 25711
diff --git a/comms/ebook2cw/files/patch-Makefile b/comms/ebook2cw/files/patch-Makefile
index bf9c5e8f825b..e779293b3df0 100644
--- a/comms/ebook2cw/files/patch-Makefile
+++ b/comms/ebook2cw/files/patch-Makefile
@@ -1,17 +1,28 @@
---- Makefile.orig 2008-07-03 10:36:58.000000000 -0400
-+++ Makefile 2008-07-18 08:34:18.000000000 -0400
-@@ -1,12 +1,12 @@
+--- Makefile.orig 2011-01-25 16:10:27.000000000 -0500
++++ Makefile 2011-02-10 19:41:06.000000000 -0500
+@@ -1,19 +1,19 @@
# ebook2cw Makefile -- Fabian Kurz, DJ1YFK -- http://fkurz.net/ham/ebook2cw.html
- VERSION=0.7.0
+ VERSION=0.8.0
-DESTDIR ?= /usr
+DESTDIR ?= %%PREFIX%%
++CC ?= gcc
- all: ebook2cw
+-all: ebook2cw
++all: ebook2cw cgi
ebook2cw: ebook2cw.c codetables.h
-- gcc ebook2cw.c -pedantic -Wall -lm -lmp3lame -D VERSION=\"$(VERSION)\" -o ebook2cw
-+ ${CC} -I%%PREFIX%%/include -L%%PREFIX%%/lib ebook2cw.c ${CFLAGS} -lm -lmp3lame -D VERSION=\"$(VERSION)\" -o ebook2cw
+- gcc ebook2cw.c -pedantic -Wall -lm -lmp3lame -lvorbis -lvorbisenc -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
++ ${CC} -I%%PREFIX%%/include -L%%PREFIX%%/lib ebook2cw.c -pedantic -Wall -lm -lmp3lame -lvorbis -lvorbisenc -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
+
+ cgi: ebook2cw.c codetables.h
+- gcc -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -D CGI -o cw.cgi
++ ${CC} -I%%PREFIX%%/include -L%%PREFIX%%/lib -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -D CGI -o cw.cgi
static:
- gcc -static ebook2cw.c -lmp3lame -lm -D VERSION=\"$(VERSION)\" -o ebook2cw
+- gcc -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
+-
++ ${CC} -I%%PREFIX%% -L%%PREFIX%% -static ebook2cw.c -lvorbis -lvorbisenc -logg -lmp3lame -lm -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\" -o ebook2cw
+ install:
+ install -d -v $(DESTDIR)/share/man/man1/
+ install -d -v $(DESTDIR)/bin/