aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-01-25 09:28:51 +0000
committerJohn Marino <marino@FreeBSD.org>2014-01-25 09:28:51 +0000
commit5d2bf00922924786e751450b733a54620ca97b6d (patch)
treeb66ec22bd725110e940e87823982aa59f15c67f8 /comms
parente275f8d7de74f8c5cba5cc544d471689c5466b53 (diff)
downloadports-5d2bf00922924786e751450b733a54620ca97b6d.tar.gz
ports-5d2bf00922924786e751450b733a54620ca97b6d.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/xmorse/Makefile7
-rw-r--r--comms/xmorse/files/Makefile22
-rw-r--r--comms/xmorse/files/patch-Bargraph.cxx11
-rw-r--r--comms/xmorse/files/patch-Help.h11
-rw-r--r--comms/xmorse/files/patch-Makefile28
-rw-r--r--comms/xmorse/files/patch-m.fl22
6 files changed, 69 insertions, 32 deletions
diff --git a/comms/xmorse/Makefile b/comms/xmorse/Makefile
index 3f6450435743..0f300a839a4c 100644
--- a/comms/xmorse/Makefile
+++ b/comms/xmorse/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xmorse
PORTVERSION= 20041125
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= comms hamradio
MASTER_SITES= http://c2.com/morse/files/SourceCode/ \
http://www.525183.com/freebsd/xmorse/ \
@@ -21,6 +21,9 @@ USE_SDL= sdl
PLIST_FILES= bin/xmorse
NO_WRKSUBDIR= yes
+MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
+
+post-patch:
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/comms/xmorse/files/Makefile b/comms/xmorse/files/Makefile
new file mode 100644
index 000000000000..72e07f3327b6
--- /dev/null
+++ b/comms/xmorse/files/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+CXXFLAGS+= -MMD `fltk-config --cxxflags` `sdl-config --cflags`
+PREFIX ?= /usr/local
+INSTALL_PROGRAM ?= ${INSTALL} -o root -g wheel -m 755
+
+all: xmorse
+
+m.cxx: m.fl
+ fluid -c m.fl
+
+xmorse: m.o Bargraph.o Codebox.o Cw.o Knob.o
+ ${CXX} -o$@ $> `fltk-config --ldflags` `sdl-config --libs`
+
+install: xmorse
+ ${INSTALL_PROGRAM} xmorse ${PREFIX}/bin/xmorse
+
+clean:
+ -rm *.o
+ -rm *.d
+ -rm m.cxx m.h
+ -rm xmorse
diff --git a/comms/xmorse/files/patch-Bargraph.cxx b/comms/xmorse/files/patch-Bargraph.cxx
new file mode 100644
index 000000000000..a97a9d227f9f
--- /dev/null
+++ b/comms/xmorse/files/patch-Bargraph.cxx
@@ -0,0 +1,11 @@
+--- Bargraph.cxx.orig 2004-08-25 17:18:01.000000000 -0700
++++ Bargraph.cxx 2014-01-01 10:26:23.000000000 -0800
+@@ -82,7 +82,7 @@
+ if (child(i)->visible()) nd++;
+ int dx = w()/nd; // Slider horizontal "period"
+ int width = dx*nd - gap; // Width of slider array
+- int x0 = w()-width >> 1; // Inset to 1st slider
++ int x0 = (w()-width) >> 1; // Inset to 1st slider
+ width = dx-gap; // Width of individual Slider
+ for (int i = 0; i < children(); i++) { // Loop to reposition sliders
+ Fl_Slider* s = (Fl_Slider*) child(i); // Pointer to this Slider
diff --git a/comms/xmorse/files/patch-Help.h b/comms/xmorse/files/patch-Help.h
new file mode 100644
index 000000000000..1da75f6de43f
--- /dev/null
+++ b/comms/xmorse/files/patch-Help.h
@@ -0,0 +1,11 @@
+--- Help.h.orig 2014-01-01 10:24:05.000000000 -0800
++++ Help.h 2014-01-01 10:24:10.000000000 -0800
+@@ -2,7 +2,7 @@
+ * generated from the original HTML file by the script, help.py.
+ */
+
+-static char* HelpString =
++static const char* HelpString =
+ "<!DOCTYPE html PUBLIC \"-//W3C//DTD HTML 4.01 Transitional//EN\">\n"
+ "<html>\n"
+ "<head>\n"
diff --git a/comms/xmorse/files/patch-Makefile b/comms/xmorse/files/patch-Makefile
deleted file mode 100644
index 0ba313e35029..000000000000
--- a/comms/xmorse/files/patch-Makefile
+++ /dev/null
@@ -1,28 +0,0 @@
---- ./Makefile.orig 2004-09-29 22:12:16.000000000 +0000
-+++ ./Makefile 2007-11-24 19:55:15.000000000 +0000
-@@ -36,6 +36,25 @@
- strip m
- rm *.o m.cxx m.h
-
-+# Regular "make" is what you want for the FreeBSD version
-+
-+all: m.fl Bargraph.cxx Bargraph.h Codebox.cxx Codebox.h Cw.cxx Cw.h \
-+ Knob.cxx Knob.h Help.h m.fl
-+ fluid -c m.fl
-+ g++ -c -Os `fltk-config --cxxflags` m.cxx
-+ g++ -c -Os `fltk-config --cxxflags` Bargraph.cxx
-+ g++ -c -Os `fltk-config --cxxflags` Codebox.cxx
-+ g++ -c -Os `fltk-config --cxxflags` Knob.cxx
-+ g++ -c -Os `sdl-config --cflags` Cw.cxx
-+ g++ -om m.o Bargraph.o Codebox.o Cw.o Knob.o \
-+ `sdl-config --static-libs` \
-+ `fltk-config --ldstaticflags`
-+ strip m
-+ rm *.o m.cxx m.h
-+
-+install: m
-+ ${INSTALL} -o root -g wheel -m 0555 m ${PREFIX}/bin/xmorse
-+
- # Besemer's Python extension version
-
- cw.so: cw.pyx Cw.cxx Cw.h
diff --git a/comms/xmorse/files/patch-m.fl b/comms/xmorse/files/patch-m.fl
index 9bb6cec224aa..af83fabbff44 100644
--- a/comms/xmorse/files/patch-m.fl
+++ b/comms/xmorse/files/patch-m.fl
@@ -1,5 +1,23 @@
---- m.fl.orig 2011-07-17 14:56:20.000000000 -0400
-+++ m.fl 2011-07-17 14:56:31.000000000 -0400
+--- m.fl.orig 2004-08-13 16:38:24.000000000 -0700
++++ m.fl 2014-01-01 10:25:10.000000000 -0800
+@@ -188,7 +188,7 @@
+ }
+ menuitem {} {
+ label Numbers
+- callback {char* nrs = "0123456789";
++ callback {const char* nrs = "0123456789";
+ if (o->mvalue()->value())
+ Lesson->enable(nrs);
+ else
+@@ -199,7 +199,7 @@
+ }
+ menuitem {} {
+ label Symbols
+- callback {char* syms = "./=?";
++ callback {const char* syms = "./=?";
+ if (o->mvalue()->value())
+ Lesson->enable(syms);
+ else
@@ -231,7 +231,7 @@
}
}