aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2014-12-15 14:07:51 +0000
committerDiane Bruce <db@FreeBSD.org>2014-12-15 14:07:51 +0000
commita0921d30f87413815a44ce16101a002624ca98b5 (patch)
treec94896f3052d268e2180b88715208c125ea13cce /comms
parent81e4df835ef80a5b207c8b17aec031681c32574c (diff)
downloadports-a0921d30f87413815a44ce16101a002624ca98b5.tar.gz
ports-a0921d30f87413815a44ce16101a002624ca98b5.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/wspr/Makefile9
-rw-r--r--comms/wspr/files/patch-WsprMode_specjt.py14
-rw-r--r--comms/wspr/files/patch-wspr.py11
3 files changed, 31 insertions, 3 deletions
diff --git a/comms/wspr/Makefile b/comms/wspr/Makefile
index 358a684093c3..cd37b028d19b 100644
--- a/comms/wspr/Makefile
+++ b/comms/wspr/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wspr
DISTVERSION= ${VERSION}.r${SVN_REV}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= db
@@ -24,19 +24,22 @@ LIB_DEPENDS= libhamlib.so:${PORTSDIR}/comms/hamlib \
DISABLE_MAKE_JOBS= yes
USE_AUTOTOOLS= autoconf
-USES= fortran gmake libtool tar:bzip2 python:3.3
+USES= fortran gmake libtool tar:bzip2 python:3.3 dos2unix
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-gfortran=${FC} \
--with-f2py=f2py-${PYTHON_VER} \
--with-python3=${PYTHON_CMD}
MAKE_ENV+= PYTHONUSERBASE=${STAGEDIR}${PYTHONBASE}
-LDFLAGS+= -shared
+#LDFLAGS+= -shared
VERSION= 4.00
.include <bsd.port.pre.mk>
pre-configure:
@${CP} ${FILESDIR}/wspr.sh.in ${WRKSRC}
+do-build:
+ (cd ${WRKSRC};${GMAKE})
+
post-install:
.if defined(BOOTSTRAP)
#portlint freaks over this but it's only for dev ignore.
diff --git a/comms/wspr/files/patch-WsprMode_specjt.py b/comms/wspr/files/patch-WsprMode_specjt.py
new file mode 100644
index 000000000000..e991851916b8
--- /dev/null
+++ b/comms/wspr/files/patch-WsprMode_specjt.py
@@ -0,0 +1,14 @@
+--- WsprMod/specjt.py.orig 2014-12-14 19:17:21.630624057 -0500
++++ WsprMod/specjt.py 2014-12-14 19:19:41.021613990 -0500
+@@ -34,10 +34,7 @@
+ import tkinter.messagebox
+ from . import w
+
+-try:
+- from numpy.oldnumeric import zeros, multiarray
+-except:
+- from Numeric import zeros, multiarray
++from numpy import zeros, multiarray
+ import Image, ImageTk, ImageDraw
+ from .palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
diff --git a/comms/wspr/files/patch-wspr.py b/comms/wspr/files/patch-wspr.py
new file mode 100644
index 000000000000..1932d28ad5b2
--- /dev/null
+++ b/comms/wspr/files/patch-wspr.py
@@ -0,0 +1,11 @@
+--- wspr.py.orig 2014-12-14 19:16:10.079628932 -0500
++++ wspr.py 2014-12-14 19:16:18.894628427 -0500
+@@ -50,7 +50,7 @@
+ import Pmw
+ from WsprMod import palettes
+ from math import log10
+-from numpy.oldnumeric import zeros
++from numpy import zeros
+ import array
+ ##import dircache
+ from PIL import Image, ImageTk, ImageDraw