aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-09-15 18:35:24 +0000
committerAde Lovett <ade@FreeBSD.org>2010-09-15 18:35:24 +0000
commit8262a7b51d413e11ef8f67c56e862ebbc6f182de (patch)
tree1e9812bc2638933184cae2b226809eb69253bb9f /comms
parentbe8126109fa13097c8a0f9337fa9dfb68cf5d4c2 (diff)
downloadports-8262a7b51d413e11ef8f67c56e862ebbc6f182de.tar.gz
ports-8262a7b51d413e11ef8f67c56e862ebbc6f182de.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/aldo/Makefile8
-rw-r--r--comms/dfu-util/Makefile3
-rw-r--r--comms/gnuradio/Makefile8
-rw-r--r--comms/hamlib/Makefile3
-rw-r--r--comms/klog/Makefile4
-rw-r--r--comms/libsyncml/Makefile4
-rw-r--r--comms/tlf/Makefile3
-rw-r--r--comms/unixcw/Makefile3
-rw-r--r--comms/unixcw/files/patch-configure.ac2
9 files changed, 22 insertions, 16 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index 4ba55d838feb..3c7f0ce693c3 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -7,7 +7,7 @@
PORTNAME= aldo
PORTVERSION= 0.7.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,7 +19,7 @@ LIB_DEPENDS= ao:${PORTSDIR}/audio/libao
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf:262 automake:110 libtool:22
+USE_AUTOTOOLS= autoconf:267 automake:110 libtool:22
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib"
USE_GMAKE= yes
@@ -28,8 +28,8 @@ PLIST_FILES= bin/aldo
MAN1= aldo.1
post-patch:
- @${REINPLACE_CMD} -e 's|1.10|1.10.1|g' ${WRKSRC}/aclocal.m4
- @${REINPLACE_CMD} -e 's|2.61|2.62|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|1.10|1.10.3|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|2.61|2.67|g' ${WRKSRC}/aclocal.m4
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/aldo ${PREFIX}/bin
diff --git a/comms/dfu-util/Makefile b/comms/dfu-util/Makefile
index 92e5b538f395..e71c34f9647e 100644
--- a/comms/dfu-util/Makefile
+++ b/comms/dfu-util/Makefile
@@ -7,6 +7,7 @@
PORTNAME= dfu-util
DISTVERSION= 0.1.snap${SNAPDATE}
+PORTREVISION= 1
CATEGORIES= comms
MASTER_SITES= http://www.cran.org.uk/~brucec/software/
@@ -15,7 +16,7 @@ COMMENT= Device firmware update (DFU) USB programmer
MAN1= dfu-util.1
PLIST_FILES= bin/dfu-util
-USE_AUTOTOOLS= aclocal:19 automake:19 autoheader:262
+USE_AUTOTOOLS= aclocal:19 automake:19 autoheader:267
AUTOMAKE_ARGS= --add-missing --foreign --copy
SNAPDATE= 20090212
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 51660037cb0c..9e11753a3262 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnuradio
PORTVERSION= 3.1.3
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= comms astro hamradio
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= gnuradio
@@ -31,7 +31,7 @@ USE_PYTHON= 2.4+
USE_WX= 2.6+
WX_COMPS= wx wx:build wx:run python:build python:run
USE_PERL5= yes
-USE_AUTOTOOLS= autoconf:262 libtool:22
+USE_AUTOTOOLS= autoconf:267 libtool:22
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -56,7 +56,8 @@ LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|2.61|2.62|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|2.61|2.67|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|^GR_FORTRAN||g' ${WRKSRC}/configure.ac
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
-n 10 ${REINPLACE_CMD} -E -e \
's!^(ACLOCAL|AUTOCONF|AUTOMAKE|AUTOHEADER).+$$!\1=${TRUE}!' \
@@ -64,6 +65,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LIBDATA%%|${PREFIX}/libdata|' \
${WRKSRC}/gnuradio-core/Makefile.in ${WRKSRC}/usrp/Makefile.in \
${WRKSRC}/omnithread/Makefile.in ${WRKSRC}/gr-atsc/Makefile.in
+
pre-install:
@${CP} ${FILESDIR}/wxgui_src_python_init.py \
${WRKSRC}/gr-wxgui/src/python/__init__.py
diff --git a/comms/hamlib/Makefile b/comms/hamlib/Makefile
index 92dfab6dd950..ad32795a5665 100644
--- a/comms/hamlib/Makefile
+++ b/comms/hamlib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= hamlib
PORTVERSION= 1.2.11
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -20,7 +21,7 @@ USE_GNOME= pkgconfig gnomehack libxml2
USE_PERL5= yes
USE_TCL= yes
USE_PYTHON= yes
-USE_AUTOTOOLS= autoconf:262 libtool:22
+USE_AUTOTOOLS= autoconf:267 libtool:22
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-perl-binding --with-python=${PYTHON_CMD} \
diff --git a/comms/klog/Makefile b/comms/klog/Makefile
index d8eae89af5f4..b0492bc88f00 100644
--- a/comms/klog/Makefile
+++ b/comms/klog/Makefile
@@ -6,7 +6,7 @@
PORTNAME= klog
PORTVERSION= 0.4.2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= comms hamradio
MASTER_SITES= BERLIOS
@@ -17,7 +17,7 @@ LIB_DEPENDS= hamlib.2:${PORTSDIR}/comms/hamlib
USE_KDELIBS_VER= 3
USE_GMAKE= yes
-USE_AUTOTOOLS= autoconf:262:env automake:19:env libtool:22:env
+USE_AUTOTOOLS= autoconf:267:env automake:19:env libtool:22:env
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/comms/libsyncml/Makefile b/comms/libsyncml/Makefile
index 64aade612f7e..46455b7cf4d1 100644
--- a/comms/libsyncml/Makefile
+++ b/comms/libsyncml/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libsyncml
PORTVERSION= 0.4.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= comms
MASTER_SITES= http://libsyncml.opensync.org/download/releases/${PORTVERSION}/ \
http://mirror.roe.ch/dist/${PORTNAME}/
@@ -19,7 +19,7 @@ LIB_DEPENDS= wbxml2:${PORTSDIR}/textproc/wbxml2 \
openobex:${PORTSDIR}/comms/openobex \
soup-2.2.8:${PORTSDIR}/devel/libsoup22
-USE_AUTOTOOLS= autoheader:262 automake:110 libtool:22
+USE_AUTOTOOLS= autoheader:267 automake:110 libtool:22
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GNOME= glib20 libxml2
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index a55d59d6dd11..921b99b1845c 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tlf
PORTVERSION= 0.9.31
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/ \
${MASTER_SITE_LOCAL}
@@ -17,7 +18,7 @@ MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio curses based logging program
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_AUTOTOOLS= autoconf:262 libtool:22 aclocal:19 automake:19
+USE_AUTOTOOLS= autoconf:267 libtool:22 aclocal:19 automake:19
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
--libdir="${LOCALBASE}/lib"
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index 9c2b7a0673e8..d516d9d026a7 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -7,6 +7,7 @@
PORTNAME= unixcw
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://www.ibiblio.org/pub/linux/apps/ham/morse/ \
${MASTER_SITE_LOCAL}
@@ -31,7 +32,7 @@ PLIST_SUB+= XCWCP="@comment "
.endif
MAN7= cw.7 CW.7
MANCOMPRESSED= yes
-USE_AUTOTOOLS= autoconf:262
+USE_AUTOTOOLS= autoconf:267
USE_LDCONFIG= yes
USE_GMAKE= yes
diff --git a/comms/unixcw/files/patch-configure.ac b/comms/unixcw/files/patch-configure.ac
index 330e762acc71..8d836485f98d 100644
--- a/comms/unixcw/files/patch-configure.ac
+++ b/comms/unixcw/files/patch-configure.ac
@@ -5,7 +5,7 @@
# General initializations.
-AC_PREREQ(2.57)
-+AC_PREREQ(2.62)
++AC_PREREQ(2.67)
AC_INIT([UnixCW], 2.3, [simon_baldwin@yahoo.com])
-
# Specify a configuration header.