aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-22 20:06:14 +0000
commitffd97a0193e0238aa21bc32b570fd052292e0fe5 (patch)
treeb368198f913179c06dafd19ac72527fcf9836f6d /comms
parentccbdf54cacb9796580726f8d5278fe3fa53d5e53 (diff)
downloadports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.tar.gz
ports-ffd97a0193e0238aa21bc32b570fd052292e0fe5.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/cutecom/Makefile2
-rw-r--r--comms/gammu-devel/Makefile2
-rw-r--r--comms/gammu/Makefile2
-rw-r--r--comms/gnuradio/Makefile4
-rw-r--r--comms/openobex/Makefile3
-rw-r--r--comms/usbmuxd/Makefile2
-rw-r--r--comms/usrp/Makefile3
7 files changed, 7 insertions, 11 deletions
diff --git a/comms/cutecom/Makefile b/comms/cutecom/Makefile
index 209a5243b577..ece15458943a 100644
--- a/comms/cutecom/Makefile
+++ b/comms/cutecom/Makefile
@@ -17,7 +17,7 @@ COMMENT= Graphical serial terminal
RUN_DEPENDS= lsz:${PORTSDIR}/comms/lrzsz
USE_QT4= qt3support qmake_build moc_build rcc_build uic_build
-USE_CMAKE= yes
+USES= cmake
MAN1= cutecom.1
diff --git a/comms/gammu-devel/Makefile b/comms/gammu-devel/Makefile
index 71f961ff2d46..ac62397d9d1f 100644
--- a/comms/gammu-devel/Makefile
+++ b/comms/gammu-devel/Makefile
@@ -23,7 +23,7 @@ CONFLICTS= gammu-[1-9]* gammu-python-[1-9]*
CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
-USE_CMAKE= yes
+USES= cmake
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GNOME= glib20
diff --git a/comms/gammu/Makefile b/comms/gammu/Makefile
index 52d30de403c8..b2e07191791a 100644
--- a/comms/gammu/Makefile
+++ b/comms/gammu/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE= BASH
CMAKE_ARGS+= -DINSTALL_LIBDATA_DIR=${LOCALBASE}/libdata
-USE_CMAKE= yes
+USES= cmake
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GNOME= glib20
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 5940895e7ec8..5fb2caa837c9 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -30,9 +30,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_SITELIBDIR}/ephem/__init__.py:${PORTSDIR}/astro/pyephem\
${PYTHON_SITELIBDIR}/PyQt4/Qt.py:${PORTSDIR}/devel/py-qt4
-USE_CMAKE= yes
-CMAKE_VERBOSE= yes
-CMAKE_OUTSOURCE= yes
+USES= cmake:outsource
DOCSDIR= share/doc/${PORTNAME}-${PORTVERSION}
#CMAKE_ARGS= --debug-output --trace
CMAKE_ARGS=+ --debug-output
diff --git a/comms/openobex/Makefile b/comms/openobex/Makefile
index e53ce5aed395..f2fbf3253b05 100644
--- a/comms/openobex/Makefile
+++ b/comms/openobex/Makefile
@@ -10,9 +10,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-Source
MAINTAINER= madpilot@FreeBSD.org
COMMENT= Open source implementation of the OBEX protocol
-USE_CMAKE= yes
USE_LDCONFIG= yes
-USES= pathfix
+USES= pathfix cmake
MAKE_JOBS_SAFE= yes
USE_DOS2UNIX= CMakeLists.txt
CMAKE_ARGS+= -DPKGCONFIG_INSTALL_DIR:STRING="${PREFIX}/libdata/pkgconfig"
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
index d12b9e0be041..284071b2b5f1 100644
--- a/comms/usbmuxd/Makefile
+++ b/comms/usbmuxd/Makefile
@@ -12,7 +12,7 @@ COMMENT= Daemon for multiplexing connections over USB to an iPhone/iPod Touch
LIB_DEPENDS= plist:${PORTSDIR}/devel/libplist
USE_BZIP2= yes
-USE_CMAKE= yes
+USES= cmake
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
diff --git a/comms/usrp/Makefile b/comms/usrp/Makefile
index ccba33718b7f..bd65f2b5cc79 100644
--- a/comms/usrp/Makefile
+++ b/comms/usrp/Makefile
@@ -19,10 +19,9 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boos
sdcc:${PORTSDIR}/lang/sdcc
USE_DOS2UNIX= yes
-USE_CMAKE= yes
+USES= cmake:outsource
USE_GMAKE= yes
USE_LDCONFIG= yes
-CMAKE_OUTSOURCE= yes
CMAKE_SOURCE_PATH= ${WRKSRC}/host
# for excruciating debug use this -db