aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-24 16:58:57 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-04-24 16:58:57 +0000
commit647ad05c73b2149ba8bdef07aa49dff72fdbb1d5 (patch)
tree8ab8db7eead68482f5c4ec9f6f48bfb1019c9a3f /comms
parent76d133ba80bb0b4879c0ce091d037aea539cd3c5 (diff)
downloadports-647ad05c73b2149ba8bdef07aa49dff72fdbb1d5.tar.gz
ports-647ad05c73b2149ba8bdef07aa49dff72fdbb1d5.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/p5-Cisco-UCS/Makefile25
-rw-r--r--comms/p5-Cisco-UCS/distinfo2
-rw-r--r--comms/p5-Cisco-UCS/pkg-descr11
-rw-r--r--comms/p5-Cisco-UCS/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 19593a2db10d..befb9314549c 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -90,6 +90,7 @@
SUBDIR += o2sms
SUBDIR += obexapp
SUBDIR += openobex
+ SUBDIR += p5-Cisco-UCS
SUBDIR += p5-Device-Gsm
SUBDIR += p5-Device-Modem
SUBDIR += p5-Device-SerialPort
diff --git a/comms/p5-Cisco-UCS/Makefile b/comms/p5-Cisco-UCS/Makefile
new file mode 100644
index 000000000000..4d0a91de3edc
--- /dev/null
+++ b/comms/p5-Cisco-UCS/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Cisco-UCS
+# Date created: 2012-04-11
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cisco-UCS
+PORTVERSION= 0.031
+CATEGORIES= comms perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= A Perl interface to the Cisco UCS XML API
+
+BUILD_DEPENDS= p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Cisco::UCS.3
+
+.include <bsd.port.mk>
diff --git a/comms/p5-Cisco-UCS/distinfo b/comms/p5-Cisco-UCS/distinfo
new file mode 100644
index 000000000000..da6cc2eba876
--- /dev/null
+++ b/comms/p5-Cisco-UCS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Cisco-UCS-0.031.tar.gz) = 9efe14ecfb37cc033ca81a0658da902f76f4858e3edf1a45aac193492df65130
+SIZE (Cisco-UCS-0.031.tar.gz) = 10745
diff --git a/comms/p5-Cisco-UCS/pkg-descr b/comms/p5-Cisco-UCS/pkg-descr
new file mode 100644
index 000000000000..37d39c7fe01c
--- /dev/null
+++ b/comms/p5-Cisco-UCS/pkg-descr
@@ -0,0 +1,11 @@
+This package provides an abstracted interface to the Cisco UCS Manager XML API
+and Cisco UCS Management Information Model.
+
+The Cisco UCS Manager (UCSM) is an embedded software agent providing access to
+the hardware and configuration management features of attached Cisco UCS
+hardware. The Management Information Model for the UCSM is organised into a
+structured heirachy of both physical and virtual objects. Accessing objects
+within the heirachy is done through a number of high level calls to heirachy
+search and traversal methods
+
+WWW: http://search.cpan.org/dist/Cisco-UCS/
diff --git a/comms/p5-Cisco-UCS/pkg-plist b/comms/p5-Cisco-UCS/pkg-plist
new file mode 100644
index 000000000000..d678b977a675
--- /dev/null
+++ b/comms/p5-Cisco-UCS/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Cisco/UCS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/UCS/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/UCS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco
+@dirrmtry %%SITE_PERL%%/Cisco