aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2014-06-27 19:55:50 +0000
committerStephen Hurd <shurd@FreeBSD.org>2014-06-27 19:55:50 +0000
commit230f3ffa567c52009c76a187de20fd94bdbdbb0b (patch)
tree5f173e18f4c7c9108d39ad3641e2f0585cf3982e /comms
parent37a172c645dfe6a1f9fdf03d903e7da5f91ff0a2 (diff)
downloadports-230f3ffa567c52009c76a187de20fd94bdbdbb0b.tar.gz
ports-230f3ffa567c52009c76a187de20fd94bdbdbb0b.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/tlf/Makefile15
-rw-r--r--comms/tlf/files/patch-configure.in25
-rw-r--r--comms/tlf/files/patch-doc_Makefile.am10
-rw-r--r--comms/tlf/files/patch-rules_Makefile.am40
-rw-r--r--comms/tlf/files/patch-scripts_Makefile.am11
-rw-r--r--comms/tlf/files/patch-share_Makefile.am26
-rw-r--r--comms/tlf/pkg-plist1
7 files changed, 98 insertions, 30 deletions
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index e8d2413635cd..e985fcca5c0c 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -10,24 +10,23 @@ MASTER_SITES= http://sharon.esrac.ele.tue.nl/pub/linux/ham/tlf/ \
MASTER_SITE_SUBDIR= db
DISTNAME= tlf-0.9.31-2
-MAINTAINER= db@FreeBSD.org
+MAINTAINER= hamradio@FreeBSD.org
COMMENT= Amateur Radio curses based logging program
+LICENSE= GPLv2
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_AUTOTOOLS= autoconf libtool aclocal automake
+USE_AUTOTOOLS= autoconf aclocal automake
+USES= libtool
AUTOMAKE_ARGS= --add-missing
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --includedir="${LOCALBASE}/include" \
- --libdir="${LOCALBASE}/lib"
-LDFLAGS+= ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
OPTIONS_DEFINE= HAMLIB
HAMLIB_DESC= Use hamlib
OPTION_DEFAULT= HAMLIB
-MAN1= tlf.1
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MHAMLIB}
diff --git a/comms/tlf/files/patch-configure.in b/comms/tlf/files/patch-configure.in
index de3e7187097b..5f9059b36a15 100644
--- a/comms/tlf/files/patch-configure.in
+++ b/comms/tlf/files/patch-configure.in
@@ -1,25 +1,6 @@
---- configure.in.orig Wed Apr 5 03:22:01 2006
-+++ configure.in Tue Nov 21 14:23:37 2006
-@@ -8,6 +8,10 @@
- AC_PROG_INSTALL
- AC_PROG_AWK
-
-+CPPFLAGS="-I${includedir}"
-+LDFLAGS="-L${libdir}"
-+LIBS="-L${libdir} ${LIBS}"
-+
- # Checks for header files.
- AC_HEADER_STDC
- AC_CHECK_HEADERS([fcntl.h stdlib.h string.h sys/ioctl.h unistd.h])
-@@ -22,6 +26,7 @@
- #AC_CHECK_LIB(hamlib,main,,AC_MSG_ERROR([Hamradio control libraries (hamlib) not found! ABORTED!]))
- #AC_CHECK_HEADERS(hamlib/rig.h hamlib/riglist.h,,AC_MSG_ERROR([hamlib header(s) not found! ABORTED]))
-
-+
- dnl Check if we want to link the Hamradio control libraries (hamlib)
- AC_ARG_ENABLE([hamlib],
- [  --enable-hamlib   Add support for hamradio control libraries],
-@@ -33,7 +38,7 @@
+--- configure.in.orig 2007-12-19 04:59:39.000000000 -0800
++++ configure.in 2014-06-21 03:37:13.000000000 -0700
+@@ -33,7 +33,7 @@
[wanthamlib=false])
if test "x${wanthamlib}" != "xfalse"; then
diff --git a/comms/tlf/files/patch-doc_Makefile.am b/comms/tlf/files/patch-doc_Makefile.am
new file mode 100644
index 000000000000..ab93859129e2
--- /dev/null
+++ b/comms/tlf/files/patch-doc_Makefile.am
@@ -0,0 +1,10 @@
+--- doc/Makefile.am.orig 2014-06-21 03:59:01.000000000 -0700
++++ doc/Makefile.am 2014-06-21 03:59:22.000000000 -0700
+@@ -3,5 +3,5 @@
+ CLEANFILES = *~
+
+ install-data-local:
+- $(mkinstalldirs) $(pkgdatadir)/doc
+- install -m 0644 README $(pkgdatadir)/doc
++ $(mkinstalldirs) ${DESTDIR}$(pkgdatadir)/doc
++ install -m 0644 README ${DESTDIR}$(pkgdatadir)/doc
diff --git a/comms/tlf/files/patch-rules_Makefile.am b/comms/tlf/files/patch-rules_Makefile.am
new file mode 100644
index 000000000000..59a26081ad85
--- /dev/null
+++ b/comms/tlf/files/patch-rules_Makefile.am
@@ -0,0 +1,40 @@
+--- rules/Makefile.am.orig 2014-06-21 04:03:17.000000000 -0700
++++ rules/Makefile.am 2014-06-21 04:03:54.000000000 -0700
+@@ -6,20 +6,20 @@
+ CLEANFILES = *~
+
+ install-data-local:
+- $(mkinstalldirs) $(pkgdatadir)/rules
+- install -m 0644 arrldx_dx $(pkgdatadir)/rules
+- install -m 0644 arrldx_usa $(pkgdatadir)/rules
+- install -m 0644 arrlfd $(pkgdatadir)/rules
+- install -m 0644 arrlss $(pkgdatadir)/rules
+- install -m 0644 cqww $(pkgdatadir)/rules
+- install -m 0644 dxped $(pkgdatadir)/rules
+- install -m 0644 eusprint $(pkgdatadir)/rules
+- install -m 0644 lzdx $(pkgdatadir)/rules
+- install -m 0644 pacc_pa $(pkgdatadir)/rules
+- install -m 0644 pacc_dx $(pkgdatadir)/rules
+- install -m 0644 qso $(pkgdatadir)/rules
+- install -m 0644 spdx_dx $(pkgdatadir)/rules
+- install -m 0644 spdx_sp $(pkgdatadir)/rules
+- install -m 0644 ssa_mt $(pkgdatadir)/rules
+- install -m 0644 template $(pkgdatadir)/rules
+- install -m 0644 wpx $(pkgdatadir)/rules
++ $(mkinstalldirs) ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 arrldx_dx ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 arrldx_usa ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 arrlfd ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 arrlss ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 cqww ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 dxped ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 eusprint ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 lzdx ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 pacc_pa ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 pacc_dx ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 qso ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 spdx_dx ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 spdx_sp ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 ssa_mt ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 template ${DESTDIR}$(pkgdatadir)/rules
++ install -m 0644 wpx ${DESTDIR}$(pkgdatadir)/rules
diff --git a/comms/tlf/files/patch-scripts_Makefile.am b/comms/tlf/files/patch-scripts_Makefile.am
new file mode 100644
index 000000000000..b87f9cda2cb9
--- /dev/null
+++ b/comms/tlf/files/patch-scripts_Makefile.am
@@ -0,0 +1,11 @@
+--- scripts/Makefile.am.orig 2014-06-21 04:11:09.000000000 -0700
++++ scripts/Makefile.am 2014-06-21 04:11:27.000000000 -0700
+@@ -3,7 +3,7 @@
+ CLEANFILES = *~
+
+ install-exec-local:
+- install soundlog $(bindir)
++ install soundlog ${DESTDIR}$(bindir)
+
+ uninstall:
+ rm -f $(bindir)/soundlog
diff --git a/comms/tlf/files/patch-share_Makefile.am b/comms/tlf/files/patch-share_Makefile.am
new file mode 100644
index 000000000000..0a46492fcf36
--- /dev/null
+++ b/comms/tlf/files/patch-share_Makefile.am
@@ -0,0 +1,26 @@
+--- share/Makefile.am.orig 2014-06-21 04:10:12.000000000 -0700
++++ share/Makefile.am 2014-06-21 04:10:22.000000000 -0700
+@@ -4,14 +4,14 @@
+ spdxmults ssamults
+
+ install-data-local:
+- install -m 0644 callmaster $(pkgdatadir)
+- install -m 0644 cty.dat $(pkgdatadir)
+- install -m 0644 logcfg.dat $(pkgdatadir)
+- install -m 0644 arrlsections $(pkgdatadir)
+- install -m 0644 ea_sections $(pkgdatadir)
+- install -m 0644 paccmults $(pkgdatadir)
+- install -m 0644 spdxmults $(pkgdatadir)
+- install -m 0644 ssamults $(pkgdatadir)
++ install -m 0644 callmaster ${DESTDIR}$(pkgdatadir)
++ install -m 0644 cty.dat ${DESTDIR}$(pkgdatadir)
++ install -m 0644 logcfg.dat ${DESTDIR}$(pkgdatadir)
++ install -m 0644 arrlsections ${DESTDIR}$(pkgdatadir)
++ install -m 0644 ea_sections ${DESTDIR}$(pkgdatadir)
++ install -m 0644 paccmults ${DESTDIR}$(pkgdatadir)
++ install -m 0644 spdxmults ${DESTDIR}$(pkgdatadir)
++ install -m 0644 ssamults ${DESTDIR}$(pkgdatadir)
+
+ uninstall:
+- rm -rf $(pkgdatadir)
++ rm -rf ${DESTDIR}$(pkgdatadir)
diff --git a/comms/tlf/pkg-plist b/comms/tlf/pkg-plist
index 2e1c374c8b8d..aa9a8c1eb189 100644
--- a/comms/tlf/pkg-plist
+++ b/comms/tlf/pkg-plist
@@ -1,5 +1,6 @@
bin/soundlog
bin/tlf
+man/man1/tlf.1.gz
%%DATADIR%%/arrlsections
%%DATADIR%%/callmaster
%%DATADIR%%/cty.dat