aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-05 20:15:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-05 20:15:24 +0000
commit65abc0fc9bc4c9dd012b9b52d2c1ca300af67abb (patch)
tree2d8c9fae32b08d7069d3c481c5f7992d1b9818b6 /comms
parent52712e9bc86eee6edb3d0c17f8ad50e6af465176 (diff)
downloadports-65abc0fc9bc4c9dd012b9b52d2c1ca300af67abb.tar.gz
ports-65abc0fc9bc4c9dd012b9b52d2c1ca300af67abb.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/xastir/Makefile107
-rw-r--r--comms/xastir/distinfo2
-rw-r--r--comms/xastir/pkg-descr10
-rw-r--r--comms/xastir/pkg-message14
-rw-r--r--comms/xastir/pkg-plist103
6 files changed, 237 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 01b43f17f1a3..5c043b547448 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -83,6 +83,7 @@
SUBDIR += vpb2
SUBDIR += vrflash
SUBDIR += wy60
+ SUBDIR += xastir
SUBDIR += xcept
SUBDIR += xdx
SUBDIR += xlog
diff --git a/comms/xastir/Makefile b/comms/xastir/Makefile
new file mode 100644
index 000000000000..c29153fa1418
--- /dev/null
+++ b/comms/xastir/Makefile
@@ -0,0 +1,107 @@
+# New ports collection makefile for: xastir
+# Date created: 17th June 2004
+# Whom: Carl Makin <carl@stagecraft.cx>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xastir
+PORTVERSION= 1.3.2
+CATEGORIES= comms
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= xastir
+
+MAINTAINER= carl@stagecraft.cx
+COMMENT= X Amateur Station Tracking and Information Reporting
+
+RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg:${PORTSDIR}/graphics/jpeg \
+ png:${PORTSDIR}/graphics/png
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_MOTIF= yes
+USE_REINPLACE= yes
+
+MAN1= xastir.1
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+OPTIONS= SHAPELIB "Include Shapelib support" On \
+ PCRE "Include Perl Compatible Regular Expression Support" On \
+ DBFAWK "Include DBFAWK Support" On \
+ MAGICK "Include ImageMagick Support" On \
+ CURL "Include CURL Internet Image support" On \
+ GDAL "Include GDAL Support" Off \
+ GPSMAN "Include GPSMAN Support" Off \
+ FESTIVAL "Include Festival Voice Synthesis Support" Off \
+ OPTCFLAGS "Use optimized CFLAGS (-O2 -pipe)" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FESTIVAL)
+RUN_DEPENDS+= festival:${PORTSDIR}/audio/festival
+.else
+CONFIGURE_ARGS+= --without-festival
+.endif
+
+.if defined(WITH_GPSMAN)
+RUN_DEPENDS+= gpsman:${PORTSDIR}/astro/gpsman
+WITH_SHAPELIB= true
+.undef WITHOUT_SHAPELIB
+.else
+CONFIGURE_ARGS+= --without-gpsman
+.endif
+
+.if defined(WITHOUT_SHAPELIB)
+CONFIGURE_ARGS+= --without-shapelib
+.else
+LIB_DEPENDS+= shp.1:${PORTSDIR}/devel/shapelib
+.endif
+
+.if defined(WITHOUT_MAGICK)
+CONFIGURE_ARGS+= --without-imagemagick
+.else
+LIB_DEPENDS+= Magick:${PORTSDIR}/graphics/ImageMagick
+.endif
+
+.if defined(WITHOUT_DBFAWK)
+CONFIGURE_ARGS+= --without-dbfawk
+WITH_PCRE= true
+.undef WITHOUT_PCRE
+.endif
+
+.if defined(WITHOUT_PCRE)
+CONFIGURE_ARGS+= --without-pcre
+.else
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+.endif
+
+.if !defined(WITHOUT_CURL)
+LIB_DEPENDS+= curl:${PORTSDIR}/ftp/curl
+.endif
+
+.if defined(WITH_GDAL)
+LIB_DEPENDS+= gdal:${PORTSDIR}/graphics/gdal
+.else
+CONFIGURE_ARGS+= --without-gdal
+.endif
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+WITH_OPTCFLAGS= true
+.endif
+
+# OPTIMIZED_CFLAGS is too big for the OPTIONS variable to draw on the screen.
+.if defined(WITH_OPTCFLAGS)
+CFLAGS+= -O2 -pipe
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||' ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+ @${SED} 's|%%PREFIX%%|${PREFIX}|g' ${.CURDIR}/pkg-message > ${PKGMESSAGE}
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/comms/xastir/distinfo b/comms/xastir/distinfo
new file mode 100644
index 000000000000..e26d461e8e8f
--- /dev/null
+++ b/comms/xastir/distinfo
@@ -0,0 +1,2 @@
+MD5 (xastir-1.3.2.tar.gz) = 6d906c107bf778f294371198d72cc088
+SIZE (xastir-1.3.2.tar.gz) = 1281063
diff --git a/comms/xastir/pkg-descr b/comms/xastir/pkg-descr
new file mode 100644
index 000000000000..b8eebb17dca3
--- /dev/null
+++ b/comms/xastir/pkg-descr
@@ -0,0 +1,10 @@
+Xastir is an APRS client program that uses amateur radio and internet
+services to convey GPS mapping, weather, and positional data in a
+graphical application. It has been developed by and for amateur
+radio enthusiasts to provide real-time data in an easy to use
+package.
+
+WWW: http://www.xastir.org/
+
+- Carl
+carl@stagecraft.cx
diff --git a/comms/xastir/pkg-message b/comms/xastir/pkg-message
new file mode 100644
index 000000000000..d5708a3acfcf
--- /dev/null
+++ b/comms/xastir/pkg-message
@@ -0,0 +1,14 @@
+********************************************************************
+Xastir is now installed.
+
+Hop on over to http://www.xastir.org/ for details on getting
+maps and for more information on using Xastir.
+
+Your map directory is %%PREFIX%%/share/xastir/maps
+
+WARNING! File locations have changed since Xastir 1.2.0 (the stable
+version). What used to be in /usr/local/xastir is now in
+%%PREFIX%%/share/xastir. If you are upgrading from 1.2.0 or earlier
+then you need to follow the instructions in the UPGRADING document
+in %%PREFIX%%/share/xastir/doc.
+********************************************************************
diff --git a/comms/xastir/pkg-plist b/comms/xastir/pkg-plist
new file mode 100644
index 000000000000..3f6ab9867b34
--- /dev/null
+++ b/comms/xastir/pkg-plist
@@ -0,0 +1,103 @@
+bin/callpass
+bin/xastir
+lib/xastir/Coordinate.pm
+lib/xastir/coord-convert.pl
+lib/xastir/fcc-get
+lib/xastir/icontable.pl
+lib/xastir/inf2geo.pl
+lib/xastir/mapblast2geo.pl
+lib/xastir/mapfgd.pl
+lib/xastir/overlay.pl
+lib/xastir/ozi2geo.pl
+lib/xastir/permutations.pl
+lib/xastir/split_gnis.bash
+lib/xastir/split_gnis.pl
+lib/xastir/test_coord.pl
+lib/xastir/track-get.pl
+lib/xastir/update_langfile.pl
+lib/xastir/waypoint-get.pl
+lib/xastir/xastir-fixcfg.sh
+lib/xastir/xastir-migrate.sh
+share/xastir/Counties/placeholder
+share/xastir/GNIS/placeholder
+share/xastir/config/language-Dutch.sys
+share/xastir/config/language-English.sys
+share/xastir/config/language-French.sys
+share/xastir/config/language-German.sys
+share/xastir/config/language-Italian.sys
+share/xastir/config/language-Portuguese.sys
+share/xastir/config/language-Spanish.sys
+share/xastir/config/nwsc_ddmmyy.dbfawk
+share/xastir/config/nwsfz_ddmmyy.dbfawk
+share/xastir/config/nwsmzddmmyy.dbfawk
+share/xastir/config/nwsozddmmyy.dbfawk
+share/xastir/config/nwsw_ddmmyy.dbfawk
+share/xastir/config/nwsz_ddmmyy.dbfawk
+share/xastir/config/tgr2shp.dbfawk
+share/xastir/config/tgrcty.dbfawk
+share/xastir/config/tgrkgl.dbfawk
+share/xastir/config/tgrlk.dbfawk
+share/xastir/config/tgrlpt.dbfawk
+share/xastir/config/tgrlpy.dbfawk
+share/xastir/config/tgrplc00.dbfawk
+share/xastir/config/tgrwat.dbfawk
+share/xastir/config/tnc-startup.aea
+share/xastir/config/tnc-startup.kam
+share/xastir/config/tnc-startup.kpc3
+share/xastir/config/tnc-startup.pico
+share/xastir/config/tnc-startup.sys
+share/xastir/config/tnc-startup.thd7
+share/xastir/config/tnc-stop.sys
+share/xastir/config/xastir.rgb
+share/xastir/doc/AUTHORS
+share/xastir/doc/COPYING
+share/xastir/doc/ChangeLog
+share/xastir/doc/FAQ
+share/xastir/doc/INSTALL
+share/xastir/doc/LICENSE
+share/xastir/doc/README
+share/xastir/doc/README.CVS
+share/xastir/doc/README.MAPS
+share/xastir/doc/README.win32
+share/xastir/doc/UPGRADE
+share/xastir/fcc/placeholder
+share/xastir/help/help-Dutch.dat
+share/xastir/help/help-English.dat
+share/xastir/help/help-French.dat
+share/xastir/help/help-German.dat
+share/xastir/help/help-Italian.dat
+share/xastir/help/help-Portuguese.dat
+share/xastir/help/help-Spanish.dat
+share/xastir/maps/GPS/placeholder
+share/xastir/maps/Online/CanadaTopo250k.geo
+share/xastir/maps/Online/CanadaTopo50k.geo
+share/xastir/maps/Online/USRadar.geo
+share/xastir/maps/Online/terraserver.geo
+share/xastir/maps/Online/tigermap.geo
+share/xastir/maps/Online/toposerver.geo
+share/xastir/sounds/placeholder
+share/xastir/symbols/13pct.xbm
+share/xastir/symbols/25pct.xbm
+share/xastir/symbols/2x2.xbm
+share/xastir/symbols/alert.xbm
+share/xastir/symbols/flood.xbm
+share/xastir/symbols/red_flag.xbm
+share/xastir/symbols/snow.xbm
+share/xastir/symbols/symbols.dat
+share/xastir/symbols/tornado.xbm
+share/xastir/symbols/wind.xbm
+share/xastir/symbols/winter_wx.xbm
+share/xastir/symbols/wntr_strm.xbm
+@dirrm share/xastir/symbols
+@dirrm share/xastir/sounds
+@dirrm share/xastir/maps/Online
+@dirrm share/xastir/maps/GPS
+@dirrm share/xastir/maps
+@dirrm share/xastir/help
+@dirrm share/xastir/fcc
+@dirrm share/xastir/doc
+@dirrm share/xastir/config
+@dirrm share/xastir/GNIS
+@dirrm share/xastir/Counties
+@dirrm share/xastir
+@dirrm lib/xastir