aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2019-06-17 13:37:52 +0000
committerMichael Landin <mich@FreeBSD.org>2019-06-17 13:37:52 +0000
commitaf4f260a20f7b064e852aa6e777ca425b52d89c2 (patch)
tree91d838a7999f78d251c6631bd50472352e452afa /comms
parentfd2b9625c6a3130ff334b66646344960068b5ef0 (diff)
downloadports-af4f260a20f7b064e852aa6e777ca425b52d89c2.tar.gz
ports-af4f260a20f7b064e852aa6e777ca425b52d89c2.zip
- update to -> 1.3.0
- cleanup Makefile to keep portlint happy - regenerate patches to keep portlint happy PR: 238610 Submitted by: Thomas Merkel <tm@NetBSD.org>
Notes
Notes: svn path=/head/; revision=504422
Diffstat (limited to 'comms')
-rw-r--r--comms/tits/Makefile4
-rw-r--r--comms/tits/distinfo5
-rw-r--r--comms/tits/files/patch-Makefile19
-rw-r--r--comms/tits/files/patch-dispatcher.c10
-rw-r--r--comms/tits/files/patch-listener.c7
-rw-r--r--comms/tits/files/patch-rtelnet.c11
-rw-r--r--comms/tits/files/patch-tty.c20
7 files changed, 39 insertions, 37 deletions
diff --git a/comms/tits/Makefile b/comms/tits/Makefile
index 78c8e5b5f796..4349e6dfca46 100644
--- a/comms/tits/Makefile
+++ b/comms/tits/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tits
-PORTVERSION= 1.1.2
-PORTREVISION= 2
+PORTVERSION= 1.3.0
CATEGORIES= comms
MASTER_SITES= http://www.mctavish.co.uk/tits/
@@ -14,6 +13,7 @@ LICENSE= BSD4CLAUSE
USES= uidfix
USE_RC_SUBR= tits
+
MAKE_ENV= BINDIR=${PREFIX}/sbin MANDIR=${PREFIX}/man/man
post-patch:
diff --git a/comms/tits/distinfo b/comms/tits/distinfo
index 92b2bbd0715d..9ed1dfe95a6a 100644
--- a/comms/tits/distinfo
+++ b/comms/tits/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tits-1.1.2.tar.gz) = da82e0ca603dbcb59c4d28353a47a70d228e6b2cd6df23f952abe367850970e0
-SIZE (tits-1.1.2.tar.gz) = 21948
+TIMESTAMP = 1560688435
+SHA256 (tits-1.3.0.tar.gz) = f6cd7bf11b8aa730be0ddd6ed6f6a3a8380285959a586e9404d5ec02ef73f237
+SIZE (tits-1.3.0.tar.gz) = 31811
diff --git a/comms/tits/files/patch-Makefile b/comms/tits/files/patch-Makefile
index 4e56d6d80bfb..6565217e1d92 100644
--- a/comms/tits/files/patch-Makefile
+++ b/comms/tits/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig Wed Sep 24 16:05:07 2003
-+++ Makefile Wed Sep 24 16:06:52 2003
-@@ -29,15 +29,15 @@
+--- Makefile.orig 2011-01-15 12:47:19 UTC
++++ Makefile
+@@ -29,22 +29,22 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
@@ -11,11 +11,20 @@
-MAN= tits.8
+MAN8= tits.8
- SRCS= main.c buffer.c client.c context.c listener.c telnet.c tty.c
- SRCS+= dispatcher.c setup.c config.c server.c logger.c
+ SRCS= main.c buffer.c client.c context.c listener.c masterpty.c telnet.c
+ SRCS+= tty.c dispatcher.c setup.c config.c server.c logger.c stdio2pty.c
+ SRCS+= rtelnet.c
+ .if !defined(SMALLPROG)
-CPPFLAGS+= -DLIBWRAP -DTITS_DEFAULT_CONFIG_FILE=\"${LOCALBASE}/etc/tits.conf\"
+CFLAGS+= -DLIBWRAP -DTITS_DEFAULT_CONFIG_FILE=\"${LOCALBASE}/etc/tits.conf\"
LDADD+= -lwrap
+ .else
+-CPPFLAGS+= -DTITS_DEFAULT_CONFIG_FILE=\"/etc/tits.conf\"
++CFLAGS+= -DTITS_DEFAULT_CONFIG_FILE=\"${LOCALBASE}/etc/tits.conf\"
+ .endif
+-CPPFLAGS+= -DTITS_DEFAULT_LINKDIR=\"/var/run\"
++CFLAGS+= -DTITS_DEFAULT_LINKDIR=\"/var/run\"
PREFIX?= /usr/local
BINDIR?= ${PREFIX}/sbin
+
diff --git a/comms/tits/files/patch-dispatcher.c b/comms/tits/files/patch-dispatcher.c
index faccdbccfbc0..9e16bc099706 100644
--- a/comms/tits/files/patch-dispatcher.c
+++ b/comms/tits/files/patch-dispatcher.c
@@ -1,11 +1,11 @@
---- dispatcher.c.orig Tue Sep 24 13:21:42 2002
-+++ dispatcher.c Tue Sep 24 13:23:15 2002
-@@ -131,7 +131,7 @@
+--- dispatcher.c.orig 2006-03-19 11:34:47 UTC
++++ dispatcher.c
+@@ -237,7 +237,7 @@ dispatcher_mainloop(void)
struct context *ctx;
struct client_ctx *cc;
struct pollfd *pf;
- nfds_t pfds;
+ unsigned int pfds;
int nfds, errcnt = 0;
-
- while (!TAILQ_EMPTY(&contexts)) {
+ int timeout;
+ time_t delta = 0;
diff --git a/comms/tits/files/patch-listener.c b/comms/tits/files/patch-listener.c
index ce1f4be4daa9..157a4850f5c2 100644
--- a/comms/tits/files/patch-listener.c
+++ b/comms/tits/files/patch-listener.c
@@ -1,12 +1,13 @@
---- listener.c.orig
+--- listener.c.orig 2009-11-16 14:30:13 UTC
+++ listener.c
-@@ -189,10 +189,6 @@
+@@ -189,11 +189,6 @@ listener_destroy(struct client_ctx *cc)
NULL)
context_del_client(cc->cc_ctx, ccc);
- if (lc->lc_args.la_address)
- (void) free(lc->lc_args.la_address);
-- (void) free(lc->lc_args.la_port);
+- if (lc->lc_args.la_port)
+- (void) free(lc->lc_args.la_port);
-
(void) free(lc);
}
diff --git a/comms/tits/files/patch-rtelnet.c b/comms/tits/files/patch-rtelnet.c
new file mode 100644
index 000000000000..7a6bc3981687
--- /dev/null
+++ b/comms/tits/files/patch-rtelnet.c
@@ -0,0 +1,11 @@
+--- rtelnet.c.orig 2019-06-17 13:22:22 UTC
++++ rtelnet.c
+@@ -900,7 +900,7 @@ cf_rtelnet_port(void *cs, char **argv, i
+
+ if (isdigit((unsigned char)argv[1][0])) {
+ ro->ro_port = atoi(argv[1]);
+- if (ro->ro_port < 0 || ro->ro_port > IPPORT_ANONMAX)
++ if (ro->ro_port < 0 || ro->ro_port > IPPORT_MAX)
+ return (config_err(cs, "Invalid port number '%s'",
+ argv[1]));
+ } else
diff --git a/comms/tits/files/patch-tty.c b/comms/tits/files/patch-tty.c
deleted file mode 100644
index f17162b9a7dd..000000000000
--- a/comms/tits/files/patch-tty.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- tty.c 2001/04/18 14:43:52 1.1
-+++ tty.c 2001/04/18 14:45:57
-@@ -32,6 +32,7 @@
- #include <sys/types.h>
- #include <sys/filio.h>
- #include <sys/ioctl.h>
-+#include <sys/stat.h>
- #include <sys/types.h>
-
- #include <ctype.h>
-@@ -216,8 +217,7 @@
- * If this is *not* a pseudo tty, ensure DTR is asserted.
- * Note: This relies on TIOCGFLAGS returning ENOTTY for pty(4)'s.
- */
-- if (ioctl(cc->cc_fd, TIOCGFLAGS, &flags) == 0 && errno == ENOTTY &&
-- ioctl(cc->cc_fd, TIOCSDTR, 0) < 0) {
-+ if (ioctl(cc->cc_fd, TIOCSDTR, 0) < 0 && errno != ENOTTY) {
- (void) close(cc->cc_fd);
- (void) free(tc->tc_to.to_device);
- (void) free(tc);