aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-08 12:19:29 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-08 12:19:29 +0000
commitf5538e3326c4f4ed7a88572788a87e776ad2d860 (patch)
tree3162f734ed530f13d5dda5fdcbfb36a0a3b09b9a /comms
parent5fdb1d332d2447fa0fe9729b3863a8967001c4d0 (diff)
downloadports-f5538e3326c4f4ed7a88572788a87e776ad2d860.tar.gz
ports-f5538e3326c4f4ed7a88572788a87e776ad2d860.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gnokii/Makefile2
-rw-r--r--comms/gnokii/distinfo4
-rw-r--r--comms/gnokii/files/patch-Makefile.global.in12
-rw-r--r--comms/gnokii/files/patch-configure45
-rw-r--r--comms/gnokii/pkg-plist11
5 files changed, 40 insertions, 34 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index d9ab56418ee7..a4293d0d0089 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.6.1
+PORTVERSION= 0.6.3
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SAVANNAH} \
diff --git a/comms/gnokii/distinfo b/comms/gnokii/distinfo
index d550b1626b48..0543f7f4b600 100644
--- a/comms/gnokii/distinfo
+++ b/comms/gnokii/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnokii-0.6.1.tar.bz2) = 45521637ecb443f28558317aaee80bdf
-SIZE (gnokii-0.6.1.tar.bz2) = 1777215
+MD5 (gnokii-0.6.3.tar.bz2) = 7e932688aeaa2ca8be2f2e3b3bf1b90e
+SIZE (gnokii-0.6.3.tar.bz2) = 1824992
diff --git a/comms/gnokii/files/patch-Makefile.global.in b/comms/gnokii/files/patch-Makefile.global.in
index 787cca46e5cd..76c588dcca92 100644
--- a/comms/gnokii/files/patch-Makefile.global.in
+++ b/comms/gnokii/files/patch-Makefile.global.in
@@ -1,6 +1,6 @@
---- Makefile.global.in.orig Tue Jul 8 23:33:22 2003
-+++ Makefile.global.in Tue Jul 8 23:33:03 2003
-@@ -22,15 +22,15 @@
+--- Makefile.global.in.orig Tue Jul 6 11:57:56 2004
++++ Makefile.global.in Tue Jul 6 11:59:17 2004
+@@ -21,14 +21,14 @@
bindir = @bindir@
sbindir = @sbindir@
@@ -14,9 +14,7 @@
man1dir = ${mandir}/man1/
man8dir = ${mandir}/man8/
-xmandir = @XGNOKIIDIR@/man/man1/
--docdir = ${prefix}/doc/${PACKAGE}
-+xmandir = ${man1dir}
-+docdir = ${prefix}/share/doc/${PACKAGE}
++xmandir = ${prefix}/man/man1/
+ docdir = ${prefix}/share/doc/${PACKAGE}
locdir = @datadir@/locale
- BIN_MODE = 0755
diff --git a/comms/gnokii/files/patch-configure b/comms/gnokii/files/patch-configure
index d816fd14e3d0..b57945d1760e 100644
--- a/comms/gnokii/files/patch-configure
+++ b/comms/gnokii/files/patch-configure
@@ -1,13 +1,32 @@
---- configure.orig Tue May 20 20:29:43 2003
-+++ configure Tue May 20 20:30:35 2003
-@@ -6407,8 +6407,8 @@
- echo "${ECHO_T}$ac_cv_lib_c_r_pthread_attr_init" >&6
- if test $ac_cv_lib_c_r_pthread_attr_init = yes; then
-
-- PTHREAD_CFLAGS="$PTHREAD_CFLAGS -D_THREAD_SAFE"
-- PTHREAD_LIBS="-pthread"
-+ PTHREAD_CFLAGS="$PTHREAD_CFLAGS %%PTHREAD_CFLAGS%%"
-+ PTHREAD_LIBS="%%PTHREAD_LIBS%%"
- fi
-
- fi
+--- configure.orig Mon Jul 5 00:04:50 2004
++++ configure Tue Jul 6 12:56:33 2004
+@@ -26348,13 +26348,15 @@
+ # First of all, check if the user has set any of the PTHREAD_LIBS,
+ # etcetera environment variables, and if threads linking works using
+ # them:
+-if test x"$PTHREAD_LIBS$PTHREAD_CFLAGS" != x; then
++if test x"%%PTHREAD_LIBS%%%%PTHREAD_CFLAGS%%" != x; then
++ PTHREAD_CFLAGS="%%PTHREAD_CFLAGS%%"
++ PTHREAD_LIBS="%%PTHREAD_LIBS%%"
+ save_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
++ CFLAGS="$CFLAGS %%PTHREAD_CFLAGS%%"
+ save_LIBS="$LIBS"
+- LIBS="$PTHREAD_LIBS $LIBS"
+- echo "$as_me:$LINENO: checking for pthread_join in LIBS=$PTHREAD_LIBS with CFLAGS=$PTHREAD_CFLAGS" >&5
+-echo $ECHO_N "checking for pthread_join in LIBS=$PTHREAD_LIBS with CFLAGS=$PTHREAD_CFLAGS... $ECHO_C" >&6
++ LIBS="%%PTHREAD_LIBS%% $LIBS"
++ echo "$as_me:$LINENO: checking for pthread_join in LIBS=%%PTHREAD_LIBS%% with CFLAGS=%%PTHREAD_CFLAGS%%" >&5
++echo $ECHO_N "checking for pthread_join in LIBS=%%PTHREAD_LIBS%% with CFLAGS=%%PTHREAD_CFLAGS%%... $ECHO_C" >&6
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -26726,7 +26728,7 @@
+ echo $ECHO_N "checking if more special flags are required for pthreads... $ECHO_C" >&6
+ flag=no
+ case "${host_cpu}-${host_os}" in
+- *-aix* | *-freebsd* | *-darwin*) flag="-D_THREAD_SAFE";;
++ *-aix* | *-darwin*) flag="-D_THREAD_SAFE";;
+ *solaris* | *-osf* | *-hpux*) flag="-D_REENTRANT";;
+ esac
+ echo "$as_me:$LINENO: result: ${flag}" >&5
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index 191505d1a31b..69b36c605ed3 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -107,12 +107,9 @@ share/locale/sl/LC_MESSAGES/gnokii.mo
%%X11%%share/xgnokii/help/POSIX
%%X11%%share/xgnokii/help/en_US/COPYING
%%X11%%share/xgnokii/help/en_US/CREDITS
-%%X11%%share/xgnokii/help/en_US/cables/cables.html
-%%X11%%share/xgnokii/help/en_US/config.html
%%X11%%share/xgnokii/help/en_US/faq.html
%%X11%%share/xgnokii/help/en_US/firmware/firmware.html
%%X11%%share/xgnokii/help/en_US/index.html
-%%X11%%share/xgnokii/help/en_US/irda/irda.html
%%X11%%share/xgnokii/help/en_US/netmon/faq_net0.html
%%X11%%share/xgnokii/help/en_US/netmon/faq_net1.html
%%X11%%share/xgnokii/help/en_US/netmon/faq_net2.html
@@ -130,14 +127,6 @@ share/locale/sl/LC_MESSAGES/gnokii.mo
%%X11%%share/xgnokii/help/en_US/netmon/tip.png
%%X11%%share/xgnokii/help/en_US/sample/gnokiirc
%%X11%%share/xgnokii/help/en_US/styl.css
-%%X11%%share/xgnokii/help/en_US/windows/calendar/index.html
-%%X11%%share/xgnokii/help/en_US/windows/contacts/index.html
-%%X11%%share/xgnokii/help/en_US/windows/dtmf/index.html
-%%X11%%share/xgnokii/help/en_US/windows/main/index.html
-%%X11%%share/xgnokii/help/en_US/windows/netmon/index.html
-%%X11%%share/xgnokii/help/en_US/windows/sms/index.html
-%%X11%%share/xgnokii/help/en_US/windows/speeddial/index.html
-%%X11%%share/xgnokii/help/en_US/windows/xkeyb/index.html
%%X11%%share/xgnokii/help/pl_PL/calendar.html
%%X11%%share/xgnokii/help/pl_PL/contacts.html
%%X11%%share/xgnokii/help/pl_PL/dtmf.html