aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-31 03:59:57 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-10-31 03:59:57 +0000
commit21335badbf315423d328ed5f0c2c853815066ed1 (patch)
tree1fad8f98815cc64efc57dc097169e313e8804a4c /comms
parentb57d3257d24b65078626fa3ef5bf2423a333467d (diff)
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/libimobiledevice/Makefile22
-rw-r--r--comms/libimobiledevice/pkg-plist13
2 files changed, 18 insertions, 17 deletions
diff --git a/comms/libimobiledevice/Makefile b/comms/libimobiledevice/Makefile
index 638f5895bb8b..17575e2a2484 100644
--- a/comms/libimobiledevice/Makefile
+++ b/comms/libimobiledevice/Makefile
@@ -22,11 +22,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
.if ${SLAVE_PORT} == "no"
-LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
- tasn1:${PORTSDIR}/security/libtasn1 \
- gcrypt:${PORTSDIR}/security/libgcrypt \
- plist:${PORTSDIR}/devel/libplist \
- usbmuxd:${PORTSDIR}/comms/usbmuxd
+LIB_DEPENDS= libplist.so:${PORTSDIR}/devel/libplist \
+ libusbmuxd.so:${PORTSDIR}/comms/usbmuxd
USE_GNOME= glib20
CONFIGURE_ARGS+=--without-cython
@@ -35,14 +32,7 @@ USE_LDCONFIG= yes
PORTDOCS= AUTHORS NEWS README
-MAN1= idevice_id.1 idevicebackup.1 idevicebackup2.1 idevicedate.1 \
- idevicedebugserverproxy.1 idevicediagnostics.1 \
- ideviceenterrecovery.1 ideviceimagemounter.1 ideviceinfo.1 \
- idevicepair.1 ideviceprovision.1 idevicescreenshot.1 \
- idevicesyslog.1
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} -e 's, *@ssl_requires@,,' \
@@ -51,10 +41,8 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif # ${SLAVE_PORT} == "no"
diff --git a/comms/libimobiledevice/pkg-plist b/comms/libimobiledevice/pkg-plist
index 054c58bb8eb2..0c9abd23fad5 100644
--- a/comms/libimobiledevice/pkg-plist
+++ b/comms/libimobiledevice/pkg-plist
@@ -34,4 +34,17 @@ lib/libimobiledevice.la
lib/libimobiledevice.so
lib/libimobiledevice.so.4
libdata/pkgconfig/libimobiledevice-1.0.pc
+man/man1/idevice_id.1.gz
+man/man1/idevicebackup.1.gz
+man/man1/idevicebackup2.1.gz
+man/man1/idevicedate.1.gz
+man/man1/idevicedebugserverproxy.1.gz
+man/man1/idevicediagnostics.1.gz
+man/man1/ideviceenterrecovery.1.gz
+man/man1/ideviceimagemounter.1.gz
+man/man1/ideviceinfo.1.gz
+man/man1/idevicepair.1.gz
+man/man1/ideviceprovision.1.gz
+man/man1/idevicescreenshot.1.gz
+man/man1/idevicesyslog.1.gz
@dirrm include/libimobiledevice