aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-26 21:21:37 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-26 21:21:37 +0000
commit209d894120183c5bdc268a0e1b0fa2dbcabaad53 (patch)
treecaba32dc41230b27f723afc8f81dafd017e2ba99 /comms
parentf1a0ce6e51c6c332324dc48da51c0a834464e345 (diff)
downloadports-209d894120183c5bdc268a0e1b0fa2dbcabaad53.tar.gz
ports-209d894120183c5bdc268a0e1b0fa2dbcabaad53.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/hylafax/Makefile53
-rw-r--r--comms/hylafax/files/hylafax-faxq.sh.sample23
-rw-r--r--comms/hylafax/files/hylafax-hfaxd.sh.sample27
-rw-r--r--comms/hylafax/files/hylafax.sh.sample23
-rw-r--r--comms/hylafax/files/patch-Makefile.in14
-rw-r--r--comms/hylafax/files/patch-configure91
-rw-r--r--comms/hylafax/files/patch-util::faxrcvd.sh.in6
-rw-r--r--comms/hylafax/pkg-plist412
8 files changed, 435 insertions, 214 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index b8da1539dd3d..b07b14db4c8e 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -31,10 +31,18 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-DIR_HTML="${DOCSDIR}"
# Defaults to "North American Letter". Use "ISO A4" for A4.
-.ifdef PAGESIZE
+.if defined(PAGESIZE)
CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
+# Want HTML documentation?
+.if defined(WITH_HTMLDOC)
+CONFIGURE_ARGS+=--with-HTML=yes
+PLIST_SUB+= PORTDOCS=""
+.else
+PLIST_SUB+= PORTDOCS="@comment "
+.endif
+
.if defined(PACKAGE_BUILDING) || defined(BATCH)
CONFIGURE_ARGS+=--nointeractive
.endif
@@ -44,46 +52,51 @@ HAS_CONFIGURE= yes
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
USE_REINPLACE= yes
-MAN1= hylafax-client.1 faxalter.1 faxcover.1 faxmail.1 \
- faxrm.1 faxstat.1 sendfax.1 \
- sendpage.1 sgi2fax.1 textfmt.1 edit-faxcover.1
-MAN5= pagesizes.5f typerules.5f hosts.hfaxd.5f xferfaxlog.5f \
- cid.5f doneq.5f hylafax-config.5f destctrls.5f dialrules.5f \
+MAN1= hylafax-client.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 \
+ sendfax.1 sendpage.1 sgi2fax.1 textfmt.1 edit-faxcover.1
+
+MAN5= pagesizes.5f typerules.5f hosts.hfaxd.5f xferfaxlog.5f cid.5f \
+ doneq.5f hylafax-config.5f destctrls.5f dialrules.5f \
hylafax-info.5f hylafax-log.5f pagermap.5f recvq.5f sendq.5f \
hylafax-server.5f hylafax-shutdown.5f status.5f tsi.5f
+
MAN8= cqtest.8c choptest.8c dialtest.8c faxabort.8c faxaddmodem.8c \
faxadduser.8c faxanswer.8c faxconfig.8c faxdeluser.8c faxmodem.8c \
faxstate.8c faxcron.8c faxgetty.8c faxinfo.8c faxlock.8c faxq.8c \
faxqclean.8c faxquit.8c faxrcvd.8c faxsend.8c faxsetup.8c \
faxwatch.8c hfaxd.8c mkcover.8c notify.8c pagesend.8c pdf2fax.8c \
- pollrcvd.8c ps2fax.8c recvstats.8c \
- tagtest.8c tiff2fax.8c tiffcheck.8c tsitest.8c wedged.8c \
- xferfaxstats.8c
+ pollrcvd.8c ps2fax.8c recvstats.8c tagtest.8c tiff2fax.8c \
+ tiffcheck.8c tsitest.8c wedged.8c xferfaxstats.8c
SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
${PREFIX}/bin/faxrm ${PREFIX}/bin/faxalter
-post-extract:
- ${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+pre-extract:
+ @if [ -d /var/db/pkg/tiff-3.6.1 ]; then \
+ ${ECHO_MSG} ""; \
+ ${ECHO_MSG} "Hylafax does not work with libtiff-3.6.1."; \
+ ${ECHO_MSG} "Please upgrade to libtiff-3.6.1_1. (/usr/ports/graphics/tiff)"; \
+ ${ECHO_MSG} ""; \
+ exit 1; \
+ fi
post-patch:
${REINPLACE_CMD} \
-e 's,/usr/local,${LOCALBASE},g' \
${WRKSRC}/configure
- ${REINPLACE_CMD} \
- -e 's,%%LOCALBASE%%,${LOCALBASE},g' \
- ${WRKSRC}/util/faxrcvd.sh.in
-
-pre-install:
-PLIST_SUB= SPOOL="`${GREP} SPOOL ${WRKSRC}/defs | ${CUT} -c10-`"
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
- @if [ ! -f ${PREFIX}/etc/rc.d/hylafax.sh.sample ]; then \
+ @if [ ! -f ${PREFIX}/etc/rc.d/hylafax-faxq.sh.sample ]; then \
+ ${SED} 's^/usr/local^${PREFIX}^g' \
+ < ${FILESDIR}/hylafax-faxq.sh.sample \
+ > ${PREFIX}/etc/rc.d/hylafax-faxq.sh.sample; \
+ fi
+ @if [ ! -f ${PREFIX}/etc/rc.d/hylafax-hfaxd.sh.sample ]; then \
${SED} 's^/usr/local^${PREFIX}^g' \
- < ${FILESDIR}/hylafax.sh.sample \
- > ${PREFIX}/etc/rc.d/hylafax.sh.sample; \
+ < ${FILESDIR}/hylafax-hfaxd.sh.sample \
+ > ${PREFIX}/etc/rc.d/hylafax-hfaxd.sh.sample; \
fi
@${SED} 's^/usr/local^${PREFIX}^g' < ${PKGMESSAGE}
diff --git a/comms/hylafax/files/hylafax-faxq.sh.sample b/comms/hylafax/files/hylafax-faxq.sh.sample
new file mode 100644
index 000000000000..643e834b0910
--- /dev/null
+++ b/comms/hylafax/files/hylafax-faxq.sh.sample
@@ -0,0 +1,23 @@
+#! /bin/sh
+# hylafax faxq startup example.
+# be sure to initialize the followings:
+# server: /usr/local/sbin/faxsetup
+# modems: /usr/local/sbin/faxaddmodem
+# incoming calls: /etc/ttys
+
+case "$1" in
+start)
+ if [ -x /usr/local/sbin/faxq ]; then
+ /usr/local/sbin/faxq && echo -n ' hylafax-faxq'
+ fi
+ ;;
+stop)
+ killall faxq && echo -n ' hylafax-faxq'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0
diff --git a/comms/hylafax/files/hylafax-hfaxd.sh.sample b/comms/hylafax/files/hylafax-hfaxd.sh.sample
new file mode 100644
index 000000000000..b24845c46a12
--- /dev/null
+++ b/comms/hylafax/files/hylafax-hfaxd.sh.sample
@@ -0,0 +1,27 @@
+#! /bin/sh
+# hylafax hfaxd startup example.
+# be sure to initialize the followings:
+# server........: /usr/local/sbin/faxsetup
+# modems........: /usr/local/sbin/faxaddmodem
+# incoming calls: /etc/ttys
+#
+# add switch to use old protocol (not recommended): -o [port]
+# add switch to use paging protocol (SNPP)........: -s [port]
+# read more about these options in 'man hfaxd'.
+
+case "$1" in
+start)
+ if [ -x /usr/local/sbin/hfaxd ]; then
+ /usr/local/sbin/hfaxd && echo -n ' hylafax-hfaxd'
+ fi
+ ;;
+stop)
+ killall hfaxd && echo -n ' hylafax-hfaxd'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0
diff --git a/comms/hylafax/files/hylafax.sh.sample b/comms/hylafax/files/hylafax.sh.sample
deleted file mode 100644
index f7a0f61200e3..000000000000
--- a/comms/hylafax/files/hylafax.sh.sample
+++ /dev/null
@@ -1,23 +0,0 @@
-#! /bin/sh
-# hylafax startup example.
-# be sure to initialize the followings:
-# server: /usr/local/sbin/faxsetup
-# modems: /usr/local/sbin/faxaddmodem
-# incoming calls: /etc/ttys
-
-case "$1" in
-start)
- if [ -x /usr/local/sbin/faxq ]; then
- /usr/local/sbin/faxq && echo -n ' hylafax'
- fi
- ;;
-stop)
- killall faxq && echo -n ' hylafax'
- ;;
-*)
- echo "Usage: `basename $0` {start|stop}" >&2
- exit 64
- ;;
-esac
-
-exit 0
diff --git a/comms/hylafax/files/patch-Makefile.in b/comms/hylafax/files/patch-Makefile.in
deleted file mode 100644
index f6af939424ca..000000000000
--- a/comms/hylafax/files/patch-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- Makefile.in.orig Mon May 27 21:22:33 2002
-+++ Makefile.in Mon Jan 13 20:20:15 2003
-@@ -219,10 +219,8 @@
- makeClientDirs::
- -${INSTALL} -u ${SYSUSER} -g ${SYSGROUP} -m ${DIRMODE} \
- -idb hylafax.sw.client -dir \
-- ${BIN} ${LIBDATA} ${LIBEXEC} ${SBIN}
-+ ${LIBDATA}
- makeServerDirs::
-- -${INSTALL} -u ${SYSUSER} -g ${SYSGROUP} -m ${DIRMODE} \
-- -idb hylafax.sw.server -dir ${SBIN};
- -${INSTALL} -u ${FAXUSER} -g ${FAXGROUP} -m ${DIRMODE} \
- -idb hylafax.sw.server -dir ${SPOOL}
- -${INSTALL} -u ${FAXUSER} -g ${FAXGROUP} -m ${DIRMODE} \
diff --git a/comms/hylafax/files/patch-configure b/comms/hylafax/files/patch-configure
index ec410d87b893..59dc20e4d0e7 100644
--- a/comms/hylafax/files/patch-configure
+++ b/comms/hylafax/files/patch-configure
@@ -1,13 +1,92 @@
-$FreeBSD$
-
---- configure.orig Wed May 30 19:29:46 2001
-+++ configure Mon Apr 8 22:28:59 2002
-@@ -2584,7 +2584,7 @@
+--- configure.orig Mon May 24 15:24:35 2004
++++ configure Mon May 24 17:44:28 2004
+@@ -43,8 +43,8 @@
+ DIR_LIB=/usr/local/lib
+ DIR_LIBEXEC=$DIR_SBIN
+ DIR_SPOOL=/var/spool/hylafax
+-DIR_HTML=/var/httpd/htdocs/hylafax
+-DIR_CGI=/var/httpd/cgi-bin
++DIR_HTML=/usr/local/share/doc/hylafax
++DIR_CGI=/usr/local/share/doc/hylafax/cgi-bin
+ PATH_DPSRIP=$DIR_LIBEXEC/ps2fax.exe
+ PATH_IMPRIP=/usr/lib/print/psrip
+ HTMLPATH=/hylafax
+@@ -52,9 +52,9 @@
+ DEFVRES=98
+ PAGESIZE="North American Letter"
+ FAXUID=uucp
+-FAXGID=
+-SYSUID=bin
+-SYSGID=
++FAXGID=dialer
++SYSUID=root
++SYSGID=wheel
+ DSO=auto
+ GETTY=auto
+ HTML=no
+@@ -2604,7 +2604,7 @@
}
CheckFuncDecl unlink 'extern int unlink(const char*);' unistd.h
CheckFuncDecl read 'extern int read(int, const void*, unsigned int);' unistd.h
- CheckFuncDecl ioctl 'extern int ioctl(int, int, ...);' unistd.h sys/ioctl.h
-+# CheckFuncDecl ioctl 'extern int ioctl(int, int, ...);' unistd.h sys/ioctl.h
++ CheckFuncDecl ioctl 'extern int ioctl(int, unsigned long, ...);' sys/ioccom.h
CheckForFunc fchown && {
echo '#define HAS_FCHOWN 1'
Note "... configure use of fchown"
+@@ -4245,18 +4245,8 @@
+
+ HylaFAX configuration parameters (part 1 of 2) are:
+
+-[ 1] Directory for applications: $DIR_BIN
+-[ 2] Directory for lib data files: $DIR_LIBDATA
+-[ 3] Directory for lib executables: $DIR_LIBEXEC
+-[ 4] Directory for system apps: $DIR_SBIN
+-[ 5] Directory for manual pages: $DIR_MAN
+-[ 6] Directory for HTML documentation: $DIR_HTML
+-[ 7] Directory for spooling: $DIR_SPOOL
+-[ 8] Directory for uucp lock files: $DIR_LOCKS
+-[ 9] Uucp lock file scheme: $LOCKS
+ [10] PostScript imager package: $PS
+ [11] PostScript imager program: $PATH_PSRIP
+-[12] Manual page installation scheme: $MANSCHEME
+ [13] Default page size: $PAGESIZE
+ [14] Default vertical res (lpi): $DEFVRES
+
+@@ -4272,16 +4262,9 @@
+ [15] Location of getty program: $PATH_GETTY
+ [16] Location of voice getty program: $PATH_VGETTY
+ [17] Location of sendmail program: $PATH_SENDMAIL
+-[18] Location of TIFF tools: $TIFFBIN
+-[19] Location of SysV init scripts: $DIR_SYSVINIT
+-[20] Location of SysV start scripts: $DIR_SYSVINITSTART
+-[21] Location of SysV stop scripts: $DIR_SYSVINITSTOP
+-[22] Name of SysV start script: $NAME_SYSVINITSTART
+-[23] Name of SysV stop script: $NAME_SYSVINITSTOP
+-[24] Init script starts faxq: $FAXQ_SERVER
+-[25] Init script starts hfaxd $HFAXD_SERVER
+-[26] Start old protocol: $HFAXD_OLD_PROTOCOL
+-[27] Start paging protocol: $HFAXD_SNPP_SERVER
++[26] Use old protocol: $HFAXD_OLD_PROTOCOL
++[27] Use paging protocol: $HFAXD_SNPP_SERVER
++
+ EOF
+ }
+
+@@ -4382,7 +4365,7 @@
+ ok=skip
+ while [ "$ok" != y ] && [ "$ok" != yes ]; do
+ if [ "$ok" != skip ]; then
+- for i in 1 2 3 4 5 6 7 8 9 10 11 12 13 14 ; do
++ for i in 10 11 13 14 ; do
+ promptForParameter $i;
+ done
+ fi
+@@ -4411,7 +4394,7 @@
+ ok=skip
+ while [ "$ok" != y ] && [ "$ok" != yes ]; do
+ if [ "$ok" != skip ]; then
+- for i in 15 16 17 18 19 20 21 22 23 24 25 26 27 ; do
++ for i in 15 16 17 26 27 ; do
+ promptForParameter $i;
+ done
+ fi
diff --git a/comms/hylafax/files/patch-util::faxrcvd.sh.in b/comms/hylafax/files/patch-util::faxrcvd.sh.in
index 224331f4b89e..6a3fdf430d63 100644
--- a/comms/hylafax/files/patch-util::faxrcvd.sh.in
+++ b/comms/hylafax/files/patch-util::faxrcvd.sh.in
@@ -1,10 +1,10 @@
---- util/faxrcvd.sh.in.orig Sun Sep 28 15:54:52 2003
-+++ util/faxrcvd.sh.in Sun Sep 28 15:56:06 2003
+--- util/faxrcvd.sh.in.orig Sun May 23 15:47:38 2004
++++ util/faxrcvd.sh.in Sun May 23 15:48:12 2004
@@ -51,6 +51,7 @@
}
. etc/setup.cache
-+export PATH=$PATH:%%LOCALBASE%%/bin
++export PATH=$PATH:$BIN
INFO=$SBIN/faxinfo
FAX2PS=$TIFFBIN/fax2ps
MIMENCODE=mimencode
diff --git a/comms/hylafax/pkg-plist b/comms/hylafax/pkg-plist
index 757a08c6ba4d..1b8fbd3cfd19 100644
--- a/comms/hylafax/pkg-plist
+++ b/comms/hylafax/pkg-plist
@@ -5,13 +5,15 @@ bin/faxrm
bin/faxstat
bin/sendfax
bin/sendpage
-etc/rc.d/hylafax.sh.sample
+etc/rc.d/hylafax-faxq.sh.sample
+etc/rc.d/hylafax-hfaxd.sh.sample
lib/fax/faxcover.ps
lib/fax/faxcover_example_sgi.ps
lib/fax/faxmail.ps
lib/fax/hfaxd.conf
lib/fax/pagesizes
lib/fax/typerules
+@dirrm lib/fax
sbin/choptest
sbin/cqtest
sbin/dialtest
@@ -51,150 +53,264 @@ sbin/tiffcheck
sbin/tsitest
sbin/typetest
sbin/xferfaxstats
-@dirrm lib/fax
-@cwd %%SPOOL%%
-COPYRIGHT
-bin/archive
-bin/faxrcvd
-bin/mkcover
-bin/notify
-bin/notify.awk
-@unexec if [ -f %D/bin/pdf2fax ]; then rm %D/bin/pdf2fax; fi
-bin/pdf2fax.gs
-bin/pcl2fax
-bin/pollrcvd
-@unexec if [ -f %D/bin/ps2fax ]; then rm %D/bin/ps2fax; fi
-bin/ps2fax.dps
-bin/ps2fax.gs
-bin/ps2fax.imp
-bin/tiff2fax
-bin/wedged
-config/att-dataport
-config/att-dataport-2
-config/att-dataport-2.0
-config/att-dpexpress-2
-config/cirrus
-config/class1
-config/class1.0
-config/class2
-config/class2.0
-config/class2.1
-config/digi
-config/digi-2
-config/digi-20
-config/davicom-2
-config/dsi-scout+
-config/e-tech
-config/eicon
-config/eicon-2
-config/elsa-microlink-56k-basic-2.0
-config/everex-2496d
-config/exar
-config/gvc-288
-config/gvc-288-2
-config/hayes
-config/intel-400e
-config/lucent
-config/lucent-isa
-config/lucent-mt-2
-config/lucent-mt-20
-config/lucent-mt-21
-config/moto-288
-config/mt-1432
-config/nuvo-voyager
-config/ppi-pm14400fxmt
-config/ppi-pm14400fxsa
-config/prometheus
-config/rc144ac
-config/rc144ac-1
-config/rc288dpi
-config/rc288dpi-1
-config/rc32acl
-config/rc32acl-1
-config/rockwell-k56
-config/rockwell-rc
-config/sierra
-config/skel
-config/telebit-qblazer
-config/telebit-t3000
-config/telebit-wb
-config/topic
-config/tricom2842
-config/uds-fastalk
-config/umc92144
-config/umc9624
-config/usr-2.0
-config/usr-rts
-config/usr-xon
-config/zyxel-1496e
-config/zyxel-1496e-1
-config/zyxel-1496e-2.0
-config/zyxel-2864
-@unexec if [ -f %D/dev/null ]; then rm %D/dev/null; fi
-etc/cover.templ
-etc/dialrules
-etc/dialrules.europe
-etc/dialrules.sf-ba
-etc/dpsprinter.ps
-etc/hosts.hfaxd
-etc/lutRS18.pcf
-etc/xferfaxlog
-@exec chown uucp:dialer %D/fax
-@comment pkg_* can't deal with fifos if specified as a file
-@exec mkfifo %D/FIFO
-@exec chown uucp:dialer %D/FIFO
-@exec chmod 600 %D/FIFO
-@unexec rm %D/FIFO*
-@exec mkdir %D/archive
-@exec chown uucp:dialer %D/archive
-@exec chmod 700 %D/archive
-@exec mkdir %D/client
-@exec chown uucp:dialer %D/client
-@exec chmod 755 %D/client
-@exec mkdir %D/dev
-@exec chown uucp:dialer %D/dev
-@exec chmod 755 %D/dev
-@exec mkdir %D/docq
-@exec chown uucp:dialer %D/docq
-@exec chmod 700 %D/docq
-@exec mkdir %D/doneq
-@exec chown uucp:dialer %D/doneq
-@exec chmod 700 %D/doneq
-@exec mkdir %D/info
-@exec chown uucp:dialer %D/info
-@exec chmod 755 %D/info
-@exec mkdir %D/log
-@exec chown uucp:dialer %D/log
-@exec chmod 755 %D/log
-@exec mkdir %D/pollq
-@exec chown uucp:dialer %D/pollq
-@exec chmod 700 %D/pollq
-@exec mkdir %D/recvq
-@exec chown uucp:dialer %D/recvq
-@exec chmod 755 %D/recvq
-@exec mkdir %D/sendq
-@exec chown uucp:dialer %D/sendq
-@exec chmod 700 %D/sendq
-@exec mkdir %D/status
-@exec chown uucp:dialer %D/status
-@exec chmod 755 %D/status
-@exec mkdir %D/tmp
-@exec chown uucp:dialer %D/tmp
-@exec chmod 700 %D/tmp
-@dirrm archive
-@dirrm bin
-@dirrm client
-@dirrm config
-@dirrm dev
-@dirrm docq
-@dirrm doneq
-@dirrm etc
-@dirrm info
-@dirrm log
-@dirrm pollq
-@dirrm recvq
-@dirrm sendq
-@dirrm status
-@dirrm tmp
-@cwd /
-@dirrm %%SPOOL%%
+%%PORTDOCS%%share/doc/hylafax/acknowledge.html
+%%PORTDOCS%%share/doc/hylafax/binary.html
+%%PORTDOCS%%share/doc/hylafax/building.html
+%%PORTDOCS%%share/doc/hylafax/cgi-bin/man2html
+%%PORTDOCS%%share/doc/hylafax/cgi-bin/manpage
+%%PORTDOCS%%share/doc/hylafax/cgi-bin/unquote
+%%PORTDOCS%%share/doc/hylafax/class1.html
+%%PORTDOCS%%share/doc/hylafax/class2.html
+%%PORTDOCS%%share/doc/hylafax/class2.0.html
+%%PORTDOCS%%share/doc/hylafax/contrib.html
+%%PORTDOCS%%share/doc/hylafax/copyright.html
+%%PORTDOCS%%share/doc/hylafax/documentation.html
+%%PORTDOCS%%share/doc/hylafax/faxgateway.html
+%%PORTDOCS%%share/doc/hylafax/ftpmail-help.html
+%%PORTDOCS%%share/doc/hylafax/ghostscript.html
+%%PORTDOCS%%share/doc/hylafax/HOWTO.html
+%%PORTDOCS%%share/doc/hylafax/hylafax.gif
+%%PORTDOCS%%share/doc/hylafax/hylafax3.0.html
+%%PORTDOCS%%share/doc/hylafax/hylafax4.0.html
+%%PORTDOCS%%share/doc/hylafax/icons/at_work_icon.gif
+%%PORTDOCS%%share/doc/hylafax/icons/back.gif
+%%PORTDOCS%%share/doc/hylafax/icons/ball_blue_icon.gif
+%%PORTDOCS%%share/doc/hylafax/icons/button.excl.gif
+%%PORTDOCS%%share/doc/hylafax/icons/contents.gif
+%%PORTDOCS%%share/doc/hylafax/icons/frog.gif
+%%PORTDOCS%%share/doc/hylafax/icons/improved.gif
+%%PORTDOCS%%share/doc/hylafax/icons/info_icon.gif
+%%PORTDOCS%%share/doc/hylafax/icons/new.gif
+%%PORTDOCS%%share/doc/hylafax/icons/next.gif
+%%PORTDOCS%%share/doc/hylafax/icons/smiley.gif
+%%PORTDOCS%%share/doc/hylafax/icons/warning_icon.gif
+%%PORTDOCS%%share/doc/hylafax/index.html
+%%PORTDOCS%%share/doc/hylafax/install-source.html
+%%PORTDOCS%%share/doc/hylafax/ixotap.html
+%%PORTDOCS%%share/doc/hylafax/mailing-lists.html
+%%PORTDOCS%%share/doc/hylafax/Majordomo/help.html
+%%PORTDOCS%%share/doc/hylafax/matthias.gif
+%%PORTDOCS%%share/doc/hylafax/matthias.html
+%%PORTDOCS%%share/doc/hylafax/modems.html
+%%PORTDOCS%%share/doc/hylafax/Modems/Hayes/hayes.html
+%%PORTDOCS%%share/doc/hylafax/Modems/Supra/class1.html
+%%PORTDOCS%%share/doc/hylafax/Modems/Supra/class2.html
+%%PORTDOCS%%share/doc/hylafax/Modems/Telebit/faxcmds.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ZyXEL/autodetect.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ZyXEL/codes.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ZyXEL/commands.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ZyXEL/compression.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ZyXEL/examples.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ZyXEL/voice.html
+%%PORTDOCS%%share/doc/hylafax/Modems/att-dataport.html
+%%PORTDOCS%%share/doc/hylafax/Modems/digicom-scout.html
+%%PORTDOCS%%share/doc/hylafax/Modems/everex-2496d.html
+%%PORTDOCS%%share/doc/hylafax/Modems/hayes-accura288.html
+%%PORTDOCS%%share/doc/hylafax/Modems/hayes-optima2400.html
+%%PORTDOCS%%share/doc/hylafax/Modems/index.html
+%%PORTDOCS%%share/doc/hylafax/Modems/multitech-1432.html
+%%PORTDOCS%%share/doc/hylafax/Modems/multitech-1932.html
+%%PORTDOCS%%share/doc/hylafax/Modems/multitech-2834.html
+%%PORTDOCS%%share/doc/hylafax/Modems/nuvo-96424pfx.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ppi-pm14400fxmt.html
+%%PORTDOCS%%share/doc/hylafax/Modems/rockwell-56k.html
+%%PORTDOCS%%share/doc/hylafax/Modems/supra-v32bis.html
+%%PORTDOCS%%share/doc/hylafax/Modems/telebit-t3000.html
+%%PORTDOCS%%share/doc/hylafax/Modems/twincom-144df.html
+%%PORTDOCS%%share/doc/hylafax/Modems/ucom-traveller96.html
+%%PORTDOCS%%share/doc/hylafax/Modems/usr-courier.html
+%%PORTDOCS%%share/doc/hylafax/Modems/usr-sportster.html
+%%PORTDOCS%%share/doc/hylafax/Modems/zyxel-1496.html
+%%PORTDOCS%%share/doc/hylafax/Modems/zyxel-elite.html
+%%PORTDOCS%%share/doc/hylafax/Modems/zyxel-omni.html
+%%PORTDOCS%%share/doc/hylafax/namechange.html
+%%PORTDOCS%%share/doc/hylafax/operation.html
+%%PORTDOCS%%share/doc/hylafax/overview.html
+%%PORTDOCS%%share/doc/hylafax/sam.gif
+%%PORTDOCS%%share/doc/hylafax/sam.html
+%%PORTDOCS%%share/doc/hylafax/setup.html
+%%PORTDOCS%%share/doc/hylafax/setup-advanced.html
+%%PORTDOCS%%share/doc/hylafax/setup-client.html
+%%PORTDOCS%%share/doc/hylafax/source.html
+%%PORTDOCS%%share/doc/hylafax/toc.html
+%%PORTDOCS%%share/doc/hylafax/troubleshooting.html
+%%PORTDOCS%%share/doc/hylafax/upgrade4.0.html
+%%PORTDOCS%%share/doc/hylafax/v2.3beta036.html
+%%PORTDOCS%%share/doc/hylafax/v2.3beta036special.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta096.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta100.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta108.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta110.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta111.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta112.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta113.html
+%%PORTDOCS%%share/doc/hylafax/v3.0beta114.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta005.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta006.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta007.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta008.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta009.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta010.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta011.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta012.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta013.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta014.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta015.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta018.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta020.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta021.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta022.html
+%%PORTDOCS%%share/doc/hylafax/v4.0beta023.html
+%%PORTDOCS%%share/doc/hylafax/version.html
+%%PORTDOCS%%@dirrm share/doc/hylafax/cgi-bin
+%%PORTDOCS%%@dirrm share/doc/hylafax/icons
+%%PORTDOCS%%@dirrm share/doc/hylafax/Majordomo
+%%PORTDOCS%%@dirrm share/doc/hylafax/Modems/Hayes
+%%PORTDOCS%%@dirrm share/doc/hylafax/Modems/Supra
+%%PORTDOCS%%@dirrm share/doc/hylafax/Modems/Telebit
+%%PORTDOCS%%@dirrm share/doc/hylafax/Modems/ZyXEL
+%%PORTDOCS%%@dirrm share/doc/hylafax/Modems
+%%PORTDOCS%%@dirrm share/doc/hylafax
+@cwd /var/spool
+hylafax/COPYRIGHT
+@exec mkfifo %D/hylafax/FIFO
+@exec chown uucp:dialer %D/hylafax/FIFO
+@exec chmod 0600 %D/hylafax/FIFO
+@unexec rm %D/hylafax/FIFO*
+@exec mkdir %D/hylafax/archive
+@exec chown uucp:dialer %D/hylafax/archive
+@exec chmod 0700 %D/hylafax/archive
+hylafax/bin/archive
+hylafax/bin/faxrcvd
+hylafax/bin/mkcover
+hylafax/bin/notify
+hylafax/bin/notify.awk
+@unexec if [ -f %D/hylafax/bin/pdf2fax ]; then rm %D/hylafax/bin/pdf2fax; fi
+hylafax/bin/pdf2fax.gs
+hylafax/bin/pcl2fax
+hylafax/bin/pollrcvd
+@unexec if [ -f %D/hylafax/bin/ps2fax ]; then rm %D/hylafax/bin/ps2fax; fi
+hylafax/bin/ps2fax.dps
+hylafax/bin/ps2fax.gs
+hylafax/bin/ps2fax.imp
+hylafax/bin/tiff2fax
+hylafax/bin/wedged
+@exec mkdir %D/hylafax/client
+@exec chown uucp:dialer %D/hylafax/client
+@exec chmod 0755 %D/hylafax/client
+hylafax/config/att-dataport
+hylafax/config/att-dataport-2
+hylafax/config/att-dataport-2.0
+hylafax/config/att-dpexpress-2
+hylafax/config/cirrus
+hylafax/config/class1
+hylafax/config/class1.0
+hylafax/config/class2
+hylafax/config/class2.0
+hylafax/config/class2.1
+hylafax/config/digi
+hylafax/config/digi-2
+hylafax/config/digi-20
+hylafax/config/davicom-2
+hylafax/config/dsi-scout+
+hylafax/config/e-tech
+hylafax/config/eicon
+hylafax/config/eicon-2
+hylafax/config/elsa-microlink-56k-basic-2.0
+hylafax/config/everex-2496d
+hylafax/config/exar
+hylafax/config/gvc-288
+hylafax/config/gvc-288-2
+hylafax/config/hayes
+hylafax/config/intel-400e
+hylafax/config/lucent
+hylafax/config/lucent-isa
+hylafax/config/lucent-mt-2
+hylafax/config/lucent-mt-20
+hylafax/config/lucent-mt-21
+hylafax/config/moto-288
+hylafax/config/mt-1432
+hylafax/config/nuvo-voyager
+hylafax/config/ppi-pm14400fxmt
+hylafax/config/ppi-pm14400fxsa
+hylafax/config/prometheus
+hylafax/config/rc144ac
+hylafax/config/rc144ac-1
+hylafax/config/rc288dpi
+hylafax/config/rc288dpi-1
+hylafax/config/rc32acl
+hylafax/config/rc32acl-1
+hylafax/config/rockwell-k56
+hylafax/config/rockwell-rc
+hylafax/config/sierra
+hylafax/config/skel
+hylafax/config/telebit-qblazer
+hylafax/config/telebit-t3000
+hylafax/config/telebit-wb
+hylafax/config/topic
+hylafax/config/tricom2842
+hylafax/config/uds-fastalk
+hylafax/config/umc92144
+hylafax/config/umc9624
+hylafax/config/usr-2.0
+hylafax/config/usr-rts
+hylafax/config/usr-xon
+hylafax/config/zyxel-1496e
+hylafax/config/zyxel-1496e-1
+hylafax/config/zyxel-1496e-2.0
+hylafax/config/zyxel-2864
+@exec mkdir %D/hylafax/dev
+@exec chown uucp:dialer %D/hylafax/dev
+@exec chmod 0755 %D/hylafax/dev
+@unexec if [ -f %D/hylafax/dev/null ]; then rm %D/hylafax/dev/null; fi
+@exec mkdir %D/hylafax/docq
+@exec chown uucp:dialer %D/hylafax/docq
+@exec chmod 0700 %D/hylafax/docq
+@exec mkdir %D/hylafax/doneq
+@exec chown uucp:dialer %D/hylafax/doneq
+@exec chmod 0700 %D/hylafax/doneq
+hylafax/etc/cover.templ
+hylafax/etc/dialrules
+hylafax/etc/dialrules.europe
+hylafax/etc/dialrules.sf-ba
+hylafax/etc/dpsprinter.ps
+hylafax/etc/hosts.hfaxd
+hylafax/etc/lutRS18.pcf
+hylafax/etc/xferfaxlog
+@exec mkdir %D/hylafax/info
+@exec chown uucp:dialer %D/hylafax/info
+@exec chmod 755 %D/hylafax/info
+@exec mkdir %D/hylafax/log
+@exec chown uucp:dialer %D/hylafax/log
+@exec chmod 755 %D/hylafax/log
+@exec mkdir %D/hylafax/pollq
+@exec chown uucp:dialer %D/hylafax/pollq
+@exec chmod 700 %D/hylafax/pollq
+@exec mkdir %D/hylafax/recvq
+@exec chown uucp:dialer %D/hylafax/recvq
+@exec chmod 755 %D/hylafax/recvq
+@exec mkdir %D/hylafax/sendq
+@exec chown uucp:dialer %D/hylafax/sendq
+@exec chmod 700 %D/hylafax/sendq
+@exec mkdir %D/hylafax/status
+@exec chown uucp:dialer %D/hylafax/status
+@exec chmod 755 %D/hylafax/status
+@exec mkdir %D/hylafax/tmp
+@exec chown uucp:dialer %D/hylafax/tmp
+@exec chmod 700 %D/hylafax/tmp
+@dirrm hylafax/archive
+@dirrm hylafax/bin
+@dirrm hylafax/client
+@dirrm hylafax/config
+@dirrm hylafax/dev
+@dirrm hylafax/docq
+@dirrm hylafax/doneq
+@dirrm hylafax/etc
+@dirrm hylafax/info
+@dirrm hylafax/log
+@dirrm hylafax/pollq
+@dirrm hylafax/recvq
+@dirrm hylafax/sendq
+@dirrm hylafax/status
+@dirrm hylafax/tmp
+@dirrm hylafax