aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-25 21:52:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-25 21:52:16 +0000
commit9b9a88cfa25a4d1d9a7ebb85501e97e01f4be6c8 (patch)
tree648b755347dccefd04bd4ee9c076f324f5499d5c /comms
parentf9a87c90cff3962c632938cc4cf044a0391da571 (diff)
downloadports-9b9a88cfa25a4d1d9a7ebb85501e97e01f4be6c8.tar.gz
ports-9b9a88cfa25a4d1d9a7ebb85501e97e01f4be6c8.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/predict/Makefile26
-rw-r--r--comms/predict/distinfo2
-rw-r--r--comms/predict/files/Makefile45
-rw-r--r--comms/predict/files/predict.h1
-rw-r--r--comms/predict/pkg-descr7
6 files changed, 82 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index b1cc9f2b305d..5c6f688fa6ab 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -53,6 +53,7 @@
SUBDIR += p5-Device-SerialPort
SUBDIR += plp
SUBDIR += pr
+ SUBDIR += predict
SUBDIR += pstngw
SUBDIR += py-bulksms
SUBDIR += py-lirc
diff --git a/comms/predict/Makefile b/comms/predict/Makefile
new file mode 100644
index 000000000000..71e4e974f2ca
--- /dev/null
+++ b/comms/predict/Makefile
@@ -0,0 +1,26 @@
+# ports collection makefile for: predict
+# Date created: 11 February 2004
+# Whom: db
+#
+# $FreeBSD$
+#
+
+PORTNAME= predict
+PORTVERSION= 2.2.2
+CATEGORIES= comms
+MASTER_SITES= ftp://ftp.amsat.org/amsat/software/Linux/
+
+MAINTAINER= db@db.net
+COMMENT= Satellite tracking program for amateur radio satellites
+
+INSTALL_TARGET= install install.man
+
+MAN1= predict.1
+PLIST_FILES= bin/predict
+MAKE_ENV= LIBS="${PTHREAD_LIBS}"
+
+post-patch:
+ ${SED} -e 's|%%PREFIX%%|${PREFIX}|g' ${FILESDIR}/predict.h > ${WRKSRC}/predict.h
+ ${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/comms/predict/distinfo b/comms/predict/distinfo
new file mode 100644
index 000000000000..8afb5eed9c19
--- /dev/null
+++ b/comms/predict/distinfo
@@ -0,0 +1,2 @@
+MD5 (predict-2.2.2.tar.gz) = 2512bc6b584ece66de027e46f114ab53
+SIZE (predict-2.2.2.tar.gz) = 1637893
diff --git a/comms/predict/files/Makefile b/comms/predict/files/Makefile
new file mode 100644
index 000000000000..20fb3df53470
--- /dev/null
+++ b/comms/predict/files/Makefile
@@ -0,0 +1,45 @@
+# $FreeBSD$
+
+.ifndef CC
+CC = -cc
+.endif
+.ifndef CPPFLAGS
+CPPFLAGS =
+.endif
+.ifndef CFLAGS
+CFLAGS = -O2
+.endif
+
+default: all
+
+all: predict
+
+SRCS = \
+ predict.c
+
+OBJS = ${SRCS:.c=.o}
+LIBS += -lm -lncurses -o predict
+#
+#
+HDRS = predict.h
+
+predict: ${OBJS} ${HDRS}
+ ${CC} ${CFLAGS} -o $@ ${OBJS} ${LIBS}
+
+.c.o:
+ ${CC} ${CPPFLAGS} ${CFLAGS} -c $<
+
+,v.c:
+ co $<
+
+clean:
+ rm -f *.o predict *core *~ \#* *.txt
+
+install:
+ echo INSTALL
+ install predict ${PREFIX}/bin
+
+install.man:
+ install docs/man/predict.1 ${PREFIX}/man/man1
+
+.PHONY: clean build
diff --git a/comms/predict/files/predict.h b/comms/predict/files/predict.h
new file mode 100644
index 000000000000..72739891eed3
--- /dev/null
+++ b/comms/predict/files/predict.h
@@ -0,0 +1 @@
+char *predictpath={"%%PREFIX%%/bin/predict"}, soundcard=1, *version={"2.2.2"};
diff --git a/comms/predict/pkg-descr b/comms/predict/pkg-descr
new file mode 100644
index 000000000000..370930a2b215
--- /dev/null
+++ b/comms/predict/pkg-descr
@@ -0,0 +1,7 @@
+This is a satellite tracking program for amateur radio satellites.
+Written by John A. Magliacane, KD2BD
+
+WWW: http://www.qsl.net/kd2bd/predict.html
+
+- Diane Bruce, VA3DB
+db@db.net