aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-03-26 19:46:43 +0000
committerDiane Bruce <db@FreeBSD.org>2020-03-26 19:46:43 +0000
commita0d692af48705cb6b99623e1ca52a3128a8ca42f (patch)
tree910703d886a4342cb4df1691fc538604a2cb4bf9 /comms
parentac169d22ec97660c5431d41e54f5df00c8db0e9e (diff)
downloadports-a0d692af48705cb6b99623e1ca52a3128a8ca42f.tar.gz
ports-a0d692af48705cb6b99623e1ca52a3128a8ca42f.zip
- Pet porlint
- strip binary - regenerate Makefile patch
Notes
Notes: svn path=/head/; revision=529209
Diffstat (limited to 'comms')
-rw-r--r--comms/ebook2cw/Makefile4
-rw-r--r--comms/ebook2cw/files/patch-Makefile22
2 files changed, 14 insertions, 12 deletions
diff --git a/comms/ebook2cw/Makefile b/comms/ebook2cw/Makefile
index 471655108e7b..e0daa2a54f37 100644
--- a/comms/ebook2cw/Makefile
+++ b/comms/ebook2cw/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ebook2cw
PORTVERSION= 0.8.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= comms hamradio
MASTER_SITES= http://fkurz.net/ham/ebook2cw/ \
LOCAL/db
@@ -13,6 +13,7 @@ COMMENT= Convert text files into cw as an mp3 or ogg file
LICENSE= GPLv2
LIB_DEPENDS= libmp3lame.so:audio/lame \
+ libogg.so:audio/libogg \
libvorbis.so:audio/libvorbis
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -24,6 +25,7 @@ post-patch:
${WRKSRC}/Makefile
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/ebook2cw ${STAGEDIR}${PREFIX}/bin/ebook2cw
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/ebook2cw
${INSTALL_DATA} ${WRKSRC}/ebook2cw.1 ${STAGEDIR}${PREFIX}/man/man1
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ebook2cw.conf isomap.txt utf8map.txt
diff --git a/comms/ebook2cw/files/patch-Makefile b/comms/ebook2cw/files/patch-Makefile
index 5a896fedf70a..012d268cf5a6 100644
--- a/comms/ebook2cw/files/patch-Makefile
+++ b/comms/ebook2cw/files/patch-Makefile
@@ -1,20 +1,20 @@
---- Makefile.orig 2013-01-04 09:33:04.000000000 -0500
-+++ Makefile 2013-01-16 10:16:50.000000000 -0500
+--- Makefile.orig 2013-01-04 14:33:04 UTC
++++ Makefile
@@ -3,37 +3,26 @@
# $Id: Makefile 547 2012-12-29 21:07:53Z dj1yfk $
VERSION=0.8.2
-DESTDIR ?= /usr
--
++DESTDIR ?= /usr/local
++CC ?= gcc
+
-# Set to NO to compile without Lame/Ogg-vorbis support
-USE_LAME?=YES
-USE_OGG?=YES
-+DESTDIR ?= %%PREFIX%%
-+CC ?= gcc
-
+-
CFLAGS:=$(CFLAGS) -D DESTDIR=\"$(DESTDIR)\" -D VERSION=\"$(VERSION)\"
-+CFLAGS+= -I%%LOCALBASE%%/include -D LAME -D OGGV
-+LDFLAGS+= -L%%LOCALBASE%%/lib -lmp3lame -lvorbis -lvorbisenc -logg
++CFLAGS+= -I/usr/local/include -D LAME -D OGGV
++LDFLAGS+= -L/usr/local/lib -lmp3lame -lvorbis -lvorbisenc -logg
-ifeq ($(USE_LAME), YES)
- CFLAGS:=$(CFLAGS) -D LAME
@@ -24,11 +24,11 @@
- CFLAGS:=$(CFLAGS) -D OGGV
- LDFLAGS:=$(LDFLAGS) -lvorbis -lvorbisenc -logg
-endif
--
--
--all: ebook2cw
+all: ebook2cw cgi
+-
+-all: ebook2cw
+-
ebook2cw: ebook2cw.c codetables.h
- gcc ebook2cw.c -pedantic -Wall -lm $(LDFLAGS) $(CFLAGS) -o ebook2cw
+ ${CC} ebook2cw.c -pedantic -Wall -lm $(LDFLAGS) $(CFLAGS) -o ebook2cw