aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-06-06 14:24:22 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-06-06 14:24:22 +0000
commit1fa64dfd1bc9a29742ce06d97c18573052ca97c7 (patch)
tree1e96fb1817890aedefdc28d106e18f168d28731c /comms
parent1e9d5b58642d6f3c84efc06e6596baea4a0dd7ce (diff)
downloadports-1fa64dfd1bc9a29742ce06d97c18573052ca97c7.tar.gz
ports-1fa64dfd1bc9a29742ce06d97c18573052ca97c7.zip
OpenCBM plugin for parallel-port cables
The OpenCBM package contains user space support programs and development libraries to control and use CBM serial IEC/IEEE-488 bus devices as used by most Commodore (CBM) 8-bit machines. This port contains the xa1541 plugin for parallel-port cables. WWW: http://opencbm.sourceforge.net/ PR: 246784 Submitted by: Felix Palmen
Notes
Notes: svn path=/head/; revision=538095
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/opencbm-plugin-xa1541/Makefile36
-rw-r--r--comms/opencbm-plugin-xa1541/pkg-descr9
-rw-r--r--comms/opencbm-plugin-xa1541/pkg-plist5
4 files changed, 51 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 1493a79ea665..6ba5a2252712 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -109,6 +109,7 @@
SUBDIR += obexapp
SUBDIR += opencbm
SUBDIR += opencbm-kmod
+ SUBDIR += opencbm-plugin-xa1541
SUBDIR += openobex
SUBDIR += openzwave
SUBDIR += openzwave-devel
diff --git a/comms/opencbm-plugin-xa1541/Makefile b/comms/opencbm-plugin-xa1541/Makefile
new file mode 100644
index 000000000000..ee8193a75543
--- /dev/null
+++ b/comms/opencbm-plugin-xa1541/Makefile
@@ -0,0 +1,36 @@
+# Created by: Felix Palmen <felix@palmen-it.de>
+# $FreeBSD$
+
+PORTNAME= opencbm-plugin-xa1541
+PORTVERSION= ${OCBM_VERSION}
+CATEGORIES= comms archivers
+
+PATCHFILES= 12ef17d4cf78903c9c52d7a348a816424d549b89.diff \
+ ca4c06e7430caf3b2296d4e1e00051fff015fc53.diff
+
+MAINTAINER= felix@palmen-it.de
+COMMENT= OpenCBM plugin for parallel-port cables
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= cc65:devel/cc65
+RUN_DEPENDS= opencbm=${PORTVERSION}:comms/opencbm \
+ opencbm-kmod=${PORTVERSION}:comms/opencbm-kmod
+
+USES= gmake
+USE_LDCONFIG= yes
+
+MAKE_ARGS= CC=cc SUBDIRS_PLUGIN_XA1541=opencbm/lib/plugin/xa1541
+MAKEFILE= LINUX/Makefile
+MAKE_JOBS_UNSAFE= yes
+ALL_TARGET= plugin-xa1541
+INSTALL_TARGET= install-plugin-xa1541
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PLUGINBASENAME}xa1541.so.${OCBM_LIBVERSION}
+ @${RM} ${STAGEDIR}${PREFIX}/etc/opencbm.conf.d/00opencbm.conf
+ @${RM} ${STAGEDIR}${PREFIX}/etc/opencbm.conf
+
+.include "../opencbm/Makefile.inc"
+
+.include <bsd.port.mk>
diff --git a/comms/opencbm-plugin-xa1541/pkg-descr b/comms/opencbm-plugin-xa1541/pkg-descr
new file mode 100644
index 000000000000..977cbdf42d84
--- /dev/null
+++ b/comms/opencbm-plugin-xa1541/pkg-descr
@@ -0,0 +1,9 @@
+OpenCBM plugin for parallel-port cables
+
+The OpenCBM package contains user space support programs and development
+libraries to control and use CBM serial IEC/IEEE-488 bus devices as used by
+most Commodore (CBM) 8-bit machines.
+
+This port contains the xa1541 plugin for parallel-port cables.
+
+WWW: http://opencbm.sourceforge.net/
diff --git a/comms/opencbm-plugin-xa1541/pkg-plist b/comms/opencbm-plugin-xa1541/pkg-plist
new file mode 100644
index 000000000000..db83ee6994ce
--- /dev/null
+++ b/comms/opencbm-plugin-xa1541/pkg-plist
@@ -0,0 +1,5 @@
+etc/opencbm.conf.d/10xa1541.conf
+lib/opencbm/plugin/libopencbm-xa1541.a
+lib/opencbm/plugin/libopencbm-xa1541.so
+lib/opencbm/plugin/libopencbm-xa1541.so.0
+lib/opencbm/plugin/libopencbm-xa1541.so.0.4.99.99