aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorStephen Hurd <shurd@FreeBSD.org>2015-12-15 09:25:26 +0000
committerStephen Hurd <shurd@FreeBSD.org>2015-12-15 09:25:26 +0000
commit3f5400005107a89f95f53106f8bd823e515b1524 (patch)
tree2803982445598b9a9994f11cfb2e005ab180ae14 /comms
parentbf21fdb9e2690957be7bab4623e7fb0f5de5c2f0 (diff)
downloadports-3f5400005107a89f95f53106f8bd823e515b1524.tar.gz
ports-3f5400005107a89f95f53106f8bd823e515b1524.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/freedv/Makefile30
-rw-r--r--comms/freedv/distinfo2
-rw-r--r--comms/freedv/files/patch-CMakeLists.txt24
-rw-r--r--comms/freedv/pkg-descr9
-rw-r--r--comms/freedv/pkg-plist6
6 files changed, 72 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 455f590b375d..7b4e0142430b 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -45,6 +45,7 @@
SUBDIR += fllog
SUBDIR += flrig
SUBDIR += flwrap
+ SUBDIR += freedv
SUBDIR += gammu
SUBDIR += ge-x2212
SUBDIR += geoid
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
new file mode 100644
index 000000000000..66bc3ca0f37d
--- /dev/null
+++ b/comms/freedv/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= freedv
+PORTVERSION= 1.1
+CATEGORIES= comms hamradio
+MASTER_SITES= http://files.freedv.org/freedv/ \
+ LOCAL/shurd
+
+MAINTAINER= hamradio@FreeBSD.org
+COMMENT= Narrow band digital voice
+
+LIB_DEPENDS= libcodec2.so:${PORTSDIR}/audio/codec2 \
+ libportaudio.so:${PORTSDIR}/audio/portaudio \
+ libhamlib.so:${PORTSDIR}/comms/hamlib \
+ libsamplerate.so:${PORTSDIR}/audio/libsamplerate \
+ libsox.so:${PORTSDIR}/audio/sox \
+ libsndfile.so:${PORTSDIR}/audio/libsndfile \
+ libspeexdsp.so:${PORTSDIR}/audio/speex
+
+USE_WX= 3.0+
+USES= cmake:outsource compiler:c++11-lib tar:xz
+CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
+ -DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
+ -DUSE_STATIC_CODEC2=FALSE \
+ -DUSE_STATIC_PORTAUDIO=FALSE \
+ -DUSE_STATIC_SOX=FALSE \
+ -DUSE_STATIC_SPEEXDSP=FALSE
+INSTALLS_ICONS= yes
+
+.include <bsd.port.mk>
diff --git a/comms/freedv/distinfo b/comms/freedv/distinfo
new file mode 100644
index 000000000000..3fff80a39c1c
--- /dev/null
+++ b/comms/freedv/distinfo
@@ -0,0 +1,2 @@
+SHA256 (freedv-1.1.tar.xz) = 3439930d73ebc9f58d39f4dff45356c3ee0e338a984e98ef8eb839eccaa44703
+SIZE (freedv-1.1.tar.xz) = 424420
diff --git a/comms/freedv/files/patch-CMakeLists.txt b/comms/freedv/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..8d6a7ed981ee
--- /dev/null
+++ b/comms/freedv/files/patch-CMakeLists.txt
@@ -0,0 +1,24 @@
+--- CMakeLists.txt.orig 2015-09-24 19:30:57 UTC
++++ CMakeLists.txt
+@@ -72,7 +72,7 @@ endif()
+
+
+ # Set default build flags.
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall")
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -std=c++11")
+
+ #
+ # Setup cmake options
+@@ -339,6 +339,12 @@ if(NOT USE_STATIC_SOX)
+ if(LIBSOX_LIBRARY AND LIBSOX_INCLUDE_DIR)
+ list(APPEND FREEDV_LINK_LIBS ${LIBSOX_LIBRARY})
+ include_directories(${LIBSOX_INCLUDE_DIR})
++ message(STATUS "Looking for static sox...")
++ find_library(STATIC_LIBSOX_LIBRARY libsox.a)
++ message(STATUS " static sox library: ${STATIC_LIBSOX_LIBRARY}")
++ if(STATIC_LIBSOX_LIBRARY)
++ list(APPEND FREEDV_LINK_LIBS ${STATIC_LIBSOX_LIBRARY})
++ endif(STATIC_LIBSOX_LIBRARY)
+ else(LIBSOX_LIBRARY AND LIBSOX_INCLUDE_DIR)
+ message(FATAL_ERROR "sox library not found.
+ On Linux systems try installing:
diff --git a/comms/freedv/pkg-descr b/comms/freedv/pkg-descr
new file mode 100644
index 000000000000..22db75454e42
--- /dev/null
+++ b/comms/freedv/pkg-descr
@@ -0,0 +1,9 @@
+FreeDV is a Digital Voice mode for HF radio. FreeDV allows any SSB radio
+to be used for low bit rate digital voice. Speech is compressed down to
+700-1600 bit/s then modulated onto a 1.25 kHz wide signal comprised of
+16 QPSK carriers which is sent to the Mic input of a SSB radio. The signal
+is received by an SSB radio, then demodulated and decoded by FreeDV. FreeDV
+700(B) rivals SSB in it's low SNR performance. At high SNRs FreeDV 1600
+sounds like FM, with no annoying analog HF radio noise.
+
+WWW: http://freedv.org/tiki-index.php
diff --git a/comms/freedv/pkg-plist b/comms/freedv/pkg-plist
new file mode 100644
index 000000000000..f82fe84ace20
--- /dev/null
+++ b/comms/freedv/pkg-plist
@@ -0,0 +1,6 @@
+bin/freedv
+share/applications/freedv.desktop
+share/icons/hicolor/128x128/apps/freedv.png
+share/icons/hicolor/256x256/apps/freedv.png
+share/icons/hicolor/48x48/apps/freedv.png
+share/icons/hicolor/64x64/apps/freedv.png