aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2010-12-22 20:05:49 +0000
committerAde Lovett <ade@FreeBSD.org>2010-12-22 20:05:49 +0000
commit843f8123d49e579e80de26ff1dd62c8c1acf3fac (patch)
treec7ef29d508548833364cb92d3bd5bcf810816e88 /comms
parent55d09a7758330e40bc25cb90b27b1ae9b034af02 (diff)
downloadports-843f8123d49e579e80de26ff1dd62c8c1acf3fac.tar.gz
ports-843f8123d49e579e80de26ff1dd62c8c1acf3fac.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/aldo/Makefile7
-rw-r--r--comms/gnuradio/Makefile4
-rw-r--r--comms/unixcw/Makefile1
-rw-r--r--comms/unixcw/files/patch-configure.ac2
4 files changed, 10 insertions, 4 deletions
diff --git a/comms/aldo/Makefile b/comms/aldo/Makefile
index a2e8214fdf4f..3a62eaa4b8a1 100644
--- a/comms/aldo/Makefile
+++ b/comms/aldo/Makefile
@@ -27,9 +27,12 @@ USE_GMAKE= yes
PLIST_FILES= bin/aldo
MAN1= aldo.1
+AUTOTOOLSFILES= aclocal.m4
+
post-patch:
- @${REINPLACE_CMD} -e 's|1.10|1.11.1|g' ${WRKSRC}/aclocal.m4
- @${REINPLACE_CMD} -e 's|2.61|2.68|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|1.10|%%AUTOMAKE_APIVER%%|g' \
+ -e 's|2.61|%%AUTOCONF_VERSION%%|g' \
+ ${WRKSRC}/aclocal.m4
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/aldo ${PREFIX}/bin
diff --git a/comms/gnuradio/Makefile b/comms/gnuradio/Makefile
index 9d450aaea1de..d37198d77c56 100644
--- a/comms/gnuradio/Makefile
+++ b/comms/gnuradio/Makefile
@@ -55,8 +55,10 @@ CONFIGURE_ARGS= --with-boost-include-dir="${LOCALBASE}/include/" \
LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
.endif
+AUTOTOOLSFILES= aclocal.m4
+
post-patch:
- @${REINPLACE_CMD} -e 's|2.61|2.68|g' ${WRKSRC}/aclocal.m4
+ @${REINPLACE_CMD} -e 's|2.61|%%AUTOCONF_VERSION%%|g' ${WRKSRC}/aclocal.m4
@${REINPLACE_CMD} -e 's|^GR_FORTRAN||g' ${WRKSRC}/configure.ac
@${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
-n 10 ${REINPLACE_CMD} -E -e \
diff --git a/comms/unixcw/Makefile b/comms/unixcw/Makefile
index 2d87e2d81354..3b013705d556 100644
--- a/comms/unixcw/Makefile
+++ b/comms/unixcw/Makefile
@@ -35,6 +35,7 @@ MANCOMPRESSED= yes
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
USE_GMAKE= yes
+AUTOTOOLSFILES= configure.ac
pre-extract:
.if !defined(WITH_XCWCP)
diff --git a/comms/unixcw/files/patch-configure.ac b/comms/unixcw/files/patch-configure.ac
index 8a2c74e76f0b..a362169195e6 100644
--- a/comms/unixcw/files/patch-configure.ac
+++ b/comms/unixcw/files/patch-configure.ac
@@ -5,7 +5,7 @@
# General initializations.
-AC_PREREQ(2.57)
-+AC_PREREQ(2.68)
++AC_PREREQ(%%AUTOCONF_VERSION%%)
AC_INIT([UnixCW], 2.3, [simon_baldwin@yahoo.com])
-
# Specify a configuration header.