aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-04-29 13:40:39 +0000
committerDiane Bruce <db@FreeBSD.org>2020-04-29 13:40:39 +0000
commita6560981d4d9e11e241ccd4b2c514f19e254cc08 (patch)
tree2033ea6237d10507d760d2f5cc9b4ce3d0f40b6c /comms
parentd89213bc0e4fe30ceab777b433d76d76d357f8dc (diff)
downloadports-a6560981d4d9e11e241ccd4b2c514f19e254cc08.tar.gz
ports-a6560981d4d9e11e241ccd4b2c514f19e254cc08.zip
Update to 1.4.1
2019-10-28 Thomas Beierlein <tomjbe@gentoo.org> * NEWS, ToDo: Update NEWS and ToDo files 2019-09-30 Thomas Beierlein <tomjbe@gentoo.org> * src/fldigixmlrpc.c, src/gettxinfo.c, src/globalvars.h, src/main.c, test/data.c: Fix definition of 'rigmode' variable Newest version of hamlib has an extended range of modei definitions and therefore defined it as UInt64. That conflicts with the former definition of 'rigmode' as 32 bit int. Reported by: portscout
Notes
Notes: svn path=/head/; revision=533336
Diffstat (limited to 'comms')
-rw-r--r--comms/tlf/Makefile7
-rw-r--r--comms/tlf/distinfo6
-rw-r--r--comms/tlf/files/patch-src_editlog.c10
3 files changed, 17 insertions, 6 deletions
diff --git a/comms/tlf/Makefile b/comms/tlf/Makefile
index 738b9b772fda..62e744aeeb0e 100644
--- a/comms/tlf/Makefile
+++ b/comms/tlf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tlf
-PORTVERSION= 1.3.2
+PORTVERSION= 1.4.1
DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= comms hamradio
@@ -11,6 +11,7 @@ COMMENT= Amateur Radio curses based logging program
LICENSE= GPLv2
+LIB_DEPENDS= libargp.so:devel/argp-standalone
RUN_DEPENDS= rec:audio/sox \
wget:ftp/wget
@@ -19,8 +20,8 @@ USE_GITHUB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= PANEL_LIB=-lpanel
USE_GNOME= glib20
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/lib
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -largp" \
+ CPPFLAGS=-I${LOCALBASE}/include
OPTIONS_SUB= yes
OPTIONS_DEFINE= HAMLIB FLDIGI DOCS
diff --git a/comms/tlf/distinfo b/comms/tlf/distinfo
index 39913b97a645..ae31fd88614a 100644
--- a/comms/tlf/distinfo
+++ b/comms/tlf/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1555701649
-SHA256 (tlf-tlf-tlf-1.3.2_GH0.tar.gz) = 5a444e4f55c7bf0209d6d12ed3387dabca9db457115068d4f79fb89b3d6f6a02
-SIZE (tlf-tlf-tlf-1.3.2_GH0.tar.gz) = 552308
+TIMESTAMP = 1588167295
+SHA256 (tlf-tlf-tlf-1.4.1_GH0.tar.gz) = a5a4d0492d206fe67d324271c50c48801236a955c36edddc198289330cb17386
+SIZE (tlf-tlf-tlf-1.4.1_GH0.tar.gz) = 567979
diff --git a/comms/tlf/files/patch-src_editlog.c b/comms/tlf/files/patch-src_editlog.c
new file mode 100644
index 000000000000..05a0eacacbc1
--- /dev/null
+++ b/comms/tlf/files/patch-src_editlog.c
@@ -0,0 +1,10 @@
+--- src/editlog.c.orig 2020-04-29 13:15:29 UTC
++++ src/editlog.c
+@@ -29,6 +29,7 @@
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/stat.h>
++#include <sys/wait.h>
+
+ #include "background_process.h"
+ #include "checklogfile.h"