aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2003-07-04 13:13:50 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2003-07-04 13:13:50 +0000
commitbbe8b66e9711b5880748ef784e7af3d419df3c60 (patch)
tree2cfc7fc5cf5ab09d45713e5116fe52e241dfd3cd /comms
parent06427e2661017a8590299cb15e3da4fca4756ff1 (diff)
downloadports-bbe8b66e9711b5880748ef784e7af3d419df3c60.tar.gz
ports-bbe8b66e9711b5880748ef784e7af3d419df3c60.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/hylafax/Makefile14
-rw-r--r--comms/hylafax/distinfo5
-rw-r--r--comms/hylafax/pkg-plist11
3 files changed, 18 insertions, 12 deletions
diff --git a/comms/hylafax/Makefile b/comms/hylafax/Makefile
index db27aa837512..90c8d332bd65 100644
--- a/comms/hylafax/Makefile
+++ b/comms/hylafax/Makefile
@@ -6,14 +6,15 @@
#
PORTNAME= hylafax
-PORTVERSION= 4.1.5
+PORTVERSION= 4.1.6
CATEGORIES= comms
MASTER_SITES= ftp://ftp.hylafax.org/source/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= tdv94ped@cs.umu.se
COMMENT= Fax software
BUILD_DEPENDS= ${LOCALBASE}/lib/afm/Courier:${PORTSDIR}/print/afm
+
# no dependency on ghostscript because we don't know which
# version the user prefers
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
@@ -27,16 +28,18 @@ CONFIGURE_ARGS= --with-INSTALL="" \
--with-TIFFINC="${LOCALBASE}/include" \
--with-GCOPTS=" " --with-GCXXOPTS=" " \
--with-REGEX=no --with-LIBREGEX='' --with-REGEXINC=none \
- --with-DIR_HTML="${LOCALBASE}/share/doc/hylafax"
+ --with-DIR_HTML="${DOCSDIR}"
+
# Defaults to "North American Letter". Use "ISO A4" for A4.
.ifdef PAGESIZE
CONFIGURE_ARGS+=--with-PAGESIZE="${PAGESIZE}"
.endif
+
.if defined(PACKAGE_BUILDING) || defined(BATCH)
CONFIGURE_ARGS+=--nointeractive
.endif
-MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
+MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER
HAS_CONFIGURE= yes
CONFIGURE_ENV= ENVOPTS="${CFLAGS}"
@@ -62,6 +65,9 @@ SUID_EXES= ${PREFIX}/sbin/faxgetty ${PREFIX}/sbin/faxq \
post-extract:
${RM} -rf ${WRKSRC}/zlib ${WRKSRC}/regex
+pre-install:
+PLIST_SUB= SPOOL="`${GREP} SPOOL ${WRKSRC}/defs | ${CUT} -c10-`"
+
post-install:
${CHOWN} uucp ${SUID_EXES}
${CHMOD} 4555 ${SUID_EXES}
diff --git a/comms/hylafax/distinfo b/comms/hylafax/distinfo
index a93b4d64cabf..d04490b7a015 100644
--- a/comms/hylafax/distinfo
+++ b/comms/hylafax/distinfo
@@ -1,4 +1 @@
-MD5 (hylafax/hylafax-4.1.5.tar.gz) = 67135ae721f7a927e0f9a96644694617
-MD5 (hylafax/tiff-3.5-interfaces.patch) = c1d2847c9967a10961bb7fe123ecd8e6
-MD5 (hylafax/cvtDateTime.patch) = 57b2d1218e83504c85cf31c1e3746e4e
-MD5 (hylafax/rings-cid-passing.patch) = ade1d9adc9dd236e45176b7a0e3b5d78
+MD5 (hylafax/hylafax-4.1.6.tar.gz) = b58d453c202ed521f5e4dbe6cfb430b2
diff --git a/comms/hylafax/pkg-plist b/comms/hylafax/pkg-plist
index 14b2a530b27d..84d75b080c5f 100644
--- a/comms/hylafax/pkg-plist
+++ b/comms/hylafax/pkg-plist
@@ -52,16 +52,18 @@ sbin/tsitest
sbin/typetest
sbin/xferfaxstats
@dirrm lib/fax
-@cwd /var/spool/hylafax
+@cwd %%SPOOL%%
COPYRIGHT
bin/archive
bin/faxrcvd
bin/mkcover
bin/notify
bin/notify.awk
+@unexec if [ -f %D/bin/pdf2fax ]; then rm %D/bin/pdf2fax; fi
bin/pdf2fax.gs
bin/pcl2fax
bin/pollrcvd
+@unexec if [ -f %D/bin/ps2fax ]; then rm %D/bin/ps2fax; fi
bin/ps2fax.dps
bin/ps2fax.gs
bin/ps2fax.imp
@@ -128,6 +130,7 @@ config/zyxel-1496e
config/zyxel-1496e-1
config/zyxel-1496e-2.0
config/zyxel-2864
+@unexec if [ -f %D/dev/null ]; then rm %D/dev/null; fi
etc/cover.templ
etc/dialrules
etc/dialrules.europe
@@ -141,7 +144,7 @@ etc/xferfaxlog
@exec mkfifo %D/FIFO
@exec chown uucp:dialer %D/FIFO
@exec chmod 600 %D/FIFO
-@unexec rm %D/FIFO
+@unexec rm %D/FIFO*
@exec mkdir %D/archive
@exec chown uucp:dialer %D/archive
@exec chmod 700 %D/archive
@@ -193,5 +196,5 @@ etc/xferfaxlog
@dirrm sendq
@dirrm status
@dirrm tmp
-@cwd /var/spool
-@dirrm hylafax
+@cwd /
+@dirrm %%SPOOL%%