aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2006-02-21 16:26:45 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2006-02-21 16:26:45 +0000
commitc4ad01236e048d16b29296ecfdd68e47551e688f (patch)
tree25dc4992241944ae87bcb31afe37b8ca4b6fcecd /comms
parent92abc480da97c0e2efbfe1dce7dcf158656bf6a1 (diff)
downloadports-c4ad01236e048d16b29296ecfdd68e47551e688f.tar.gz
ports-c4ad01236e048d16b29296ecfdd68e47551e688f.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/libticables/Makefile3
-rw-r--r--comms/libticables/distinfo6
-rw-r--r--comms/libticables/files/patch-src-bsd-bsd_mapping.c50
-rw-r--r--comms/libticables/files/patch-src-linux-slv_link2.c11
4 files changed, 5 insertions, 65 deletions
diff --git a/comms/libticables/Makefile b/comms/libticables/Makefile
index c68bfe1dabad..5ae41bac7ee0 100644
--- a/comms/libticables/Makefile
+++ b/comms/libticables/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libticables
-PORTVERSION= 3.9.2
+PORTVERSION= 3.9.7
CATEGORIES= comms
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tilp
@@ -17,6 +17,7 @@ COMMENT= TI calculator link cables library
LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
USE_GETTEXT= yes
USE_GNOME= gnomehack pkgconfig
USE_AUTOTOOLS= libtool:15
diff --git a/comms/libticables/distinfo b/comms/libticables/distinfo
index 480530e02da1..e7450a81588b 100644
--- a/comms/libticables/distinfo
+++ b/comms/libticables/distinfo
@@ -1,3 +1,3 @@
-MD5 (libticables-3.9.2.tar.gz) = 354675bfbd881082a9447efde9935226
-SHA256 (libticables-3.9.2.tar.gz) = 1c091859f09d5a38c76f0d64a93db46aa2b5d637c8a7370d348f21e7be324c37
-SIZE (libticables-3.9.2.tar.gz) = 575639
+MD5 (libticables-3.9.7.tar.gz) = 2dbe53914086e98ff015feb3586735fb
+SHA256 (libticables-3.9.7.tar.gz) = 67581a38cb314b85fe784a201f670e7aa921e0dee727af79d31a55867a85a653
+SIZE (libticables-3.9.7.tar.gz) = 576026
diff --git a/comms/libticables/files/patch-src-bsd-bsd_mapping.c b/comms/libticables/files/patch-src-bsd-bsd_mapping.c
deleted file mode 100644
index 95f40b2168da..000000000000
--- a/comms/libticables/files/patch-src-bsd-bsd_mapping.c
+++ /dev/null
@@ -1,50 +0,0 @@
---- src/bsd/bsd_mapping.c.orig Mon May 30 14:01:58 2005
-+++ src/bsd/bsd_mapping.c Mon May 30 14:09:38 2005
-@@ -74,9 +74,7 @@
- break;
-
- case LINK_AVR:
-- if(resources & IO_API) {
-- *method |= IOM_API | IOM_OK;
-- }
-+ printl1(2, "AVR link support has been removed !\n");
- break;
-
- case LINK_SER:
-@@ -114,6 +112,7 @@
-
- case LINK_TIE:
- case LINK_VTI:
-+ case LINK_VTL:
- *method |= IOM_API | IOM_OK;
- break;
-
-@@ -212,7 +211,10 @@
- ret = bsd_map_io((TicableMethod)method, port);
- if(ret)
- return ret;
--
-+
-+ // set fields to default values
-+ nul_register_cable(lc);
-+
- // set the link cable
- printl1(0, _("registering cable...\n"));
- switch (type) {
-@@ -242,16 +244,6 @@
- ser_register_cable_1(lc);
- else if(method & IOM_IOCTL)
- ser_register_cable_2(lc);
-- break;
--
-- case LINK_AVR:
-- if ((port != SERIAL_PORT_1) &&
-- (port != SERIAL_PORT_2) &&
-- (port != SERIAL_PORT_3) &&
-- (port != SERIAL_PORT_4) && (port != USER_PORT))
-- return ERR_INVALID_PORT;
--
-- avr_register_cable(lc);
- break;
-
- case LINK_VTL:
diff --git a/comms/libticables/files/patch-src-linux-slv_link2.c b/comms/libticables/files/patch-src-linux-slv_link2.c
deleted file mode 100644
index 0fb5f99a1b49..000000000000
--- a/comms/libticables/files/patch-src-linux-slv_link2.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/linux/slv_link2.c.orig Sun Sep 26 13:11:20 2004
-+++ src/linux/slv_link2.c Mon May 30 15:27:12 2005
-@@ -111,7 +111,7 @@
- {}
- };
-
--//static int max_ps = 32; // max packet size (32 ot 64)
-+static int max_ps = 32; // max packet size (32 ot 64)
-
- static int nBytesWrite2 = 0;
- static uint8_t *wBuf2 = NULL;