aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2008-04-17 18:24:03 +0000
committerAnders Nordby <anders@FreeBSD.org>2008-04-17 18:24:03 +0000
commit280850236cc404736d01d20c642cca8eb5469985 (patch)
treea7e79fc2eb95a57db80f160a1b288272daad34fe /comms
parent341170d4c98a1fddda838426af78bf66b4ce0ccd (diff)
downloadports-280850236cc404736d01d20c642cca8eb5469985.tar.gz
ports-280850236cc404736d01d20c642cca8eb5469985.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/minicom/Makefile5
-rw-r--r--comms/minicom/distinfo6
-rw-r--r--comms/minicom/files/patch-ac14
-rw-r--r--comms/minicom/files/patch-af64
-rw-r--r--comms/minicom/files/patch-ag26
-rw-r--r--comms/minicom/files/patch-configure11
-rw-r--r--comms/minicom/files/patch-lib-Makefile.in20
-rw-r--r--comms/minicom/files/patch-minirc.dfl8
-rw-r--r--comms/minicom/files/patch-src-Makefile.in14
-rw-r--r--comms/minicom/files/patch-src-minicom.h10
-rw-r--r--comms/minicom/files/patch-sysdep1.c26
-rw-r--r--comms/minicom/pkg-plist9
12 files changed, 76 insertions, 137 deletions
diff --git a/comms/minicom/Makefile b/comms/minicom/Makefile
index 166faad28013..2d463501bf28 100644
--- a/comms/minicom/Makefile
+++ b/comms/minicom/Makefile
@@ -7,9 +7,10 @@
#
PORTNAME= minicom
-PORTVERSION= 2.1
+PORTVERSION= 2.3
CATEGORIES= comms
-MASTER_SITES= ftp://ftp.nuug.no/pub/anders/distfiles/ \
+MASTER_SITES= http://alioth.debian.org/frs/download.php/2332/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/ \
http://atreides.freenix.no/~anders/
MAINTAINER= anders@FreeBSD.org
diff --git a/comms/minicom/distinfo b/comms/minicom/distinfo
index e40f9eea9539..639bc3c1be70 100644
--- a/comms/minicom/distinfo
+++ b/comms/minicom/distinfo
@@ -1,3 +1,3 @@
-MD5 (minicom-2.1.tar.gz) = 1c8f3b247c38fb16c3c2170df9fc102a
-SHA256 (minicom-2.1.tar.gz) = 7f04535b3839fbbb0affa780108c32c330b924caf4e41dacd57dd23aa1fec392
-SIZE (minicom-2.1.tar.gz) = 607939
+MD5 (minicom-2.3.tar.gz) = 0ebe7a91898384ca906787cc4e2c3f25
+SHA256 (minicom-2.3.tar.gz) = 2acbc3d4a07e1134ee285a72fa44bbc27703b02dba02be68db9e6fd8320356fb
+SIZE (minicom-2.3.tar.gz) = 789162
diff --git a/comms/minicom/files/patch-ac b/comms/minicom/files/patch-ac
index 880e95199761..56431e4f56e6 100644
--- a/comms/minicom/files/patch-ac
+++ b/comms/minicom/files/patch-ac
@@ -1,11 +1,11 @@
---- src/updown.c.orig Sun Jan 27 18:45:22 2002
-+++ src/updown.c Sun Jan 27 18:45:58 2002
-@@ -245,7 +245,7 @@
+--- src/updown.c.orig 2008-04-17 19:52:52.000000000 +0200
++++ src/updown.c 2008-04-17 19:53:27.000000000 +0200
+@@ -244,7 +244,7 @@
do_log("%s", cmdline); /* jl 22.06.97 */
if (P_PFULL(g) == 'N') {
-- win = wopen(10, 7, 70, 13, BSINGLE, stdattr, mfcolor, mbcolor, 1, 0, 1);
-+ win = wopen(5, 5, 74, 11, BSINGLE, stdattr, mfcolor, mbcolor, 1, 0, 1);
+- win = mc_wopen(10, 7, 70, 13, BSINGLE, stdattr, mfcolor, mbcolor, 1, 0, 1);
++ win = mc_wopen(5, 5, 74, 11, BSINGLE, stdattr, mfcolor, mbcolor, 1, 0, 1);
snprintf(title, sizeof(title), _("%.30s %s - Press CTRL-C to quit"), P_PNAME(g),
- what == 'U' ? _("upload") : _("download"));
- wtitle(win, TMID, title);
+ what == 'U' ? _("upload") : _("download"));
+ mc_wtitle(win, TMID, title);
diff --git a/comms/minicom/files/patch-af b/comms/minicom/files/patch-af
index 785aa386f70a..c721ec7c927d 100644
--- a/comms/minicom/files/patch-af
+++ b/comms/minicom/files/patch-af
@@ -1,35 +1,25 @@
---- src/window.c.orig 2003-05-17 04:06:26.000000000 +0800
-+++ src/window.c 2007-06-22 11:33:39.000000000 +0800
-@@ -62,7 +62,7 @@
- static char *CS, *SF, *SR, *VB, *BL;
- static char *VE, *VI, *KS, *KE;
- static char *CD, *CL, *IC, *DC;
--static char *BC, *CR, *NL;
-+static char *mcBC, *CR, *NL;
- #if ST_LINE
- static char *TS, *FS, *DS;
+--- src/window.c.orig 2008-02-06 22:49:55.000000000 +0100
++++ src/window.c 2008-04-17 20:08:10.000000000 +0200
+@@ -70,6 +70,7 @@
+ static const char *CS, *SF, *SR, *VB, *BL;
+ static const char *VE, *VI, *KS, *KE;
+ static const char *CD, *CL, *IC, *DC;
++static char *mcBC;
+ static const char *CR, *NL;
+ #ifdef ST_LINE
+ static const char *TS, *FS, *DS;
+@@ -342,8 +343,8 @@
+ else if (NL != NULL && x == 0 && x == curx && y == cury + 1)
+ outstr(NL);
#endif
-@@ -110,7 +110,7 @@
-
- int useattr = 1;
- int dirflush = 1;
--extern int LINES, COLS;
-+int LINES, COLS;
- int usecolor = 0;
- WIN *stdwin;
- char *_tptr = CNULL;
-@@ -322,8 +322,8 @@
- else if (NL != CNULL && x == 0 && x == curx && y == cury + 1)
- outstr(NL);
- #endif
-- else if (BC != CNULL && y == cury && x == curx - 1)
-- outstr(BC);
-+ else if (mcBC != CNULL && y == cury && x == curx - 1)
-+ outstr(mcBC);
- else
- outstr(tgoto(CM, x, y));
+- else if (BC != NULL && y == cury && x == curx - 1)
+- outstr(BC);
++ else if (mcBC != NULL && y == cury && x == curx - 1)
++ outstr(mcBC);
+ else
+ outstr(tgoto(CM, x, y));
curx = x;
-@@ -1918,7 +1918,7 @@
+@@ -2007,7 +2008,7 @@
CL = tgetstr("cl", &_tptr);
IC = tgetstr("ic", &_tptr);
DC = tgetstr("dc", &_tptr);
@@ -38,16 +28,18 @@
CR = tgetstr("cr", &_tptr);
NL = tgetstr("nl", &_tptr);
AC = tgetstr("ac", &_tptr);
-@@ -1967,10 +1967,10 @@
+@@ -2066,11 +2067,11 @@
_has_am = tgetflag("am");
_mv_standout = tgetflag("ms");
if (tgetflag("bs")) {
-- if (BC == CNULL) BC = "\b";
-+ if (mcBC == CNULL) mcBC = "\b";
- }
+- if (BC == NULL)
+- BC = "\b";
++ if (mcBC == NULL)
++ mcBC = "\b";
+ }
else
-- BC = CNULL;
-+ mcBC = CNULL;
+- BC = NULL;
++ mcBC = NULL;
/* Special IBM box-drawing characters */
D_UL = 201;
diff --git a/comms/minicom/files/patch-ag b/comms/minicom/files/patch-ag
deleted file mode 100644
index 9e099c5aca75..000000000000
--- a/comms/minicom/files/patch-ag
+++ /dev/null
@@ -1,26 +0,0 @@
---- src/windiv.c.orig Mon Jan 31 21:12:08 2000
-+++ src/windiv.c Sun Jan 27 19:05:05 2002
-@@ -19,6 +19,7 @@
- #include "rcsid.h"
- RCSID("$Id: windiv.c,v 1.2 2000/01/27 11:25:31 misiek Exp $")
-
-+#include <sys/types.h>
- #include <dirent.h>
- #include <sys/stat.h>
- #include "port.h"
-@@ -251,8 +252,14 @@
-
- /* get regular files */
- dirlist[nCnt].d_ino = dirent->d_ino;
-- dirlist[nCnt].d_off = dirent->d_off;
- dirlist[nCnt].d_reclen = dirent->d_reclen;
-+#if (defined(BSD) && (BSD >= 199306))
-+ dirlist[nCnt].d_type = dirent->d_type;
-+ dirlist[nCnt].d_namlen = dirent->d_namlen;
-+#else
-+ dirlist[nCnt].d_off = dirent->d_off;
-+#endif
-+
- strcpy(dirlist[nCnt].d_name, dirent->d_name );
- nMaxWidth = max(nMaxWidth, strlen(dirent->d_name));
- nCnt++;
diff --git a/comms/minicom/files/patch-configure b/comms/minicom/files/patch-configure
deleted file mode 100644
index 449071237c31..000000000000
--- a/comms/minicom/files/patch-configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.orig Mon Oct 1 14:21:54 2001
-+++ configure Mon May 20 14:24:41 2002
-@@ -4893,7 +4893,7 @@
- fi
-
-
--for ac_func in snprintf usleep getopt getopt_long
-+for ac_func in snprintf usleep
- do
- echo $ac_n "checking for $ac_func""... $ac_c" 1>&6
- echo "configure:4900: checking for $ac_func" >&5
diff --git a/comms/minicom/files/patch-lib-Makefile.in b/comms/minicom/files/patch-lib-Makefile.in
deleted file mode 100644
index 505463fdc78a..000000000000
--- a/comms/minicom/files/patch-lib-Makefile.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/Makefile.in.orig Wed Jul 23 04:04:52 2003
-+++ lib/Makefile.in Wed Jul 23 04:05:33 2003
-@@ -76,7 +76,7 @@
- INTL_LIBTOOL_SUFFIX_PREFIX = @INTL_LIBTOOL_SUFFIX_PREFIX@
- KEYSERV = @KEYSERV@
- LIBICONV = @LIBICONV@
--LIBOBJS = @LIBOBJS@
-+LIBOBJS = @LIBOBJS@ getopt.o getopt_long.o
- LIBPORT_GETOPT_LONG_DEP = @LIBPORT_GETOPT_LONG_DEP@
- MAKEINFO = @MAKEINFO@
- MKINSTALLDIRS = @MKINSTALLDIRS@
-@@ -109,7 +109,7 @@
- CPPFLAGS = @CPPFLAGS@
- LDFLAGS = @LDFLAGS@
- LIBS = @LIBS@
--libport_a_DEPENDENCIES = @LIBOBJS@
-+libport_a_DEPENDENCIES = @LIBOBJS@ getopt.o getopt_long.o
- libport_a_OBJECTS =
- AR = ar
- CFLAGS = @CFLAGS@
diff --git a/comms/minicom/files/patch-minirc.dfl b/comms/minicom/files/patch-minirc.dfl
index e13f5c406afb..1e588d621a42 100644
--- a/comms/minicom/files/patch-minirc.dfl
+++ b/comms/minicom/files/patch-minirc.dfl
@@ -1,9 +1,9 @@
---- doc/minirc.dfl.orig Sun Jan 27 23:21:45 2002
-+++ doc/minirc.dfl Sun Jan 27 23:21:49 2002
+--- doc/minirc.dfl.orig 2003-03-30 20:55:39.000000000 +0200
++++ doc/minirc.dfl 2008-04-17 20:17:35.000000000 +0200
@@ -1,2 +1,7 @@
- # $Id: minirc.dfl,v 1.1.1.1 1999/12/18 11:18:51 misiek Exp $
+ # $Id: minirc.dfl,v 1.1.1.1 2003/03/30 18:55:39 al-guest Exp $
# Machine-generated file - use "minicom -s" to change parameters.
-+pr port /dev/cuaa0
++pr port /dev/cuad0
+pu baudrate 9600
+pu bits 8
+pu parity N
diff --git a/comms/minicom/files/patch-src-Makefile.in b/comms/minicom/files/patch-src-Makefile.in
deleted file mode 100644
index 84e7e4d84e1e..000000000000
--- a/comms/minicom/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/Makefile.in.orig Sun May 18 11:46:03 2003
-+++ src/Makefile.in Wed Jul 23 04:12:27 2003
-@@ -119,9 +119,9 @@
-
- CPPFLAGS = @CPPFLAGS@ -I$(top_srcdir)/lib
-
--minicom_LDADD = @INTLLIBS@ $(MINICOM_LIBPORT)
-+minicom_LDADD = @INTLLIBS@ $(MINICOM_LIBPORT) ../lib/getopt.o ../lib/getopt_long.o
-
--runscript_LDADD = @INTLLIBS@
-+runscript_LDADD = @INTLLIBS@ ../lib/getopt.o ../lib/getopt_long.o
-
- EXTRA_DIST = functions.c xminicom
- mkinstalldirs = $(SHELL) $(top_srcdir)/aux/mkinstalldirs
diff --git a/comms/minicom/files/patch-src-minicom.h b/comms/minicom/files/patch-src-minicom.h
new file mode 100644
index 000000000000..74c4b7c2a0cf
--- /dev/null
+++ b/comms/minicom/files/patch-src-minicom.h
@@ -0,0 +1,10 @@
+--- src/minicom.h.orig 2008-04-17 20:06:14.000000000 +0200
++++ src/minicom.h 2008-04-17 20:06:22.000000000 +0200
+@@ -34,6 +34,7 @@
+ #include "libport.h"
+
+ #include <time.h>
++#include <limits.h>
+
+ #ifdef USE_SOCKET
+ #include <sys/socket.h>
diff --git a/comms/minicom/files/patch-sysdep1.c b/comms/minicom/files/patch-sysdep1.c
index 35c08dc5bdad..467e1858167a 100644
--- a/comms/minicom/files/patch-sysdep1.c
+++ b/comms/minicom/files/patch-sysdep1.c
@@ -1,6 +1,6 @@
---- src/sysdep1.c.orig Wed Jul 23 04:06:53 2003
-+++ src/sysdep1.c Wed Jul 23 04:10:29 2003
-@@ -82,13 +82,13 @@
+--- src/sysdep1.c.orig 2007-10-10 22:18:20.000000000 +0200
++++ src/sysdep1.c 2008-04-17 19:48:58.000000000 +0200
+@@ -84,13 +84,13 @@
if (portfd_is_socket)
return;
#endif
@@ -17,21 +17,21 @@
}
#endif
#ifdef _COHERENT
-@@ -215,11 +215,11 @@
+@@ -213,11 +213,11 @@
return portfd_is_connected;
}
#endif
-#ifdef TIOCMODG
-+#ifdef TIOCMGET
++#ifdef TIOCMODGET
{
- int mcs=0;
-
-- ioctl(fd, TIOCMODG, &mcs);
-+ ioctl(fd, TIOCMGET, &mcs);
- return(mcs & TIOCM_CAR ? 1 : 0);
+ int mcs = 0;
+
+- if (ioctl(fd, TIOCMODG, &mcs) < 0)
++ if (ioctl(fd, TIOCMODGET, &mcs) < 0)
+ return -1;
+ return mcs & TIOCM_CAR ? 1 : 0;
}
- #else
-@@ -262,8 +262,8 @@
+@@ -260,8 +260,8 @@
ioctl(fd, TIOCLGET, &lsw);
# endif
#endif
@@ -42,7 +42,7 @@
#endif
}
-@@ -288,8 +288,8 @@
+@@ -285,8 +285,8 @@
ioctl(fd, TIOCLSET, &lsw);
# endif
#endif
diff --git a/comms/minicom/pkg-plist b/comms/minicom/pkg-plist
index 066b4c81d9e6..8559647a5663 100644
--- a/comms/minicom/pkg-plist
+++ b/comms/minicom/pkg-plist
@@ -4,14 +4,22 @@ bin/runscript
bin/ascii-xfr
etc/minicom/minicom.users
%%NLS%%share/locale/cs/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/da/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/de/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/es/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/fi/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/fr/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/hu/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/ja/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/pl/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/minicom.mo
%%NLS%%share/locale/ru/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/rw/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/minicom.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/minicom.mo
@exec /usr/sbin/chown uucp %D/etc/minicom
@dirrmtry etc/minicom
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
@@ -28,7 +36,6 @@ etc/minicom/minicom.users
%%PORTDOCS%%%%DOCSDIR%%/doc/Macros
%%PORTDOCS%%%%DOCSDIR%%/doc/QuickStart.modemu
%%PORTDOCS%%%%DOCSDIR%%/doc/README.lrzsz
-%%PORTDOCS%%%%DOCSDIR%%/doc/RedHat
%%PORTDOCS%%%%DOCSDIR%%/doc/TODO.lrzsz
%%PORTDOCS%%%%DOCSDIR%%/doc/Todo
%%PORTDOCS%%%%DOCSDIR%%/doc/Todo.175