aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-09 17:16:12 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-04-09 17:16:12 +0000
commit0923d36607fdffe112cfc4900db19d9383a194a7 (patch)
treeb86d94eab822f6e686a542c89a3c4f5645f40356 /comms
parente553f4f6d8c5dbb54669a9c32dfb96b6ee0c42c4 (diff)
downloadports-0923d36607fdffe112cfc4900db19d9383a194a7.tar.gz
ports-0923d36607fdffe112cfc4900db19d9383a194a7.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/gnokii/Makefile19
-rw-r--r--comms/gnokii/distinfo6
-rw-r--r--comms/gnokii/pkg-plist66
3 files changed, 15 insertions, 76 deletions
diff --git a/comms/gnokii/Makefile b/comms/gnokii/Makefile
index 28c7f68f1663..85c0791a50be 100644
--- a/comms/gnokii/Makefile
+++ b/comms/gnokii/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnokii
-PORTVERSION= 0.6.10
-PORTREVISION= 1
+PORTVERSION= 0.6.12
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= http://www.gnokii.org/download/gnokii/ \
@@ -17,7 +16,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= mad@madpilot.net
COMMENT= Tools to talk to GSM cellular phones
-USE_REINPLACE= yes
USE_GMAKE= yes
USE_BZIP2= yes
INSTALLS_SHLIB= yes
@@ -29,8 +27,9 @@ CONFIGURE_ENV+= MSGFMT="${LOCALBASE}/bin/msgfmt" \
CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include -fPIC" \
LIBS="-L../common -L${LOCALBASE}/lib"
-MAN1= gnokii.1 todologo.1 ppm2nokia.1 sendsms.1
-MAN8= gnokiid.8 mgnokiidev.8
+MAN1= gnokii.1 todologo.1 ppm2nokia.1 sendsms.1
+MAN8= gnokiid.8 mgnokiidev.8
+PORTDOCS= *
INSTALL_TARGET= install-suid
PKGDEINSTALL= ${PKGINSTALL}
@@ -43,6 +42,10 @@ WANT_GNOME= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on FreeBSD 4.x
+.endif
+
.if exists(${LOCALBASE}/lib/libical.so.0)
WITH_ICAL= yes
.endif
@@ -134,10 +137,7 @@ post-patch:
@${REINPLACE_CMD} -E -e "s:^(#ifdef.*)__OpenBSD__:\1__FreeBSD__:" \
${WRKSRC}/${f}
.endfor
-.if ${OSVERSION} <= 500027
- @${FIND} ${WRKSRC} -type f -name "*.[ch]" | ${XARGS} ${REINPLACE_CMD} \
- -e 's|<stdint.h>|<inttypes.h>|'
-.endif
+ @${REINPLACE_CMD} -e '/pkgconfig/d' ${WRKSRC}/xgnokii/Makefile
.if defined(SMSD_WITH_GLIB1)
@cd ${WRKSRC} && ${PATCH} -s <${PATCHDIR}/smsd-Makefile-WITH_GLIB.diff
.endif
@@ -158,6 +158,7 @@ pre-install:
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
+ ${INSTALL_DATA} ${WRKSRC}/xgnokii/xgnokii.pc ${PREFIX}/libdata/pkgconfig
@${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.if !defined(NOPORTDOCS)
@(cd ${WRKSRC} && ${GMAKE} install-docs)
diff --git a/comms/gnokii/distinfo b/comms/gnokii/distinfo
index e1da186ffbff..6ce6f999c4eb 100644
--- a/comms/gnokii/distinfo
+++ b/comms/gnokii/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnokii-0.6.10.tar.bz2) = 031007358ff9b6e6e2994d408a4fa88a
-SHA256 (gnokii-0.6.10.tar.bz2) = 92659c8b02a50f7a2d40a608b81514176a13216d4a40d35689df9a49f58444f0
-SIZE (gnokii-0.6.10.tar.bz2) = 1916536
+MD5 (gnokii-0.6.12.tar.bz2) = 846e03e7cf3581000c9d0141c2950b79
+SHA256 (gnokii-0.6.12.tar.bz2) = 7ec179f8d933c1005af2b4996198fffc10b528f4604b796c471d6413cc825b58
+SIZE (gnokii-0.6.12.tar.bz2) = 1517318
diff --git a/comms/gnokii/pkg-plist b/comms/gnokii/pkg-plist
index d4123eb7a399..58f9716d3716 100644
--- a/comms/gnokii/pkg-plist
+++ b/comms/gnokii/pkg-plist
@@ -23,61 +23,10 @@ lib/libgnokii.la
lib/libgnokii.so
lib/libgnokii.so.2
libdata/pkgconfig/gnokii.pc
+libdata/pkgconfig/xgnokii.pc
sbin/gnokiid
sbin/mgnokiidev
%%SMSD%%sbin/smsd
-%%PORTDOCS%%%%DOCSDIR%%/Bugs
-%%PORTDOCS%%%%DOCSDIR%%/CREDITS
-%%PORTDOCS%%%%DOCSDIR%%/DataCalls-QuickStart
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README-2110
-%%PORTDOCS%%%%DOCSDIR%%/README-3810
-%%PORTDOCS%%%%DOCSDIR%%/README-6110
-%%PORTDOCS%%%%DOCSDIR%%/README-6510
-%%PORTDOCS%%%%DOCSDIR%%/README-7110
-%%PORTDOCS%%%%DOCSDIR%%/README-MacOSX
-%%PORTDOCS%%%%DOCSDIR%%/README-Symbian
-%%PORTDOCS%%%%DOCSDIR%%/README-WIN32
-%%PORTDOCS%%%%DOCSDIR%%/README-dancall
-%%PORTDOCS%%%%DOCSDIR%%/README-ericsson
-%%PORTDOCS%%%%DOCSDIR%%/README-siemens
-%%PORTDOCS%%%%DOCSDIR%%/README.libsms
-%%PORTDOCS%%%%DOCSDIR%%/gettext-howto
-%%PORTDOCS%%%%DOCSDIR%%/gnapplet.sis
-%%PORTDOCS%%%%DOCSDIR%%/gnokii-IrDA-Linux
-%%PORTDOCS%%%%DOCSDIR%%/gnokii-hackers-howto
-%%PORTDOCS%%%%DOCSDIR%%/gnokii-ir-howto
-%%PORTDOCS%%%%DOCSDIR%%/gnokii.nol
-%%PORTDOCS%%%%DOCSDIR%%/logos.txt
-%%PORTDOCS%%%%DOCSDIR%%/packaging-howto
-%%PORTDOCS%%%%DOCSDIR%%/ringtones.txt
-%%PORTDOCS%%%%DOCSDIR%%/sample/gnokiirc
-%%PORTDOCS%%%%DOCSDIR%%/sample/logo/bronto.xpm
-%%PORTDOCS%%%%DOCSDIR%%/sample/logo/gnokii.xpm
-%%PORTDOCS%%%%DOCSDIR%%/sample/logo/gnokiiop.xpm
-%%PORTDOCS%%%%DOCSDIR%%/sample/logo/horse.xpm
-%%PORTDOCS%%%%DOCSDIR%%/sample/logo/horse2.xpm
-%%PORTDOCS%%%%DOCSDIR%%/sample/logo/pacman.xpm
-%%PORTDOCS%%%%DOCSDIR%%/sample/magic
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/cimd-connect
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/options
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/pap-secrets
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/ppp-6210-modem
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/ppp-FILES
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/ppp-gnokii
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/ppp-hscsd
-%%PORTDOCS%%%%DOCSDIR%%/sample/ppp/ppp-on
-%%PORTDOCS%%%%DOCSDIR%%/sample/ringtone/star.imelody
-%%PORTDOCS%%%%DOCSDIR%%/sample/ringtone/star.rtttl
-%%PORTDOCS%%%%DOCSDIR%%/sample/vCalendar/test.vcs
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/logo
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/ringtone
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/vCalendar
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/vCard
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample/ppp
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@exec mkdir -m 755 %D/%%DOCSDIR%%/sample/vCard
%%NLS%%share/locale/cs/LC_MESSAGES/gnokii.mo
%%NLS%%share/locale/de/LC_MESSAGES/gnokii.mo
%%NLS%%share/locale/et/LC_MESSAGES/gnokii.mo
@@ -88,6 +37,7 @@ sbin/mgnokiidev
%%NLS%%share/locale/pl/LC_MESSAGES/gnokii.mo
%%NLS%%share/locale/sk/LC_MESSAGES/gnokii.mo
%%NLS%%share/locale/sl/LC_MESSAGES/gnokii.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnokii.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnokii.mo
%%SMSD%%share/smsd/README
%%SMSD%%share/smsd/action
@@ -169,17 +119,6 @@ sbin/mgnokiidev
%%X11%%share/xgnokii/help/pl_PL/sms.html
%%X11%%share/xgnokii/help/pl_PL/speeddial.html
%%X11%%share/xgnokii/help/pl_PL/xkeyb.html
-%%X11%%share/xgnokii/xpm/5110.xpm
-%%X11%%share/xgnokii/xpm/6110.xpm
-%%X11%%share/xgnokii/xpm/6150.xpm
-%%X11%%share/xgnokii/xpm/Preview_3210.xpm
-%%X11%%share/xgnokii/xpm/Preview_3310.xpm
-%%X11%%share/xgnokii/xpm/Preview_5110.xpm
-%%X11%%share/xgnokii/xpm/Preview_6110.xpm
-%%X11%%share/xgnokii/xpm/Preview_6150.xpm
-%%X11%%share/xgnokii/xpm/Preview_6210.xpm
-%%X11%%share/xgnokii/xpm/Preview_6250.xpm
-%%X11%%share/xgnokii/xpm/Preview_7110.xpm
%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/calendar
%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/contacts
%%X11%%@exec mkdir -p %D/share/xgnokii/help/en_US/dtmf
@@ -218,5 +157,4 @@ sbin/mgnokiidev
%%X11%%@dirrm share/xgnokii/help/pl_PL/netmon
%%X11%%@dirrm share/xgnokii/help/pl_PL
%%X11%%@dirrm share/xgnokii/help
-%%X11%%@dirrm share/xgnokii/xpm
%%X11%%@dirrm share/xgnokii