aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2006-05-09 16:52:58 +0000
committerAnders Nordby <anders@FreeBSD.org>2006-05-09 16:52:58 +0000
commit4e0abd25b8d3f5c0764949a0120172df5175b466 (patch)
treedecd2cfa488dea7de518706af98e3f54aef4be3a /comms
parent1b1af0e5f58c6fe6437da58a9c22d7b98b3168f9 (diff)
downloadports-4e0abd25b8d3f5c0764949a0120172df5175b466.tar.gz
ports-4e0abd25b8d3f5c0764949a0120172df5175b466.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/p5-Device-Gsm/Makefile24
-rw-r--r--comms/p5-Device-Gsm/distinfo3
-rw-r--r--comms/p5-Device-Gsm/pkg-descr6
-rw-r--r--comms/p5-Device-Gsm/pkg-plist22
5 files changed, 56 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 3f5eda6e6b62..662b23c1f3e5 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -65,6 +65,7 @@
SUBDIR += nokryptia
SUBDIR += obexapp
SUBDIR += openobex
+ SUBDIR += p5-Device-Gsm
SUBDIR += p5-Device-Modem
SUBDIR += p5-Device-SerialPort
SUBDIR += p5-Fax-Hylafax-Client
diff --git a/comms/p5-Device-Gsm/Makefile b/comms/p5-Device-Gsm/Makefile
new file mode 100644
index 000000000000..2cbbbc7f2836
--- /dev/null
+++ b/comms/p5-Device-Gsm/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Device-Gsm
+# Date created: 09 May 2006
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Device-Gsm
+PORTVERSION= 1.41
+CATEGORIES= comms perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Device
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= anders@FreeBSD.org
+COMMENT= Perl interface to GSM phones/modems on serial ports
+
+BUILD_DEPENDS= ${SITE_PERL}/Device/Modem.pm:${PORTSDIR}/comms/p5-Device-Modem
+
+PERL_CONFIGURE= yes
+
+MAN3= Device::Gsm::Sms.3 Device::Gsm::Pdu.3 Device::Gsm.3
+
+.include <bsd.port.mk>
diff --git a/comms/p5-Device-Gsm/distinfo b/comms/p5-Device-Gsm/distinfo
new file mode 100644
index 000000000000..9e9d3a8672b4
--- /dev/null
+++ b/comms/p5-Device-Gsm/distinfo
@@ -0,0 +1,3 @@
+MD5 (Device-Gsm-1.41.tar.gz) = 4ca7121a6f57a0f5fda82cbf22c6e574
+SHA256 (Device-Gsm-1.41.tar.gz) = 83865596d802a874d6e7c0363e3b01ab9556151c3e57279025e466f80cbbe546
+SIZE (Device-Gsm-1.41.tar.gz) = 48705
diff --git a/comms/p5-Device-Gsm/pkg-descr b/comms/p5-Device-Gsm/pkg-descr
new file mode 100644
index 000000000000..327e46702122
--- /dev/null
+++ b/comms/p5-Device-Gsm/pkg-descr
@@ -0,0 +1,6 @@
+This module works as an interface to GSM phones or GSM modems connected on your
+local serial ports. It can control your GSM *standard* functions and status. It
+can send SMS messages in a simple and convenient way. It can read messages
+stored on your sim card.
+
+WWW: http://search.cpan.org/dist/Device-Gsm/
diff --git a/comms/p5-Device-Gsm/pkg-plist b/comms/p5-Device-Gsm/pkg-plist
new file mode 100644
index 000000000000..9fd8dabcca1e
--- /dev/null
+++ b/comms/p5-Device-Gsm/pkg-plist
@@ -0,0 +1,22 @@
+%%SITE_PERL%%/Device/Gsm/Sms/Token/VP.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/UD.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/SCTS.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/SCA.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/PID.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/PDUTYPE.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/OA.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/MR.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/DCS.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token/DA.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Token.pm
+%%SITE_PERL%%/Device/Gsm/Sms/Structure.pm
+%%SITE_PERL%%/Device/Gsm/Sms.pm
+%%SITE_PERL%%/Device/Gsm/Pdu.pm
+%%SITE_PERL%%/Device/Gsm/Charset.pm
+%%SITE_PERL%%/Device/Gsm.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Gsm/.packlist
+@dirrm %%SITE_PERL%%/Device/Gsm/Sms/Token
+@dirrm %%SITE_PERL%%/Device/Gsm/Sms
+@dirrm %%SITE_PERL%%/Device/Gsm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Device/Gsm
+@dirrmtry %%SITE_PERL%%/Device