aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-08-27 04:57:39 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-08-27 04:57:39 +0000
commit6f46789133cab5c264641ba287f10d4369f814c8 (patch)
tree419112c352771bf79dc75142d38b30a90235ed29 /comms
parent0989b39cd7cdbead361551b9e08d797df0643a90 (diff)
downloadports-6f46789133cab5c264641ba287f10d4369f814c8.tar.gz
ports-6f46789133cab5c264641ba287f10d4369f814c8.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/tkscanfax/Makefile31
-rw-r--r--comms/tkscanfax/distinfo6
-rw-r--r--comms/tkscanfax/files/patch-src:fax-init.tcl10
-rw-r--r--comms/tkscanfax/files/patch-src:wish20
-rw-r--r--comms/tkscanfax/pkg-descr2
-rw-r--r--comms/tkscanfax/pkg-plist212
6 files changed, 129 insertions, 152 deletions
diff --git a/comms/tkscanfax/Makefile b/comms/tkscanfax/Makefile
index 5c530cbfc4c5..a3b1fb2db544 100644
--- a/comms/tkscanfax/Makefile
+++ b/comms/tkscanfax/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tkscanfax
-PORTVERSION= 1.1.4
-PORTREVISION= 1
+PORTVERSION= 1.1.8
PORTEPOCH= 1
CATEGORIES= comms tk
MASTER_SITES= http://shino.pos.to/linux/tkscanfax/
@@ -15,20 +14,26 @@ MASTER_SITES= http://shino.pos.to/linux/tkscanfax/
MAINTAINER= ports@FreeBSD.org
COMMENT= Tcl/Tk frontend for fax scan/receive/send program (command is tkfax)
-USE_TK= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}1
+WRKSRC= ${WRKDIR}/${PORTNAME}1
+
NO_BUILD= yes
+USE_TK_WRAPPER= yes
+
+PLIST_SUB= TKSCANFAXDIR="${TKSCANFAXDIR:S,^${PREFIX}/,,}"
+
+TKSCANFAXDIR= ${PREFIX}/lib/tkscanfax1
-post-extract:
- ${FIND} ${WRKSRC} -name '*~' -delete
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -i '' -e \
+ 's|/usr/local/lib|${PREFIX}/lib|g'
do-install:
- (\
- cd ${WRKDIR}; \
- ${TAR} '--exclude=*.orig' -cf - tkscanfax1 | \
- ${TAR} -C ${PREFIX}/lib -xf - ; \
- ${LN} -sf ${PREFIX}/lib/tkscanfax1/tkscan ${PREFIX}/bin ; \
- ${LN} -sf ${PREFIX}/lib/tkscanfax1/tkfax ${PREFIX}/bin \
- )
+ @${MKDIR} ${TKSCANFAXDIR}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} . ${TKSCANFAXDIR})
+.for file in tkfax tkscan
+ ${CHMOD} ${BINMODE} ${TKSCANFAXDIR}/${file}
+ ${CHOWN} ${BINOWN}:${BINGRP} ${TKSCANFAXDIR}/${file}
+ ${LN} -sf ${TKSCANFAXDIR}/${file} ${PREFIX}/bin
+.endfor
.include <bsd.port.mk>
diff --git a/comms/tkscanfax/distinfo b/comms/tkscanfax/distinfo
index 2e8cb11c6491..b29efd9f5fa6 100644
--- a/comms/tkscanfax/distinfo
+++ b/comms/tkscanfax/distinfo
@@ -1,3 +1,3 @@
-MD5 (tkscanfax-1.1.4.tar.gz) = 689ce34520a566d22756c8e25c9cf7f7
-SHA256 (tkscanfax-1.1.4.tar.gz) = 094baa574309416b065427cf22d9d0fb10d3fef82fde647f454d65319cfcbebc
-SIZE (tkscanfax-1.1.4.tar.gz) = 224163
+MD5 (tkscanfax-1.1.8.tar.gz) = 250153f7a61f00b74c918a0214a0e3cb
+SHA256 (tkscanfax-1.1.8.tar.gz) = 92b9038bad5d26e05b33f402231d925b96945197329dc4362a25b61ef835078b
+SIZE (tkscanfax-1.1.8.tar.gz) = 216952
diff --git a/comms/tkscanfax/files/patch-src:fax-init.tcl b/comms/tkscanfax/files/patch-src:fax-init.tcl
deleted file mode 100644
index 6250bb7ba3f6..000000000000
--- a/comms/tkscanfax/files/patch-src:fax-init.tcl
+++ /dev/null
@@ -1,10 +0,0 @@
---- fax-init.tcl.orig Wed Nov 17 20:07:15 2004
-+++ fax-init.tcl Wed Nov 17 20:07:34 2004
-@@ -409,6 +409,7 @@
- set fid [open $lockfile r]
- gets $fid pid
- close $fid
-+ set notrun 1
- catch {set notrun [exec sh -c "ps -p $pid > /dev/null; echo $?"]}
- if {! $notrun} {
- if [tk_dialog .dialog "TkFax lock file found" \
diff --git a/comms/tkscanfax/files/patch-src:wish b/comms/tkscanfax/files/patch-src:wish
deleted file mode 100644
index 3222c667ef51..000000000000
--- a/comms/tkscanfax/files/patch-src:wish
+++ /dev/null
@@ -1,20 +0,0 @@
--- tkfax.orig Sun Nov 14 20:59:03 2004
-+++ tkfax Sun Nov 14 20:59:40 2004
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # the next line restarts using wish \
--exec wish "$0" "$@"
-+exec wish8.4 "$0" "$@"
-
- set fax(libdir) /usr/local/lib/tkscanfax1
- if [ file exist fax-init.tcl ] { set fax(libdir) [pwd] }
---- tkscan.orig Sun Nov 14 20:59:24 2004
-+++ tkscan Sun Nov 14 20:59:33 2004
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # the next line restarts using wish \
--exec wish "$0" "$@"
-+exec wish8.4 "$0" "$@"
-
- # Set TkScan installation directory.
-
diff --git a/comms/tkscanfax/pkg-descr b/comms/tkscanfax/pkg-descr
index 8077814766cb..aac04041a25f 100644
--- a/comms/tkscanfax/pkg-descr
+++ b/comms/tkscanfax/pkg-descr
@@ -1 +1,3 @@
Tcl/Tk frontend for fax scan/receive/send program. Command is tkfax.
+
+WWW: http://shino.pos.to/linux/tkscanfax_e.html
diff --git a/comms/tkscanfax/pkg-plist b/comms/tkscanfax/pkg-plist
index c2e86f1ba28f..b37b0fe27608 100644
--- a/comms/tkscanfax/pkg-plist
+++ b/comms/tkscanfax/pkg-plist
@@ -1,107 +1,107 @@
-lib/tkscanfax1/fax-about.tcl
-lib/tkscanfax1/images/hbkim.gif
-lib/tkscanfax1/images/tkfax-s.gif
-lib/tkscanfax1/fax-balloon.tcl
-lib/tkscanfax1/fax-conf-win.tcl
-lib/tkscanfax1/fax-conf.tcl
-lib/tkscanfax1/fax-faxwin.tcl
-lib/tkscanfax1/fax-file.tcl
-lib/tkscanfax1/fax-init.tcl
-lib/tkscanfax1/fax-lib.tcl
-lib/tkscanfax1/fax-logbrowse.tcl
-lib/tkscanfax1/fax-mkpg.tcl
-lib/tkscanfax1/fax-pbook.tcl
-lib/tkscanfax1/fax-queue.tcl
-lib/tkscanfax1/fax-received.tcl
-lib/tkscanfax1/scan-drivers/microtek-mtekscan.tcl
-lib/tkscanfax1/scan-drivers/epson-ep_scan.tcl
-lib/tkscanfax1/scan-drivers/epson-scanimage.tcl
-lib/tkscanfax1/scan-drivers/epson.tcl
-lib/tkscanfax1/scan-drivers/hp-hpscanpbm.tcl
-lib/tkscanfax1/scan-drivers/mustek-scanimage.tcl
-lib/tkscanfax1/scan-drivers/mustek-mscan.tcl
-lib/tkscanfax1/scan-drivers/sharp.tcl
-lib/tkscanfax1/scan-drivers/umax.tcl
-lib/tkscanfax1/tex/covermacro-aux.tex
-lib/tkscanfax1/tex/covermacro-en.tex
-lib/tkscanfax1/tex/covermacro-ja.tex
-lib/tkscanfax1/tex/covermacro-kr.tex
-lib/tkscanfax1/tex/covermacro-C.tex
-lib/tkscanfax1/fax-scan.tcl
-lib/tkscanfax1/getfont.tcl
-lib/tkscanfax1/html_library.tcl
-lib/tkscanfax1/html_viewer.tcl
-lib/tkscanfax1/doc/efax.html
-lib/tkscanfax1/doc/efax.rc.sample
-lib/tkscanfax1/doc/efax.rc.sample.ja
-lib/tkscanfax1/doc/fax.html
-lib/tkscanfax1/doc/tkscanfax.html
-lib/tkscanfax1/doc/tkkinput2.sh
-lib/tkscanfax1/doc/INSTALL
-lib/tkscanfax1/doc/INSTALL.ja
-lib/tkscanfax1/doc/README.ja
-lib/tkscanfax1/doc/TRANSLATION
-lib/tkscanfax1/doc/fax
-lib/tkscanfax1/doc/images/gfax.png
-lib/tkscanfax1/doc/images/jamain2.png
-lib/tkscanfax1/doc/images/ref.gif
-lib/tkscanfax1/doc/images/shinobas.gif
-lib/tkscanfax1/doc/images/tkfax-b.xpm
-lib/tkscanfax1/doc/images/tkfax-s.xpm
-lib/tkscanfax1/doc/images/tkfax-s.png
-lib/tkscanfax1/doc/images/tux.gif
-lib/tkscanfax1/doc/images/tkfax-s.gif
-lib/tkscanfax1/doc/images/download.png
-lib/tkscanfax1/doc/printcap.sample
-lib/tkscanfax1/doc/tkscanfax_e.html
-lib/tkscanfax1/doc/sysreport.sh
-lib/tkscanfax1/doc/tkscanfax_ja.html
-lib/tkscanfax1/doc/C/scan-msg.tcl
-lib/tkscanfax1/doc/C/fax-msg.tcl
-lib/tkscanfax1/doc/C/Config_Help.html
-lib/tkscanfax1/doc/C/Cover_Page_Help.html
-lib/tkscanfax1/doc/C/HTML_Viewer.html
-lib/tkscanfax1/doc/C/Users_Guide.html
-lib/tkscanfax1/doc/C/Phone_Book_Help.html
-lib/tkscanfax1/doc/ja/fax-msg.tcl
-lib/tkscanfax1/doc/ja/scan-msg.tcl
-lib/tkscanfax1/doc/ja/Config_Help.html
-lib/tkscanfax1/doc/ja/Cover_Page_Help.html
-lib/tkscanfax1/doc/ja/HTML_Viewer.html
-lib/tkscanfax1/doc/ja/Users_Guide.html
-lib/tkscanfax1/doc/ja/Phone_Book_Help.html
-lib/tkscanfax1/doc/ja/FAQ.html
-lib/tkscanfax1/doc/ja/ToDo-2003-0316.html
-lib/tkscanfax1/doc/tkfax_tips_ja.html
-lib/tkscanfax1/doc/INSTALL1.1.ja
-lib/tkscanfax1/doc/tkscanfax_rpm.html
-lib/tkscanfax1/doc/INSTALL1.1
-lib/tkscanfax1/doc/zh_TW/fax-msg.tcl
-lib/tkscanfax1/scan-about.tcl
-lib/tkscanfax1/scan-conf.tcl
-lib/tkscanfax1/scan-file.tcl
-lib/tkscanfax1/scan-init.tcl
-lib/tkscanfax1/scan-lib.tcl
-lib/tkscanfax1/scan-out.tcl
-lib/tkscanfax1/scan-scan.tcl
-lib/tkscanfax1/scan-win.tcl
-lib/tkscanfax1/scan-scanwin.tcl
-lib/tkscanfax1/tkfax
-lib/tkscanfax1/tkscan
-lib/tkscanfax1/tkscanfax.spec
-lib/tkscanfax1/Makefile
-lib/tkscanfax1/tkscan.desktop
-lib/tkscanfax1/tkfax.desktop
-@exec /bin/ln -sf %D/lib/tkscanfax1/tkscan %D/bin
-@exec /bin/ln -sf %D/lib/tkscanfax1/tkfax %D/bin
-@unexec /bin/rm -f %D/bin/tkscan
+%%TKSCANFAXDIR%%/Makefile
+%%TKSCANFAXDIR%%/doc/C/Config_Help.html
+%%TKSCANFAXDIR%%/doc/C/Cover_Page_Help.html
+%%TKSCANFAXDIR%%/doc/C/HTML_Viewer.html
+%%TKSCANFAXDIR%%/doc/C/Phone_Book_Help.html
+%%TKSCANFAXDIR%%/doc/C/Users_Guide.html
+%%TKSCANFAXDIR%%/doc/C/fax-msg.tcl
+%%TKSCANFAXDIR%%/doc/C/scan-msg.tcl
+%%TKSCANFAXDIR%%/doc/ChangeLog
+%%TKSCANFAXDIR%%/doc/INSTALL
+%%TKSCANFAXDIR%%/doc/INSTALL.ja
+%%TKSCANFAXDIR%%/doc/INSTALL1.1
+%%TKSCANFAXDIR%%/doc/INSTALL1.1.ja
+%%TKSCANFAXDIR%%/doc/INSTALL1.1.ja_JP.UTF-8
+%%TKSCANFAXDIR%%/doc/README.ja
+%%TKSCANFAXDIR%%/doc/TRANSLATION
+%%TKSCANFAXDIR%%/doc/efax.rc.sample
+%%TKSCANFAXDIR%%/doc/efax.rc.sample.ja
+%%TKSCANFAXDIR%%/doc/en_US/fax-msg.tcl
+%%TKSCANFAXDIR%%/doc/fax
+%%TKSCANFAXDIR%%/doc/images/download.png
+%%TKSCANFAXDIR%%/doc/images/gfax.png
+%%TKSCANFAXDIR%%/doc/images/jamain2.png
+%%TKSCANFAXDIR%%/doc/images/ref.gif
+%%TKSCANFAXDIR%%/doc/images/shinobas.gif
+%%TKSCANFAXDIR%%/doc/images/tkfax-b.xpm
+%%TKSCANFAXDIR%%/doc/images/tkfax-s.gif
+%%TKSCANFAXDIR%%/doc/images/tkfax-s.png
+%%TKSCANFAXDIR%%/doc/images/tkfax-s.xpm
+%%TKSCANFAXDIR%%/doc/images/tux.gif
+%%TKSCANFAXDIR%%/doc/ja/Config_Help.html
+%%TKSCANFAXDIR%%/doc/ja/Cover_Page_Help.html
+%%TKSCANFAXDIR%%/doc/ja/FAQ.html
+%%TKSCANFAXDIR%%/doc/ja/HTML_Viewer.html
+%%TKSCANFAXDIR%%/doc/ja/Phone_Book_Help.html
+%%TKSCANFAXDIR%%/doc/ja/ToDo-2003-0316.html
+%%TKSCANFAXDIR%%/doc/ja/Users_Guide.html
+%%TKSCANFAXDIR%%/doc/ja/fax-msg.tcl
+%%TKSCANFAXDIR%%/doc/ja/scan-msg.tcl
+%%TKSCANFAXDIR%%/doc/ja_JP.UTF-8/fax-msg.tcl
+%%TKSCANFAXDIR%%/doc/ja_JP.UTF-8/scan-msg.tcl
+%%TKSCANFAXDIR%%/doc/printcap.sample
+%%TKSCANFAXDIR%%/doc/sysreport.sh
+%%TKSCANFAXDIR%%/doc/tkkinput2.sh
+%%TKSCANFAXDIR%%/doc/zh_TW/fax-msg.tcl
+%%TKSCANFAXDIR%%/fax-about.tcl
+%%TKSCANFAXDIR%%/fax-balloon.tcl
+%%TKSCANFAXDIR%%/fax-conf.tcl
+%%TKSCANFAXDIR%%/fax-confwin.tcl
+%%TKSCANFAXDIR%%/fax-faxwin.tcl
+%%TKSCANFAXDIR%%/fax-file.tcl
+%%TKSCANFAXDIR%%/fax-init.tcl
+%%TKSCANFAXDIR%%/fax-lib.tcl
+%%TKSCANFAXDIR%%/fax-logbrowse.tcl
+%%TKSCANFAXDIR%%/fax-mkpg.tcl
+%%TKSCANFAXDIR%%/fax-pbook.tcl
+%%TKSCANFAXDIR%%/fax-queue.tcl
+%%TKSCANFAXDIR%%/fax-received.tcl
+%%TKSCANFAXDIR%%/fax-scan.tcl
+%%TKSCANFAXDIR%%/getfont.tcl
+%%TKSCANFAXDIR%%/html_library.tcl
+%%TKSCANFAXDIR%%/html_viewer.tcl
+%%TKSCANFAXDIR%%/images/hbkim.gif
+%%TKSCANFAXDIR%%/images/tkfax-s.gif
+%%TKSCANFAXDIR%%/scan-about.tcl
+%%TKSCANFAXDIR%%/scan-conf.tcl
+%%TKSCANFAXDIR%%/scan-drivers/epson-ep_scan.tcl
+%%TKSCANFAXDIR%%/scan-drivers/epson-scanimage.tcl
+%%TKSCANFAXDIR%%/scan-drivers/epson.tcl
+%%TKSCANFAXDIR%%/scan-drivers/hp-hpscanpbm.tcl
+%%TKSCANFAXDIR%%/scan-drivers/microtek-mtekscan.tcl
+%%TKSCANFAXDIR%%/scan-drivers/mustek-mscan.tcl
+%%TKSCANFAXDIR%%/scan-drivers/mustek-scanimage.tcl
+%%TKSCANFAXDIR%%/scan-drivers/sharp.tcl
+%%TKSCANFAXDIR%%/scan-drivers/umax.tcl
+%%TKSCANFAXDIR%%/scan-file.tcl
+%%TKSCANFAXDIR%%/scan-init.tcl
+%%TKSCANFAXDIR%%/scan-lib.tcl
+%%TKSCANFAXDIR%%/scan-out.tcl
+%%TKSCANFAXDIR%%/scan-scan.tcl
+%%TKSCANFAXDIR%%/scan-scanwin.tcl
+%%TKSCANFAXDIR%%/scan-win.tcl
+%%TKSCANFAXDIR%%/tex/covermacro-C.tex
+%%TKSCANFAXDIR%%/tex/covermacro-aux.tex
+%%TKSCANFAXDIR%%/tex/covermacro-en.tex
+%%TKSCANFAXDIR%%/tex/covermacro-ja.tex
+%%TKSCANFAXDIR%%/tex/covermacro-kr.tex
+%%TKSCANFAXDIR%%/tkfax
+%%TKSCANFAXDIR%%/tkfax.desktop
+%%TKSCANFAXDIR%%/tkscan
+%%TKSCANFAXDIR%%/tkscan.desktop
+%%TKSCANFAXDIR%%/tkscanfax.spec
+@exec /bin/ln -sf %D/%%TKSCANFAXDIR%%/tkfax %D/bin
+@exec /bin/ln -sf %D/%%TKSCANFAXDIR%%/tkscan %D/bin
@unexec /bin/rm -f %D/bin/tkfax
-@dirrm lib/tkscanfax1/tex
-@dirrm lib/tkscanfax1/scan-drivers
-@dirrm lib/tkscanfax1/images
-@dirrm lib/tkscanfax1/doc/zh_TW
-@dirrm lib/tkscanfax1/doc/ja
-@dirrm lib/tkscanfax1/doc/images
-@dirrm lib/tkscanfax1/doc/C
-@dirrm lib/tkscanfax1/doc
-@dirrm lib/tkscanfax1
+@unexec /bin/rm -f %D/bin/tkscan
+@dirrm %%TKSCANFAXDIR%%/tex
+@dirrm %%TKSCANFAXDIR%%/scan-drivers
+@dirrm %%TKSCANFAXDIR%%/images
+@dirrm %%TKSCANFAXDIR%%/doc/zh_TW
+@dirrm %%TKSCANFAXDIR%%/doc/ja_JP.UTF-8
+@dirrm %%TKSCANFAXDIR%%/doc/ja
+@dirrm %%TKSCANFAXDIR%%/doc/images
+@dirrm %%TKSCANFAXDIR%%/doc/en_US
+@dirrm %%TKSCANFAXDIR%%/doc/C
+@dirrm %%TKSCANFAXDIR%%/doc
+@dirrm %%TKSCANFAXDIR%%