aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2021-01-06 18:32:15 +0000
committerDiane Bruce <db@FreeBSD.org>2021-01-06 18:32:15 +0000
commitb33120aa6dc149b57159ea0cdce9b56401ff6397 (patch)
treed39d70b59cff687c6092619b33a969fa5e022aed /comms
parent87d2eedc6fdd336a3102713c04103f62f36ab2d1 (diff)
downloadports-b33120aa6dc149b57159ea0cdce9b56401ff6397.tar.gz
ports-b33120aa6dc149b57159ea0cdce9b56401ff6397.zip
fixes octave paths and adds debug that is enabled by default
PR: ports/252350 Submitted by: pcc <pcc@gmx.net>
Notes
Notes: svn path=/head/; revision=560544
Diffstat (limited to 'comms')
-rw-r--r--comms/limesuite/Makefile27
-rw-r--r--comms/limesuite/pkg-plist4
2 files changed, 21 insertions, 10 deletions
diff --git a/comms/limesuite/Makefile b/comms/limesuite/Makefile
index 82217077347c..a1bf6c8bb34c 100644
--- a/comms/limesuite/Makefile
+++ b/comms/limesuite/Makefile
@@ -3,6 +3,7 @@
PORTNAME= limesuite
DISTVERSIONPREFIX= v
DISTVERSION= 20.10.0
+PORTREVISION= 1
CATEGORIES= comms astro hamradio
MAINTAINER= tomek@cedro.info
@@ -34,8 +35,8 @@ CMAKE_ON= ENABLE_LIBRARY \
ENABLE_LIMERFE \
ENABLE_EVB7COM
-OPTIONS_DEFINE= DOCS GUI QUICKTEST OCTAVE REMOTE SOAPYSDR
-OPTIONS_DEFAULT= GUI QUICKTEST SOAPYSDR
+OPTIONS_DEFINE= DOCS GUI QUICKTEST OCTAVE REMOTE SOAPYSDR DEBUG
+OPTIONS_DEFAULT= GUI QUICKTEST SOAPYSDR DEBUG
OPTIONS_UNSET= DOCS
OPTIONS_SUB= yes
QUICKTEST_DESC= Build QuickTest Self-Test suite
@@ -55,7 +56,6 @@ QUICKTEST_LIB_DEPENDS= libfltk.so:x11-toolkits/fltk
OCTAVE_CMAKE_BOOL= ENABLE_OCTAVE
OCTAVE_BUILD_DEPENDS= octave:math/octave
-PLIST_SUB+= OCTAVE_VERSION=${OCTAVE_VERSION}
REMOTE_CMAKE_BOOL= ENABLE_REMOTE
@@ -66,13 +66,25 @@ SOAPYSDR_LIB_DEPENDS= libSoapySDR.so:misc/soapysdr
.if ${PORT_OPTIONS:MGUI}
USES+= gl xorg
-USE_XORG= x11 ice sm xcursor xext xfixes xinerama xft xrender
-USE_GL= gl glu
-USE_WX= 3.1
-WX_COMPS= wx:lib
+USE_XORG+= x11 ice sm xcursor xext xfixes xinerama xft xrender
+USE_GL+= gl glu
+USE_WX+= 3.1
+WX_COMPS+= wx:lib
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig
.endif
+.if ${PORT_OPTIONS:MOCTAVE}
+.include "${.CURDIR}/../../math/octave/Makefile.version"
+OCTAVE_OCT_SITE_DIR= "lib/octave/${OCTAVE_VERSION}/site/oct/${CONFIGURE_TARGET}/"
+PLIST_SUB+= OCTAVE_OCT_SITE_DIR=${OCTAVE_OCT_SITE_DIR}
+OCTAVE_M_SITE_DIR= "share/octave/${OCTAVE_VERSION}/site/m/"
+PLIST_SUB+= OCTAVE_M_SITE_DIR=${OCTAVE_M_SITE_DIR}
+.endif
+
+.if ${PORT_OPTIONS:MDEBUG}
+WITH_DEBUG= yes
+.endif
+
post-build:
# N.B. COPYTREE_BIN here chmods 555 which breaks CMAKE_INSTALL in user mode!
(cd ${BUILD_WRKSRC}/bin && ${COPYTREE_BIN} . ${STAGEDIR}${PREFIX}/bin)
@@ -89,5 +101,4 @@ post-build:
(cd ${WRKSRC}/Desktop && ${CP} lime-suite.desktop ${STAGEDIR}${PREFIX}/share/applications/)
.endif
-.include "../../math/octave/Makefile.version"
.include <bsd.port.post.mk>
diff --git a/comms/limesuite/pkg-plist b/comms/limesuite/pkg-plist
index bb08ab318c2f..6124a4064ab4 100644
--- a/comms/limesuite/pkg-plist
+++ b/comms/limesuite/pkg-plist
@@ -48,8 +48,8 @@ libdata/pkgconfig/LimeSuite.pc
%%GUI%%share/pixmaps/lime-suite-48.png
%%GUI%%share/pixmaps/lime-suite-64.png
%%QUICKTEST%%bin/LimeQuickTest
-%%OCTAVE%%lib/octave/%%OCTAVE_VERSION%%/site/oct/%%CONFIGURE_TARGET%%/LimeSuite.oct
-%%OCTAVE%%share/octave/%%OCTAVE_VERSION%%/site/m/LoadLimeSuite.m
+%%OCTAVE%%%%OCTAVE_OCT_SITE_DIR%%LimeSuite.oct
+%%OCTAVE%%%%OCTAVE_M_SITE_DIR%%LoadLimeSuite.m
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/_lime_suite_8h.html
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/_lime_suite_8h.js
%%PORTDOCS%%%%DOCSDIR%%/LMS_API_Documentation/_lime_suite_8h_source.html