aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2013-03-14 18:49:15 +0000
committerDiane Bruce <db@FreeBSD.org>2013-03-14 18:49:15 +0000
commit08a68082fc13655c5b5fa2f36611657d77e3a64f (patch)
tree480af55bb11b35b6a99ead159c3ae518713a1b2e /comms
parent76f6847646d44fa310012b21a123f2ae315b7ffe (diff)
downloadports-08a68082fc13655c5b5fa2f36611657d77e3a64f.tar.gz
ports-08a68082fc13655c5b5fa2f36611657d77e3a64f.zip
Notes
Diffstat (limited to 'comms')
-rw-r--r--comms/Makefile1
-rw-r--r--comms/ebook2cwgui/Makefile41
-rw-r--r--comms/ebook2cwgui/distinfo2
-rw-r--r--comms/ebook2cwgui/pkg-descr6
4 files changed, 50 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 043f7837eaa7..5c75f7d2cc2e 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -29,6 +29,7 @@
SUBDIR += dfu-programmer
SUBDIR += dfu-util
SUBDIR += ebook2cw
+ SUBDIR += ebook2cwgui
SUBDIR += echolinux
SUBDIR += efax
SUBDIR += efax-gtk
diff --git a/comms/ebook2cwgui/Makefile b/comms/ebook2cwgui/Makefile
new file mode 100644
index 000000000000..06c71ff1f072
--- /dev/null
+++ b/comms/ebook2cwgui/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+#
+
+PORTNAME= ebook2cwgui
+PORTVERSION= 0.1.2
+CATEGORIES= comms hamradio
+MASTER_SITES= http://fkurz.net/ham/ebook2cw/ \
+ http://distfiles.bsdjunk.com/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= db@FreeBSD.org
+COMMENT= WxWidgets front end for ebooks2cw
+
+RUN_DEPENDS= ebook2cw:${PORTSDIR}/comms/ebook2cw
+
+MAN1= ebook2cwgui.1
+
+USE_WX= yes
+
+PLIST_FILES= bin/ebook2cwgui
+PORTDOCS= *
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG:S,${PREFIX}/bin/,,}|g' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
+ -e 's|g++|${CXX}|g' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/ebook2cwgui ${PREFIX}/bin/ebook2cwgui
+ @${INSTALL_DATA} ${WRKSRC}/ebook2cwgui.1 ${MANPREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in README COPYING ChangeLog
+ @${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}/$f
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/comms/ebook2cwgui/distinfo b/comms/ebook2cwgui/distinfo
new file mode 100644
index 000000000000..b6ba2f71b31b
--- /dev/null
+++ b/comms/ebook2cwgui/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ebook2cwgui-0.1.2.tar.gz) = 211c5593f65743d33c5fb3ce98b118592a7b15c8b807fde34a10660d6ff0812c
+SIZE (ebook2cwgui-0.1.2.tar.gz) = 15661
diff --git a/comms/ebook2cwgui/pkg-descr b/comms/ebook2cwgui/pkg-descr
new file mode 100644
index 000000000000..cf8924970726
--- /dev/null
+++ b/comms/ebook2cwgui/pkg-descr
@@ -0,0 +1,6 @@
+ebook2cwgui is a GUI front end for ebook2cw created in WxWidgets with
+support for both Linux and Windows.
+
+Written by Fabian Kurz, DJ1YFK <mail@fkurz.net>
+
+WWW: http://fkurz.net/ham/ebook2cw.html#graphicaluserinterface